]> git.pld-linux.org Git - packages/dnprogs.git/blob - dnprogs.spec
- cleanups, separated -libs/-devel/-static
[packages/dnprogs.git] / dnprogs.spec
1 %define dnet_major 1
2 %define dnet_version %{dnet_major}.2
3 %define dap_major 2
4 %define dap_version %{dap_major}.23
5 %define dnprogs_version %{dap_version}
6 Summary:        DECnet tools and libraries
7 Summary(pl.UTF-8):      Narzędzia i biblioteki DECnet
8 Name:           dnprogs
9 Version:        %{dnprogs_version}
10 Release:        0.1
11 License:        GPL
12 Group:          Networking/Utilities
13 Source0:        http://downloads.sourceforge.net/linux-decnet/%{name}-%{version}.tar.gz
14 # Source0-md5:  666e1479f60f7f0fe3bf8da3abab98bd
15 URL:            http://linux-decnet.sourceforge.net/
16 Requires(post,preun):   /sbin/chkconfig
17 Requires(post): /sbin/ldconfig
18 Requires:       %{name}-libs = %{version}-%{release}
19 Requires:       rc-scripts
20 ExclusiveOS:    Linux
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 DECnet programs for Linux.
25
26 These tools are the application layer interface for DECnet on Linux
27 systems. They provide file/terminal access facilities between OpenVMS
28 and Linux and remote execution of commands.
29
30 To use them you will need to have DECnet built into your kernel. See
31 <http://linux.dreamtime.org/decnet/> to get the kernel patch and
32 instructions on how to apply it.
33
34 %description -l pl.UTF-8
35 Programy DECnet dla Linuksa.
36
37 Narzędzia te stanowią interfejs warstwy aplikacji dla DECnetu na
38 systemach linuksowych. Zawierają elementy zapewniające dostęp
39 terminalowy i plikowy między OpenVMS-em a Linuksem oraz zdalne
40 wykonywanie poleceń.
41
42 Aby ich użyć trzeba mieć wbudowaną w jądro obsługę DECnetu. Łatę oraz
43 instrukcje dotyczące jej instalacji można znaleźć na stronie:
44 <http://linux.dreamtime.org/decnet/>.
45
46 %package libs
47 Summary:        DECnet shared libraries
48 Summary(pl.UTF-8):      Biblioteki współdzielone DECnet
49 Group:          Libraries
50
51 %description libs
52 DECnet shared libraries.
53
54 %description libs -l pl.UTF-8
55 Biblioteki współdzielone DECnet.
56
57 %package devel
58 Summary:        Header files for DECnet libraries
59 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DECnet
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62
63 %description devel
64 Header files for DECnet libraries.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe bibliotek DECnet.
68
69 %package static
70 Summary:        Static DECnet libraries
71 Summary(pl.UTF-8):      Statyczne biblioteki DECnet
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static DECnet libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki DECnet.
80
81 %prep
82 %setup -q
83
84 find . -type f -name '*~' -print0 | xargs -0 rm -f
85
86 %build
87 %{__make} \
88         DFLAGS="%{rpmcflags}" \
89         LIBCRYPT=-lcrypt \
90         SHADOWDEFS=-DSHADOW_PWD \
91         prefix=%{_prefix} \
92         libprefix=%{_prefix} \
93         sysconfprefix=
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,%{_lib},sbin}
98 %{__make} install \
99         prefix=$RPM_BUILD_ROOT%{_prefix} \
100         libprefix=$RPM_BUILD_ROOT%{_prefix} \
101         sysconfprefix=$RPM_BUILD_ROOT
102
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdnet.so
104 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
105 mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
106         $RPM_BUILD_ROOT/%{_lib}
107 ln -sf libdnet.so.%{dnet_version} \
108         $RPM_BUILD_ROOT/%{_lib}/libdnet.so.%{dnet_major}
109 ln -sf /%{_lib}/libdnet.so.%{dnet_major} \
110         $RPM_BUILD_ROOT%{_libdir}/libdnet.so
111
112 mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
113
114 touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
115
116 install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post
122 /sbin/chkconfig --add decnet
123
124 %postun
125 if [ "$1" = "0" ]; then
126         /sbin/chkconfig --del decnet
127 fi
128
129 %post   libs -p /sbin/ldconfig
130 %postun libs -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc Documentation/* README NEWS dnprogs.lsm
135 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.conf
136 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
137 %attr(754,root,root) /etc/rc.d/init.d/decnet
138 %attr(755,root,root) /sbin/startnet
139 %attr(755,root,root) %{_bindir}/dncopy
140 %attr(755,root,root) %{_bindir}/dndel
141 %attr(755,root,root) %{_bindir}/dndir
142 %attr(755,root,root) %{_bindir}/dnping
143 %attr(755,root,root) %{_bindir}/dnprint
144 %attr(755,root,root) %{_bindir}/dnsubmit
145 %attr(755,root,root) %{_bindir}/dntask
146 %attr(755,root,root) %{_bindir}/dntype
147 %attr(755,root,root) %{_bindir}/phone
148 %attr(755,root,root) %{_bindir}/sethost
149 %attr(755,root,root) %{_sbindir}/ctermd
150 %attr(755,root,root) %{_sbindir}/dnmirror
151 %attr(755,root,root) %{_sbindir}/fal
152 %attr(755,root,root) %{_sbindir}/phoned
153 %attr(755,root,root) %{_sbindir}/sendvmsmail
154 %attr(755,root,root) %{_sbindir}/vmsmaild
155 %{_mandir}/man1/ctermd.1*
156 %{_mandir}/man1/dncopy.1*
157 %{_mandir}/man1/dndel.1*
158 %{_mandir}/man1/dndir.1*
159 %{_mandir}/man1/dnmirror.1*
160 #%%{_mandir}/man1/dnmount.1*
161 %{_mandir}/man1/dnping.1*
162 %{_mandir}/man1/dnprint.1*
163 %{_mandir}/man1/dnsubmit.1*
164 %{_mandir}/man1/dntask.1*
165 %{_mandir}/man1/dntype.1*
166 %{_mandir}/man1/phone.1*
167 %{_mandir}/man1/sethost.1*
168 %{_mandir}/man1/startnet.1*
169 %{_mandir}/man3/setnodeent.3*
170 %{_mandir}/man5/decnet.conf.5*
171 %{_mandir}/man5/decnet.proxy.5*
172 %{_mandir}/man8/fal.8*
173 %{_mandir}/man8/phoned.8*
174
175 %files libs
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_major}
178 %attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
179 %attr(755,root,root) /lib/libdnet.so.%{dnet_version}
180 %attr(755,root,root) /lib/libdnet.so.%{dnet_major}
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libdap.so
185 %attr(755,root,root) %{_libdir}/libdnet.so
186 %{_includedir}/netdnet
187 %{_mandir}/man3/dnet_addr.3*
188 %{_mandir}/man3/dnet_conn.3*
189 %{_mandir}/man3/dnet_htoa.3*
190 %{_mandir}/man3/dnet_ntoa.3*
191 %{_mandir}/man3/getnodeadd.3*
192 %{_mandir}/man3/getnodebyaddr.3*
193 %{_mandir}/man3/getnodebyname.3*
194 %{_mandir}/man3/libdnet.3*
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libdnet.a
199 %{_libdir}/libdap.a
This page took 0.081793 seconds and 3 git commands to generate.