]> git.pld-linux.org Git - packages/dnprogs.git/blame - dnprogs.spec
- cleanups, separated -libs/-devel/-static
[packages/dnprogs.git] / dnprogs.spec
CommitLineData
19c3276c 1%define dnet_major 1
2%define dnet_version %{dnet_major}.2
e4deb272 3%define dap_major 2
4%define dap_version %{dap_major}.23
19c3276c 5%define dnprogs_version %{dap_version}
239180c6 6Summary: DECnet tools and libraries
21bb81d2 7Summary(pl.UTF-8): Narzędzia i biblioteki DECnet
239180c6 8Name: dnprogs
42ec118e 9Version: %{dnprogs_version}
e4deb272 10Release: 0.1
42ec118e 11License: GPL
12Group: Networking/Utilities
a613ea97 13Source0: http://downloads.sourceforge.net/linux-decnet/%{name}-%{version}.tar.gz
e4deb272 14# Source0-md5: 666e1479f60f7f0fe3bf8da3abab98bd
c6ef0d68 15URL: http://linux-decnet.sourceforge.net/
c6ef0d68
JB
16Requires(post,preun): /sbin/chkconfig
17Requires(post): /sbin/ldconfig
a613ea97
JB
18Requires: %{name}-libs = %{version}-%{release}
19Requires: rc-scripts
239180c6 20ExclusiveOS: Linux
c25b4b72 21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19c3276c 22
23%description
24DECnet programs for Linux.
25
42ec118e 26These tools are the application layer interface for DECnet on Linux
27systems. They provide file/terminal access facilities between OpenVMS
28and Linux and remote execution of commands.
19c3276c 29
42ec118e 30To use them you will need to have DECnet built into your kernel. See
a613ea97 31<http://linux.dreamtime.org/decnet/> to get the kernel patch and
19c3276c 32instructions on how to apply it.
8c74f4ce 33
1f826f11 34%description -l pl.UTF-8
a613ea97
JB
35Programy DECnet dla Linuksa.
36
37Narzędzia te stanowią interfejs warstwy aplikacji dla DECnetu na
38systemach linuksowych. Zawierają elementy zapewniające dostęp
39terminalowy i plikowy między OpenVMS-em a Linuksem oraz zdalne
40wykonywanie poleceń.
41
42Aby ich użyć trzeba mieć wbudowaną w jądro obsługę DECnetu. Łatę oraz
43instrukcje dotyczące jej instalacji można znaleźć na stronie:
44<http://linux.dreamtime.org/decnet/>.
45
46%package libs
47Summary: DECnet shared libraries
48Summary(pl.UTF-8): Biblioteki współdzielone DECnet
49Group: Libraries
50
51%description libs
52DECnet shared libraries.
53
54%description libs -l pl.UTF-8
55Biblioteki współdzielone DECnet.
56
57%package devel
58Summary: Header files for DECnet libraries
59Summary(pl.UTF-8): Pliki nagłówkowe bibliotek DECnet
60Group: Development/Libraries
61Requires: %{name}-libs = %{version}-%{release}
62
63%description devel
64Header files for DECnet libraries.
65
66%description devel -l pl.UTF-8
67Pliki nagłówkowe bibliotek DECnet.
68
69%package static
70Summary: Static DECnet libraries
71Summary(pl.UTF-8): Statyczne biblioteki DECnet
72Group: Development/Libraries
73Requires: %{name}-devel = %{version}-%{release}
74
75%description static
76Static DECnet libraries.
77
78%description static -l pl.UTF-8
79Statyczne biblioteki DECnet.
a4726999 80
8c74f4ce 81%prep
42ec118e 82%setup -q
8c74f4ce
AM
83
84find . -type f -name '*~' -print0 | xargs -0 rm -f
85
86%build
a613ea97
JB
87%{__make} \
88 DFLAGS="%{rpmcflags}" \
89 LIBCRYPT=-lcrypt \
90 SHADOWDEFS=-DSHADOW_PWD \
91 prefix=%{_prefix} \
92 libprefix=%{_prefix} \
93 sysconfprefix=
8c74f4ce
AM
94
95%install
96rm -rf $RPM_BUILD_ROOT
a613ea97
JB
97install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,%{_lib},sbin}
98%{__make} install \
99 prefix=$RPM_BUILD_ROOT%{_prefix} \
100 libprefix=$RPM_BUILD_ROOT%{_prefix} \
101 sysconfprefix=$RPM_BUILD_ROOT
102
103%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdnet.so
104%{__rm} $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
8c74f4ce 105mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
a613ea97 106 $RPM_BUILD_ROOT/%{_lib}
33085a3a 107ln -sf libdnet.so.%{dnet_version} \
a613ea97
JB
108 $RPM_BUILD_ROOT/%{_lib}/libdnet.so.%{dnet_major}
109ln -sf /%{_lib}/libdnet.so.%{dnet_major} \
8c74f4ce
AM
110 $RPM_BUILD_ROOT%{_libdir}/libdnet.so
111
112mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
113
42ec118e 114touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
8c74f4ce 115
42ec118e 116install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
8c74f4ce
AM
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
567d906b 121%post
405c370d 122/sbin/chkconfig --add decnet
8c74f4ce
AM
123
124%postun
c6ef0d68
JB
125if [ "$1" = "0" ]; then
126 /sbin/chkconfig --del decnet
405c370d 127fi
8c74f4ce 128
a613ea97
JB
129%post libs -p /sbin/ldconfig
130%postun libs -p /sbin/ldconfig
c6ef0d68 131
8c74f4ce
AM
132%files
133%defattr(644,root,root,755)
134%doc Documentation/* README NEWS dnprogs.lsm
a613ea97 135%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.conf
42ec118e 136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
eae33582 137%attr(754,root,root) /etc/rc.d/init.d/decnet
8c74f4ce 138%attr(755,root,root) /sbin/startnet
8c74f4ce
AM
139%attr(755,root,root) %{_bindir}/dncopy
140%attr(755,root,root) %{_bindir}/dndel
141%attr(755,root,root) %{_bindir}/dndir
142%attr(755,root,root) %{_bindir}/dnping
239180c6 143%attr(755,root,root) %{_bindir}/dnprint
8c74f4ce
AM
144%attr(755,root,root) %{_bindir}/dnsubmit
145%attr(755,root,root) %{_bindir}/dntask
239180c6 146%attr(755,root,root) %{_bindir}/dntype
8c74f4ce
AM
147%attr(755,root,root) %{_bindir}/phone
148%attr(755,root,root) %{_bindir}/sethost
a613ea97
JB
149%attr(755,root,root) %{_sbindir}/ctermd
150%attr(755,root,root) %{_sbindir}/dnmirror
151%attr(755,root,root) %{_sbindir}/fal
152%attr(755,root,root) %{_sbindir}/phoned
153%attr(755,root,root) %{_sbindir}/sendvmsmail
154%attr(755,root,root) %{_sbindir}/vmsmaild
33085a3a
JB
155%{_mandir}/man1/ctermd.1*
156%{_mandir}/man1/dncopy.1*
157%{_mandir}/man1/dndel.1*
158%{_mandir}/man1/dndir.1*
159%{_mandir}/man1/dnmirror.1*
8583d5f0 160#%%{_mandir}/man1/dnmount.1*
33085a3a
JB
161%{_mandir}/man1/dnping.1*
162%{_mandir}/man1/dnprint.1*
163%{_mandir}/man1/dnsubmit.1*
164%{_mandir}/man1/dntask.1*
165%{_mandir}/man1/dntype.1*
166%{_mandir}/man1/phone.1*
167%{_mandir}/man1/sethost.1*
168%{_mandir}/man1/startnet.1*
a613ea97
JB
169%{_mandir}/man3/setnodeent.3*
170%{_mandir}/man5/decnet.conf.5*
171%{_mandir}/man5/decnet.proxy.5*
172%{_mandir}/man8/fal.8*
173%{_mandir}/man8/phoned.8*
174
175%files libs
176%defattr(644,root,root,755)
177%attr(755,root,root) %{_libdir}/libdap.so.%{dap_major}
178%attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
179%attr(755,root,root) /lib/libdnet.so.%{dnet_version}
180%attr(755,root,root) /lib/libdnet.so.%{dnet_major}
181
182%files devel
183%defattr(644,root,root,755)
184%attr(755,root,root) %{_libdir}/libdap.so
185%attr(755,root,root) %{_libdir}/libdnet.so
186%{_includedir}/netdnet
33085a3a
JB
187%{_mandir}/man3/dnet_addr.3*
188%{_mandir}/man3/dnet_conn.3*
189%{_mandir}/man3/dnet_htoa.3*
190%{_mandir}/man3/dnet_ntoa.3*
191%{_mandir}/man3/getnodeadd.3*
192%{_mandir}/man3/getnodebyaddr.3*
193%{_mandir}/man3/getnodebyname.3*
194%{_mandir}/man3/libdnet.3*
a613ea97
JB
195
196%files static
197%defattr(644,root,root,755)
198%{_libdir}/libdnet.a
199%{_libdir}/libdap.a
This page took 0.129828 seconds and 4 git commands to generate.