]> git.pld-linux.org Git - packages/ding-libs.git/blob - ding-libs.spec
- Import from Fedora
[packages/ding-libs.git] / ding-libs.spec
1 Summary:        "Ding is not GLib" assorted utility libraries
2 Name:           ding-libs
3 Version:        0.1.3
4 Release:        5%{?dist}
5 License:        LGPLv3+
6 Group:          Development/Libraries
7 URL:            http://fedorahosted.org/sssd/
8 Source0:        http://fedorahosted.org/releases/d/i/ding-libs/%{name}-%{version}.tar.gz
9 # Source0-md5:  b4f5e03b0b1bd0ab765902a7a466f749
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %global path_utils_version 0.2.1
13 %global dhash_version 0.4.3
14 %global collection_version 0.6.1
15 %global ref_array_version 0.1.2
16 %global ini_config_version 0.6.2
17
18 ### Patches ###
19
20 ### Dependencies ###
21
22 ### Build Dependencies ###
23
24 BuildRequires:  autoconf
25 BuildRequires:  automake
26 BuildRequires:  check-devel
27 BuildRequires:  doxygen
28 BuildRequires:  libtool
29 BuildRequires:  m4
30
31 %description
32 A set of helpful libraries used by projects such as SSSD.
33
34
35 ##############################################################################
36 # Path Utils
37 ##############################################################################
38
39 %package -n libpath_utils
40 Summary:        Filesystem Path Utilities
41 Version:        %{path_utils_version}
42 License:        LGPLv3+
43 Group:          Development/Libraries
44
45 %description -n libpath_utils
46 Utility functions to manipulate filesystem pathnames
47
48 %package -n libpath_utils-devel
49 Summary:        Development files for libpath_utils
50 Version:        %{path_utils_version}
51 License:        LGPLv3+
52 Group:          Development/Libraries
53 Requires:       libpath_utils = %{path_utils_version}-%{release}
54
55 %description -n libpath_utils-devel
56 Utility functions to manipulate filesystem pathnames
57
58 %post -n libpath_utils -p /sbin/ldconfig
59 %postun -n libpath_utils -p /sbin/ldconfig
60
61 %files -n libpath_utils
62 %defattr(644,root,root,755)
63 %doc COPYING COPYING.LESSER
64 %attr(755,root,root) %{_libdir}/libpath_utils.so.*
65
66 %files -n libpath_utils-devel
67 %defattr(644,root,root,755)
68 %{_includedir}/path_utils.h
69 %{_libdir}/libpath_utils.so
70 %{_pkgconfigdir}/path_utils.pc
71 %doc path_utils/README.path_utils
72 %doc path_utils/doc/html/
73
74
75 ##############################################################################
76 # dhash
77 ##############################################################################
78
79 %package -n libdhash
80 Summary:        Dynamic hash table
81 Version:        %{dhash_version}
82 License:        LGPLv3+
83 Group:          Development/Libraries
84
85 %description -n libdhash
86 A hash table which will dynamically resize to achieve optimal storage
87 & access time properties
88
89 %package -n libdhash-devel
90 Summary:        Development files for libdhash
91 Version:        %{dhash_version}
92 License:        LGPLv3+
93 Group:          Development/Libraries
94 Requires:       libdhash = %{dhash_version}-%{release}
95
96 %description -n libdhash-devel
97 A hash table which will dynamically resize to achieve optimal storage
98 & access time properties
99
100 %post -n libdhash -p /sbin/ldconfig
101 %postun -n libdhash -p /sbin/ldconfig
102
103 %files -n libdhash
104 %defattr(644,root,root,755)
105 %doc COPYING COPYING.LESSER
106 %attr(755,root,root) %{_libdir}/libdhash.so.*
107
108 %files -n libdhash-devel
109 %defattr(644,root,root,755)
110 %{_includedir}/dhash.h
111 %{_libdir}/libdhash.so
112 %{_pkgconfigdir}/dhash.pc
113 %doc dhash/README.dhash
114 %doc dhash/examples/
115
116
117 ##############################################################################
118 # collection
119 ##############################################################################
120 %package -n libcollection
121 Summary:        Collection data-type for C
122 Version:        %{collection_version}
123 License:        LGPLv3+
124 Group:          Development/Libraries
125
126 %description -n libcollection
127 A data-type to collect data in a hierarchical structure for easy
128 iteration and serialization
129
130 %package -n libcollection-devel
131 Summary:        Development files for libcollection
132 Version:        %{collection_version}
133 License:        LGPLv3+
134 Group:          Development/Libraries
135 Requires:       libcollection = %{collection_version}-%{release}
136
137 %description -n libcollection-devel
138 A data-type to collect data in a hierarchical structure for easy
139 iteration and serialization
140
141 %post -n libcollection -p /sbin/ldconfig
142 %postun -n libcollection -p /sbin/ldconfig
143
144
145 %files -n libcollection
146 %defattr(644,root,root,755)
147 %doc COPYING
148 %doc COPYING.LESSER
149 %attr(755,root,root) %{_libdir}/libcollection.so.*
150
151 %files -n libcollection-devel
152 %defattr(644,root,root,755)
153 %{_includedir}/collection.h
154 %{_includedir}/collection_tools.h
155 %{_includedir}/collection_queue.h
156 %{_includedir}/collection_stack.h
157 %{_libdir}/libcollection.so
158 %{_pkgconfigdir}/collection.pc
159 %doc collection/doc/html/
160
161
162 ##############################################################################
163 # ref_array
164 ##############################################################################
165
166 %package -n libref_array
167 Summary:        A refcounted array for C
168 Version:        %{ref_array_version}
169 License:        LGPLv3+
170 Group:          Development/Libraries
171
172 %description -n libref_array
173 A dynamically-growing, reference-counted array
174
175 %package -n libref_array-devel
176 Summary:        Development files for libref_array
177 Version:        %{ref_array_version}
178 License:        LGPLv3+
179 Group:          Development/Libraries
180 Requires:       libref_array = %{ref_array_version}-%{release}
181
182 %description -n libref_array-devel
183 A dynamically-growing, reference-counted array
184
185 %post -n libref_array -p /sbin/ldconfig
186 %postun -n libref_array -p /sbin/ldconfig
187
188 %files -n libref_array
189 %defattr(644,root,root,755)
190 %doc COPYING
191 %doc COPYING.LESSER
192 %attr(755,root,root) %{_libdir}/libref_array.so.*
193
194 %files -n libref_array-devel
195 %defattr(644,root,root,755)
196 %{_includedir}/ref_array.h
197 %{_libdir}/libref_array.so
198 %{_pkgconfigdir}/ref_array.pc
199 %doc refarray/README.ref_array
200 %doc refarray/doc/html/
201
202
203 ##############################################################################
204 # ini_config
205 ##############################################################################
206
207 %package -n libini_config
208 Summary:        INI file parser for C
209 Version:        %{ini_config_version}
210 License:        LGPLv3+
211 Group:          Development/Libraries
212
213 %description -n libini_config
214 Library to process config files in INI format into a libcollection
215 data structure
216
217 %package -n libini_config-devel
218 Summary:        Development files for libini_config
219 Version:        %{ini_config_version}
220 License:        LGPLv3+
221 Group:          Development/Libraries
222 Requires:       libini_config = %{ini_config_version}-%{release}
223
224 %description -n libini_config-devel
225 Library to process config files in INI format into a libcollection
226 data structure
227
228 %post -n libini_config -p /sbin/ldconfig
229 %postun -n libini_config -p /sbin/ldconfig
230
231 %files -n libini_config
232 %defattr(644,root,root,755)
233 %doc COPYING
234 %doc COPYING.LESSER
235 %attr(755,root,root) %{_libdir}/libini_config.so.*
236
237 %files -n libini_config-devel
238 %defattr(644,root,root,755)
239 %{_includedir}/ini_config.h
240 %{_libdir}/libini_config.so
241 %{_pkgconfigdir}/ini_config.pc
242 %doc ini/doc/html/
243
244
245 ##############################################################################
246 # Build steps
247 ##############################################################################
248
249 %prep
250 %setup -q
251
252 %build
253 %configure \
254         --disable-static
255
256 %{__make} %{?_smp_mflags} all docs
257
258 %check
259 make %{?_smp_mflags} check
260
261 %install
262 rm -rf $RPM_BUILD_ROOT
263
264 %{__make} install DESTDIR=$RPM_BUILD_ROOT
265
266 # Remove .la files created by libtool
267 rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
268
269 # Remove the example files from the output directory
270 # We will copy them directly from the source directory
271 # for packaging
272 rm -f \
273     $RPM_BUILD_ROOT%{_docdir}/ding-libs/README.* \
274     $RPM_BUILD_ROOT%{_docdir}/ding-libs/examples/dhash_example.c \
275     $RPM_BUILD_ROOT%{_docdir}/ding-libs/examples/dhash_test.c
276
277 # Remove document install script. RPM is handling this
278 rm -f */doc/html/installdox
279
280 %clean
281 rm -rf $RPM_BUILD_ROOT
This page took 0.081966 seconds and 3 git commands to generate.