]> git.pld-linux.org Git - packages/dhcpcd.git/blob - dhcpcd.spec
510aee2e40205bdca26c894afa82007b dhcpcd-pid_path_fix.patch
[packages/dhcpcd.git] / dhcpcd.spec
1 %define ver     1.3.22-pl1
2 Summary:        DHCP Client Daemon
3 Summary(de):    DHCPC-Dämon
4 Summary(es):    Servidor DHCPC
5 Summary(fr):    Démon DHCPC
6 Summary(pl):    Klient (daemon) DHCP
7 Summary(pt_BR): Servidor DHCPC
8 Summary(tr):    DHCPC sunucu süreçi (daemon)
9 Name:           dhcpcd
10 Version:        %(echo %{ver} | sed -e "s#-##")
11 Release:        11
12 License:        GPL v2
13 Vendor:         Sergei Viznyuk <sv@phystech.com>
14 Group:          Networking/Daemons
15 Source0:        http://www.phystech.com/ftp/%{name}-%{ver}.tar.gz
16 Patch0:         %{name}-configure.patch
17 Patch1:         %{name}-ntpdrift-66136.patch
18 Patch2:         %{name}-noMoFakery.patch
19 Patch3:         %{name}-noNISfakery.patch
20 Patch4:         %{name}-pid_path_fix.patch
21 BuildRequires:  automake
22 BuildRequires:  autoconf
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define _sbindir        /sbin
26
27 %description
28 dhcpcd is an implementation of the DHCP client specified in
29 draft-ietf-dhc-dhcp-09 (when -r option is not specified) and RFC1541
30 (when -r option is specified).
31
32 It gets the host information (IP address, netmask, broadcast address,
33 etc.) from a DHCP server and configures the network interface of the
34 machine on which it is running. It also tries to renew the lease time
35 according to RFC1541 or draft-ietf-dhc-dhcp-09.
36
37 %description -l de
38 dhcpcd ist eine Implementierung des DHCP-Client, spezifiziert in
39 draft-ietf-dhc-dhcp-09 (wenn -r option nicht angegeben) und RFC1541
40 (wenn -r option angegeben).
41
42 Es bezieht die Host-Infos (IP-Adresse, Netmask, Broadcast-Adresse,
43 usw.) von einem DHCP-Server und konfiguriert die Netzschnittstelle des
44 Computers, auf dem es läuft Es versucht, die Verleihzeit gemäß RFC1541
45 bzw. draft-ietf-dhc-dhcp-09 zu verlängern.
46
47 %description -l es
48 dhcpcd es una implementación del cliente DHCP especificado en
49 draft-ietf-dhc-dhcp-09 (cuando la opción -r no está especificada) y
50 RFC1541 (cuando la opción -r está especificada). Captura la
51 información del host (dirección IP, máscara de red, dirección de
52 broadcast, etc.) de un servidor DHCP y configura la interface de red
53 de la máquina donde esté ejecutando. También intenta renovar el tiempo
54 de alquiler de los direcciones de acuerdo con RFC1541 o
55 draft-ietf-dhc-dhcp-09.
56
57 %description -l fr
58 dhcpcd est une implantation du client DHCP spécifié dans les
59 draft-ietf-dhc-dhcp-09 (sans l'option -r) et RFC1541 (avec l'option -r).
60
61 Il obtient l'information sur l'hôte (adresse IP, masque réseau,
62 adresse de diffusion, etc.) à partir d'un serveur DHCP et configure
63 l'interface réseau de la machine sur laquelle il tourne. Il essaie
64 aussi de renouveler le « lease time » selon les RFC1541 ou
65 draft-ietf-dhc-dhcp-09.
66
67 %description -l pl
68 dhcpd jest implementacja klienta DHCP, opisan± w
69 draft-ietf-dhc-dhcp-09 (kiedy nie podaje siê opcji -r) oraz RFC1544
70 (kiedy podaje siê opcjê -r).
71
72 Pobiera on informacjê o komputerze (adres IP, maska sieci, adres
73 rozg³oszeniowy itd.) i konfiguruje interfejs sieciowy maszyny, na
74 której jest uruchomiony. Próbuje równie¿ od¶wiezyæ czas przestoju
75 zgodnie z RFC1541 oraz draft-ietf-dhc-dhcp-09.
76
77 %description -l pt_BR
78 dhcpcd é uma implementação do cliente DHCP especificado em
79 draft-ietf-dhc-dhcp-09 (quando a opção -r não é especificada) e
80 RFC1541 (quando a opção -r é especificada). Ele captura a informação
81 do host (endereço IP, máscara de rede, endereço de broadcast, etc.) de
82 um servidor DHCP e configura a interface de rede da máquina em que
83 está rodando. Ele também tenta renovar o tempo de aluguel dos
84 endereços de acordo com RFC1541 ou draft-ietf-dhc-dhcp-09.
85
86 %description -l tr
87 Makina bilgilerini (IP adresi, að maskesi, yayýn adresi, vb.) bir DHCP
88 sunucusundan alýr ve üzerinde çalýþtýðý makinanýn að arayüzünü
89 ayarlar. Ayrýca RFC1541 veya draft-ietf-dhc-dhcp-09'a uygun olarak,
90 kira zamanýný (lease time) yenilemeye çalýþýr.
91
92 %prep
93 %setup -q -n %{name}-%{ver}
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 %patch3 -p1
98 %patch4 -p0
99
100 %build
101 rm -f missing
102 aclocal
103 %{__autoconf}
104 %{__automake}
105 %configure
106 %{__make} all mandir=%{_mandir} sbindir=%{_sbindir}
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 install -d $RPM_BUILD_ROOT%{_sysconfdir}/dhcpc
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT \
114         mandir=%{_mandir} \
115         sbindir=%{_sbindir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files
121 %defattr(644,root,root,755)
122 %doc README AUTHORS ChangeLog NEWS
123 %dir %{_sysconfdir}/dhcpc
124 %attr(755,root,root) %{_sbindir}/dhcpcd
125 %{_mandir}/man8/dhcpcd.8*
This page took 0.083589 seconds and 3 git commands to generate.