]> git.pld-linux.org Git - packages/devscripts.git/blob - devscripts.spec
rebuild with python 3.10
[packages/devscripts.git] / devscripts.spec
1 # TODO
2 # - bash-completions subpackage
3 # - some junk installed to root: "/devscripts.*"
4 Summary:        Scripts for Debian Package maintainers
5 Name:           devscripts
6 Version:        2.18.6
7 Release:        5
8 License:        GPL v2+
9 Group:          Development
10 Source0:        http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
11 # Source0-md5:  999be6ee14d60fade4d173283152dd2e
12 Patch0:         %{name}_docbook.patch
13 Patch1:         %{name}_install-layout.patch
14 Patch2:         %{name}_install-man.patch
15 URL:            https://packages.debian.org/unstable/admin/devscripts
16 BuildRequires:  docbook-dtd42-xml
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  dpkg
19 BuildRequires:  gettext-tools
20 BuildRequires:  libxslt
21 BuildRequires:  libxslt-progs
22 BuildRequires:  perl-DB_File
23 BuildRequires:  perl-File-DesktopEntry
24 BuildRequires:  perl-TimeDate
25 BuildRequires:  perl-base
26 BuildRequires:  perl-libwww
27 BuildRequires:  perl-modules
28 BuildRequires:  pkgconfig
29 BuildRequires:  po4a
30 BuildRequires:  python3-devel
31 BuildRequires:  python3-setuptools
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 BuildRequires:  rpm-pythonprov
34 BuildRequires:  rpmbuild(macros) >= 1.673
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 # man for manpage-alert
38 Requires:       %{_bindir}/man
39 Requires:       checkbashisms = %{version}-%{release}
40 #Requires:      dpkg-dev
41 #Requires:      sensible-utils
42 Conflicts:      rpmdevtools < 8.4
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Scripts to make the life of a Debian Package maintainer easier.
47
48 %package -n checkbashisms
49 Summary:        Check shell scripts for common bash-specific contructs
50 Group:          Development
51 BuildArch:      noarch
52
53 %description -n checkbashisms
54 checkbashisms checks whether a /bin/sh script contains any common
55 bash-specific contructs.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62
63 # PLD package names
64 # grep -r 'you must have the.*package installed' .
65 %{__sed} -i -e 's/liburi-perl/perl-URI/g' scripts/*.pl
66 %{__sed} -i -e 's/liblwp-protocol-https-perl/perl-LWP-Protocol-https/g' scripts/*.pl
67 %{__sed} -i -e 's/libtimedate-perl/perl-TimeDate/g' scripts/*.pl
68 %{__sed} -i -e 's/libfile-desktopentry-perl/perl-File-DesktopEntry/g' scripts/*.pl
69 %{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
70 %{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
71
72 # python paths
73 %{__sed} -i -e 's#setup.py install #setup.py install --prefix=%{_prefix} --install-purelib=%{py3_sitescriptdir} --install-platlib=%{py3_sitedir} #g' scripts/Makefile
74
75 %build
76 # LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
77 %{__make} \
78         LIBDIR=%{_libdir}/%{name} \
79         CFLAGS="$RPM_OPT_FLAGS" \
80         LDFLAGS="$RPM_LD_FLAGS"
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT%{_bindir}
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT \
87         LIBDIR=%{_libdir}/%{name}
88
89 # Install docs through %doc
90 rm -r $RPM_BUILD_ROOT%{_docdir}
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %files
96 %defattr(644,root,root,755)
97 %doc README
98 %attr(755,root,root) %{_bindir}/add-patch
99 %attr(755,root,root) %{_bindir}/annotate-output
100 %attr(755,root,root) %{_bindir}/archpath
101 %attr(755,root,root) %{_bindir}/bts
102 %attr(755,root,root) %{_bindir}/build-rdeps
103 %attr(755,root,root) %{_bindir}/chdist
104 %attr(755,root,root) %{_bindir}/cowpoke
105 %attr(755,root,root) %{_bindir}/cvs-debi
106 %attr(755,root,root) %{_bindir}/cvs-debrelease
107 %attr(755,root,root) %{_bindir}/cvs-debuild
108 %attr(755,root,root) %{_bindir}/dcmd
109 %attr(755,root,root) %{_bindir}/dcontrol
110 %attr(755,root,root) %{_bindir}/dd-list
111 %attr(755,root,root) %{_bindir}/deb-reversion
112 %attr(755,root,root) %{_bindir}/debc
113 %attr(755,root,root) %{_bindir}/debchange
114 %attr(755,root,root) %{_bindir}/debcheckout
115 %attr(755,root,root) %{_bindir}/debclean
116 %attr(755,root,root) %{_bindir}/debcommit
117 %attr(755,root,root) %{_bindir}/debdiff
118 %attr(755,root,root) %{_bindir}/debdiff-apply
119 %attr(755,root,root) %{_bindir}/debi
120 %attr(755,root,root) %{_bindir}/debpkg
121 %attr(755,root,root) %{_bindir}/debrelease
122 %attr(755,root,root) %{_bindir}/debrepro
123 %attr(755,root,root) %{_bindir}/debrsign
124 %attr(755,root,root) %{_bindir}/debsign
125 %attr(755,root,root) %{_bindir}/debsnap
126 %attr(755,root,root) %{_bindir}/debuild
127 %attr(755,root,root) %{_bindir}/dep3changelog
128 %attr(755,root,root) %{_bindir}/desktop2menu
129 %attr(755,root,root) %{_bindir}/dget
130 %attr(755,root,root) %{_bindir}/diff2patches
131 %attr(755,root,root) %{_bindir}/dpkg-depcheck
132 %attr(755,root,root) %{_bindir}/dpkg-genbuilddeps
133 %attr(755,root,root) %{_bindir}/dscextract
134 %attr(755,root,root) %{_bindir}/dscverify
135 %attr(755,root,root) %{_bindir}/edit-patch
136 %attr(755,root,root) %{_bindir}/getbuildlog
137 %attr(755,root,root) %{_bindir}/git-deborig
138 %attr(755,root,root) %{_bindir}/grep-excuses
139 %attr(755,root,root) %{_bindir}/hardening-check
140 %attr(755,root,root) %{_bindir}/list-unreleased
141 %attr(755,root,root) %{_bindir}/ltnu
142 %attr(755,root,root) %{_bindir}/manpage-alert
143 %attr(755,root,root) %{_bindir}/mass-bug
144 %attr(755,root,root) %{_bindir}/mergechanges
145 %attr(755,root,root) %{_bindir}/mk-build-deps
146 %attr(755,root,root) %{_bindir}/mk-origtargz
147 %attr(755,root,root) %{_bindir}/namecheck
148 %attr(755,root,root) %{_bindir}/nmudiff
149 %attr(755,root,root) %{_bindir}/origtargz
150 %attr(755,root,root) %{_bindir}/plotchangelog
151 %attr(755,root,root) %{_bindir}/pts-subscribe
152 %attr(755,root,root) %{_bindir}/rc-alert
153 %attr(755,root,root) %{_bindir}/reproducible-check
154 %attr(755,root,root) %{_bindir}/rmadison
155 %attr(755,root,root) %{_bindir}/sadt
156 %attr(755,root,root) %{_bindir}/suspicious-source
157 %attr(755,root,root) %{_bindir}/svnpath
158 %attr(755,root,root) %{_bindir}/tagpending
159 %attr(755,root,root) %{_bindir}/transition-check
160 %attr(755,root,root) %{_bindir}/uscan
161 %attr(755,root,root) %{_bindir}/uupdate
162 %attr(755,root,root) %{_bindir}/what-patch
163 %attr(755,root,root) %{_bindir}/who-permits-upload
164 %attr(755,root,root) %{_bindir}/who-uploads
165 %attr(755,root,root) %{_bindir}/whodepends
166 %attr(755,root,root) %{_bindir}/wnpp-alert
167 %attr(755,root,root) %{_bindir}/wnpp-check
168 %attr(755,root,root) %{_bindir}/wrap-and-sort
169 %{_mandir}/man1/add-patch.1
170 %{_mandir}/man1/annotate-output.1*
171 %{_mandir}/man1/archpath.1*
172 %{_mandir}/man1/bts.1*
173 %{_mandir}/man1/build-rdeps.1*
174 %{_mandir}/man1/chdist.1*
175 %{_mandir}/man1/cowpoke.1*
176 %{_mandir}/man1/cvs-debc.1*
177 %{_mandir}/man1/cvs-debi.1*
178 %{_mandir}/man1/cvs-debrelease.1*
179 %{_mandir}/man1/cvs-debuild.1*
180 %{_mandir}/man1/dcmd.1*
181 %{_mandir}/man1/dcontrol.1*
182 %{_mandir}/man1/dd-list.1*
183 %{_mandir}/man1/deb-reversion.1*
184 %{_mandir}/man1/debc.1*
185 %{_mandir}/man1/debchange.1*
186 %{_mandir}/man1/debcheckout.1*
187 %{_mandir}/man1/debclean.1*
188 %{_mandir}/man1/debcommit.1*
189 %{_mandir}/man1/debdiff-apply.1*
190 %{_mandir}/man1/debdiff.1*
191 %{_mandir}/man1/debi.1*
192 %{_mandir}/man1/debpkg.1*
193 %{_mandir}/man1/debrelease.1*
194 %{_mandir}/man1/debrepro.1*
195 %{_mandir}/man1/debrsign.1*
196 %{_mandir}/man1/debsign.1*
197 %{_mandir}/man1/debsnap.1*
198 %{_mandir}/man1/debuild.1*
199 %{_mandir}/man1/dep3changelog.1*
200 %{_mandir}/man1/desktop2menu.1*
201 %{_mandir}/man1/devscripts.1*
202 %{_mandir}/man1/dget.1*
203 %{_mandir}/man1/diff2patches.1*
204 %{_mandir}/man1/dpkg-depcheck.1*
205 %{_mandir}/man1/dpkg-genbuilddeps.1*
206 %{_mandir}/man1/dscextract.1*
207 %{_mandir}/man1/dscverify.1*
208 %{_mandir}/man1/edit-patch.1*
209 %{_mandir}/man1/getbuildlog.1*
210 %{_mandir}/man1/git-deborig.1*
211 %{_mandir}/man1/grep-excuses.1*
212 %{_mandir}/man1/hardening-check.1*
213 %{_mandir}/man1/list-unreleased.1*
214 %{_mandir}/man1/ltnu.1*
215 %{_mandir}/man1/manpage-alert.1*
216 %{_mandir}/man1/mass-bug.1*
217 %{_mandir}/man1/mergechanges.1*
218 %{_mandir}/man1/mk-build-deps.1*
219 %{_mandir}/man1/mk-origtargz.1*
220 %{_mandir}/man1/namecheck.1*
221 %{_mandir}/man1/nmudiff.1*
222 %{_mandir}/man1/origtargz.1*
223 %{_mandir}/man1/plotchangelog.1*
224 %{_mandir}/man1/pts-subscribe.1*
225 %{_mandir}/man1/rc-alert.1*
226 %{_mandir}/man1/reproducible-check.1*
227 %{_mandir}/man1/rmadison.1*
228 %{_mandir}/man1/sadt.1*
229 %{_mandir}/man1/suspicious-source.1*
230 %{_mandir}/man1/svnpath.1*
231 %{_mandir}/man1/tagpending.1*
232 %{_mandir}/man1/transition-check.1*
233 %{_mandir}/man1/uscan.1*
234 %{_mandir}/man1/uupdate.1*
235 %{_mandir}/man1/what-patch.1*
236 %{_mandir}/man1/who-permits-upload.1*
237 %{_mandir}/man1/who-uploads.1*
238 %{_mandir}/man1/whodepends.1*
239 %{_mandir}/man1/wnpp-alert.1*
240 %{_mandir}/man1/wnpp-check.1*
241 %{_mandir}/man1/wrap-and-sort.1*
242 %{py3_sitescriptdir}/%{name}
243 %{py3_sitescriptdir}/%{name}*.egg-info
244 %{_datadir}/%{name}
245 %{perl_vendorlib}/Devscripts
246 %{bash_compdir}/bts
247 %{bash_compdir}/build-rdeps
248 %{bash_compdir}/chdist
249 %{bash_compdir}/checkbashisms
250 %{bash_compdir}/dch
251 %{bash_compdir}/dcontrol
252 %{bash_compdir}/dd-list
253 %{bash_compdir}/debc
254 %{bash_compdir}/debchange
255 %{bash_compdir}/debcheckout
256 %{bash_compdir}/debdiff
257 %{bash_compdir}/debi
258 %{bash_compdir}/debsign
259 %{bash_compdir}/debsnap
260 %{bash_compdir}/debuild
261 %{bash_compdir}/dget
262 %{bash_compdir}/dscextract
263 %{bash_compdir}/dscverify
264 %{bash_compdir}/getbuildlog
265 %{bash_compdir}/grep-excuses
266 %{bash_compdir}/list-unreleased
267 %{bash_compdir}/mass-bug
268 %{bash_compdir}/mk-build-deps
269 %{bash_compdir}/mk-origtargz
270 %{bash_compdir}/pkgnames
271 %{bash_compdir}/plotchangelog
272 %{bash_compdir}/pts-subscribe
273 %{bash_compdir}/pts-unsubscribe
274 %{bash_compdir}/rc-alert
275 %{bash_compdir}/rmadison
276 %{bash_compdir}/transition-check
277 %{bash_compdir}/uscan
278 %{bash_compdir}/uupdate
279 %{bash_compdir}/what-patch
280 %{bash_compdir}/who-uploads
281 %{bash_compdir}/whodepends
282 %{bash_compdir}/wnpp-alert
283 %{bash_compdir}/wnpp-check
284
285 %files -n checkbashisms
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_bindir}/checkbashisms
288 %{_mandir}/man1/checkbashisms.1*
This page took 0.072869 seconds and 4 git commands to generate.