]> git.pld-linux.org Git - packages/devscripts.git/blob - devscripts.spec
up to 2.18.3
[packages/devscripts.git] / devscripts.spec
1 # TODO
2 # - bash-completions subpackage
3 # - some junk installed to root: "/devscripts.*"
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Scripts for Debian Package maintainers
6 Name:           devscripts
7 Version:        2.18.3
8 Release:        1
9 License:        GPL v2+
10 Group:          Development
11 Source0:        http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
12 # Source0-md5:  7f30530c8d74d5a986b57d80cf7f5202
13 Patch0:         %{name}_docbook.patch
14 Patch1:         %{name}_install-layout.patch
15 Patch2:         %{name}_install-man.patch
16 URL:            https://packages.debian.org/unstable/admin/devscripts
17 BuildRequires:  docbook-dtd42-xml
18 BuildRequires:  docbook-style-xsl
19 BuildRequires:  dpkg
20 BuildRequires:  gettext-tools
21 BuildRequires:  libxslt
22 BuildRequires:  libxslt-progs
23 BuildRequires:  perl-DB_File
24 BuildRequires:  perl-File-DesktopEntry
25 BuildRequires:  perl-TimeDate
26 BuildRequires:  perl-base
27 BuildRequires:  perl-libwww
28 BuildRequires:  perl-modules
29 BuildRequires:  pkgconfig
30 BuildRequires:  po4a
31 BuildRequires:  python3-devel
32 BuildRequires:  python3-setuptools
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.673
36 BuildRequires:  tar >= 1:1.22
37 BuildRequires:  xz
38 # man for manpage-alert
39 Requires:       %{_bindir}/man
40 Requires:       checkbashisms = %{version}-%{release}
41 #Requires:      dpkg-dev
42 #Requires:      sensible-utils
43 Conflicts:      rpmdevtools < 8.4
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Scripts to make the life of a Debian Package maintainer easier.
48
49 %package -n checkbashisms
50 Summary:        Check shell scripts for common bash-specific contructs
51 Group:          Development
52 %if "%{_rpmversion}" >= "5"
53 BuildArch:      noarch
54 %endif
55
56 %description -n checkbashisms
57 checkbashisms checks whether a /bin/sh script contains any common
58 bash-specific contructs.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63 %patch1 -p1
64 %patch2 -p1
65
66 # PLD package names
67 # grep -r 'you must have the.*package installed' .
68 %{__sed} -i -e 's/liburi-perl/perl-URI/g' scripts/*.pl
69 %{__sed} -i -e 's/liblwp-protocol-https-perl/perl-LWP-Protocol-https/g' scripts/*.pl
70 %{__sed} -i -e 's/libtimedate-perl/perl-TimeDate/g' scripts/*.pl
71 %{__sed} -i -e 's/libfile-desktopentry-perl/perl-File-DesktopEntry/g' scripts/*.pl
72 %{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
73 %{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
74
75 # python paths
76 %{__sed} -i -e 's#setup.py install #setup.py install --prefix=%{_prefix} --install-purelib=%{py3_sitescriptdir} --install-platlib=%{py3_sitedir} #g' scripts/Makefile
77
78 %build
79 # LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
80 %{__make} \
81         LIBDIR=%{_libdir}/%{name} \
82         CFLAGS="$RPM_OPT_FLAGS" \
83         LDFLAGS="$RPM_LD_FLAGS"
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT%{_bindir}
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT \
90         LIBDIR=%{_libdir}/%{name}
91
92 # Install docs through %doc
93 rm -r $RPM_BUILD_ROOT%{_docdir}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %files
99 %defattr(644,root,root,755)
100 %doc README
101 %attr(755,root,root) %{_bindir}/add-patch
102 %attr(755,root,root) %{_bindir}/annotate-output
103 %attr(755,root,root) %{_bindir}/archpath
104 %attr(755,root,root) %{_bindir}/bts
105 %attr(755,root,root) %{_bindir}/build-rdeps
106 %attr(755,root,root) %{_bindir}/chdist
107 %attr(755,root,root) %{_bindir}/cowpoke
108 %attr(755,root,root) %{_bindir}/cvs-debi
109 %attr(755,root,root) %{_bindir}/cvs-debrelease
110 %attr(755,root,root) %{_bindir}/cvs-debuild
111 %attr(755,root,root) %{_bindir}/dcmd
112 %attr(755,root,root) %{_bindir}/dcontrol
113 %attr(755,root,root) %{_bindir}/dd-list
114 %attr(755,root,root) %{_bindir}/deb-reversion
115 %attr(755,root,root) %{_bindir}/debc
116 %attr(755,root,root) %{_bindir}/debchange
117 %attr(755,root,root) %{_bindir}/debcheckout
118 %attr(755,root,root) %{_bindir}/debclean
119 %attr(755,root,root) %{_bindir}/debcommit
120 %attr(755,root,root) %{_bindir}/debdiff
121 %attr(755,root,root) %{_bindir}/debdiff-apply
122 %attr(755,root,root) %{_bindir}/debi
123 %attr(755,root,root) %{_bindir}/debpkg
124 %attr(755,root,root) %{_bindir}/debrelease
125 %attr(755,root,root) %{_bindir}/debrepro
126 %attr(755,root,root) %{_bindir}/debrsign
127 %attr(755,root,root) %{_bindir}/debsign
128 %attr(755,root,root) %{_bindir}/debsnap
129 %attr(755,root,root) %{_bindir}/debuild
130 %attr(755,root,root) %{_bindir}/dep3changelog
131 %attr(755,root,root) %{_bindir}/desktop2menu
132 %attr(755,root,root) %{_bindir}/dget
133 %attr(755,root,root) %{_bindir}/diff2patches
134 %attr(755,root,root) %{_bindir}/dpkg-depcheck
135 %attr(755,root,root) %{_bindir}/dpkg-genbuilddeps
136 %attr(755,root,root) %{_bindir}/dscextract
137 %attr(755,root,root) %{_bindir}/dscverify
138 %attr(755,root,root) %{_bindir}/edit-patch
139 %attr(755,root,root) %{_bindir}/getbuildlog
140 %attr(755,root,root) %{_bindir}/git-deborig
141 %attr(755,root,root) %{_bindir}/grep-excuses
142 %attr(755,root,root) %{_bindir}/hardening-check
143 %attr(755,root,root) %{_bindir}/list-unreleased
144 %attr(755,root,root) %{_bindir}/ltnu
145 %attr(755,root,root) %{_bindir}/manpage-alert
146 %attr(755,root,root) %{_bindir}/mass-bug
147 %attr(755,root,root) %{_bindir}/mergechanges
148 %attr(755,root,root) %{_bindir}/mk-build-deps
149 %attr(755,root,root) %{_bindir}/mk-origtargz
150 %attr(755,root,root) %{_bindir}/namecheck
151 %attr(755,root,root) %{_bindir}/nmudiff
152 %attr(755,root,root) %{_bindir}/origtargz
153 %attr(755,root,root) %{_bindir}/plotchangelog
154 %attr(755,root,root) %{_bindir}/pts-subscribe
155 %attr(755,root,root) %{_bindir}/rc-alert
156 %attr(755,root,root) %{_bindir}/reproducible-check
157 %attr(755,root,root) %{_bindir}/rmadison
158 %attr(755,root,root) %{_bindir}/sadt
159 %attr(755,root,root) %{_bindir}/suspicious-source
160 %attr(755,root,root) %{_bindir}/svnpath
161 %attr(755,root,root) %{_bindir}/tagpending
162 %attr(755,root,root) %{_bindir}/transition-check
163 %attr(755,root,root) %{_bindir}/uscan
164 %attr(755,root,root) %{_bindir}/uupdate
165 %attr(755,root,root) %{_bindir}/what-patch
166 %attr(755,root,root) %{_bindir}/who-permits-upload
167 %attr(755,root,root) %{_bindir}/who-uploads
168 %attr(755,root,root) %{_bindir}/whodepends
169 %attr(755,root,root) %{_bindir}/wnpp-alert
170 %attr(755,root,root) %{_bindir}/wnpp-check
171 %attr(755,root,root) %{_bindir}/wrap-and-sort
172 %{_mandir}/man1/add-patch.1
173 %{_mandir}/man1/annotate-output.1*
174 %{_mandir}/man1/archpath.1*
175 %{_mandir}/man1/bts.1*
176 %{_mandir}/man1/build-rdeps.1*
177 %{_mandir}/man1/chdist.1*
178 %{_mandir}/man1/cowpoke.1*
179 %{_mandir}/man1/cvs-debc.1*
180 %{_mandir}/man1/cvs-debi.1*
181 %{_mandir}/man1/cvs-debrelease.1*
182 %{_mandir}/man1/cvs-debuild.1*
183 %{_mandir}/man1/dcmd.1*
184 %{_mandir}/man1/dcontrol.1*
185 %{_mandir}/man1/dd-list.1*
186 %{_mandir}/man1/deb-reversion.1*
187 %{_mandir}/man1/debc.1*
188 %{_mandir}/man1/debchange.1*
189 %{_mandir}/man1/debcheckout.1*
190 %{_mandir}/man1/debclean.1*
191 %{_mandir}/man1/debcommit.1*
192 %{_mandir}/man1/debdiff-apply.1*
193 %{_mandir}/man1/debdiff.1*
194 %{_mandir}/man1/debi.1*
195 %{_mandir}/man1/debpkg.1*
196 %{_mandir}/man1/debrelease.1*
197 %{_mandir}/man1/debrepro.1*
198 %{_mandir}/man1/debrsign.1*
199 %{_mandir}/man1/debsign.1*
200 %{_mandir}/man1/debsnap.1*
201 %{_mandir}/man1/debuild.1*
202 %{_mandir}/man1/dep3changelog.1*
203 %{_mandir}/man1/desktop2menu.1*
204 %{_mandir}/man1/devscripts.1*
205 %{_mandir}/man1/dget.1*
206 %{_mandir}/man1/diff2patches.1*
207 %{_mandir}/man1/dpkg-depcheck.1*
208 %{_mandir}/man1/dpkg-genbuilddeps.1*
209 %{_mandir}/man1/dscextract.1*
210 %{_mandir}/man1/dscverify.1*
211 %{_mandir}/man1/edit-patch.1*
212 %{_mandir}/man1/getbuildlog.1*
213 %{_mandir}/man1/git-deborig.1*
214 %{_mandir}/man1/grep-excuses.1*
215 %{_mandir}/man1/hardening-check.1*
216 %{_mandir}/man1/list-unreleased.1*
217 %{_mandir}/man1/ltnu.1*
218 %{_mandir}/man1/manpage-alert.1*
219 %{_mandir}/man1/mass-bug.1*
220 %{_mandir}/man1/mergechanges.1*
221 %{_mandir}/man1/mk-build-deps.1*
222 %{_mandir}/man1/mk-origtargz.1*
223 %{_mandir}/man1/namecheck.1*
224 %{_mandir}/man1/nmudiff.1*
225 %{_mandir}/man1/origtargz.1*
226 %{_mandir}/man1/plotchangelog.1*
227 %{_mandir}/man1/pts-subscribe.1*
228 %{_mandir}/man1/rc-alert.1*
229 %{_mandir}/man1/reproducible-check.1*
230 %{_mandir}/man1/rmadison.1*
231 %{_mandir}/man1/sadt.1*
232 %{_mandir}/man1/suspicious-source.1*
233 %{_mandir}/man1/svnpath.1*
234 %{_mandir}/man1/tagpending.1*
235 %{_mandir}/man1/transition-check.1*
236 %{_mandir}/man1/uscan.1*
237 %{_mandir}/man1/uupdate.1*
238 %{_mandir}/man1/what-patch.1*
239 %{_mandir}/man1/who-permits-upload.1*
240 %{_mandir}/man1/who-uploads.1*
241 %{_mandir}/man1/whodepends.1*
242 %{_mandir}/man1/wnpp-alert.1*
243 %{_mandir}/man1/wnpp-check.1*
244 %{_mandir}/man1/wrap-and-sort.1*
245 %{py3_sitescriptdir}/%{name}
246 %{py3_sitescriptdir}/%{name}*.egg-info
247 %{_datadir}/%{name}
248 %{perl_vendorlib}/Devscripts
249 %{bash_compdir}/bts
250 %{bash_compdir}/build-rdeps
251 %{bash_compdir}/chdist
252 %{bash_compdir}/checkbashisms
253 %{bash_compdir}/dch
254 %{bash_compdir}/dcontrol
255 %{bash_compdir}/dd-list
256 %{bash_compdir}/debc
257 %{bash_compdir}/debchange
258 %{bash_compdir}/debcheckout
259 %{bash_compdir}/debdiff
260 %{bash_compdir}/debi
261 %{bash_compdir}/debsign
262 %{bash_compdir}/debsnap
263 %{bash_compdir}/debuild
264 %{bash_compdir}/dget
265 %{bash_compdir}/dscextract
266 %{bash_compdir}/dscverify
267 %{bash_compdir}/getbuildlog
268 %{bash_compdir}/grep-excuses
269 %{bash_compdir}/list-unreleased
270 %{bash_compdir}/mass-bug
271 %{bash_compdir}/mk-build-deps
272 %{bash_compdir}/mk-origtargz
273 %{bash_compdir}/pkgnames
274 %{bash_compdir}/plotchangelog
275 %{bash_compdir}/pts-subscribe
276 %{bash_compdir}/pts-unsubscribe
277 %{bash_compdir}/rc-alert
278 %{bash_compdir}/rmadison
279 %{bash_compdir}/transition-check
280 %{bash_compdir}/uscan
281 %{bash_compdir}/uupdate
282 %{bash_compdir}/what-patch
283 %{bash_compdir}/who-uploads
284 %{bash_compdir}/whodepends
285 %{bash_compdir}/wnpp-alert
286 %{bash_compdir}/wnpp-check
287
288 %files -n checkbashisms
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_bindir}/checkbashisms
291 %{_mandir}/man1/checkbashisms.1*
This page took 0.053536 seconds and 4 git commands to generate.