]> git.pld-linux.org Git - packages/devscripts.git/blob - devscripts.spec
libvfork cleanup
[packages/devscripts.git] / devscripts.spec
1 # TODO
2 # - bash-completions subpackage
3 # - some junk installed to root: "/devscripts.*"
4 %include        /usr/lib/rpm/macros.perl
5 Summary:        Scripts for Debian Package maintainers
6 Name:           devscripts
7 Version:        2.15.7
8 Release:        1
9 License:        GPL v2+
10 Group:          Development
11 Source0:        http://ftp.debian.org/debian/pool/main/d/devscripts/%{name}_%{version}.tar.xz
12 # Source0-md5:  1655e2c91e42cd48393c65726bc3faa9
13 Patch0:         %{name}_docbook.patch
14 Patch1:         %{name}_install-layout.patch
15 Patch2:         %{name}_install-man.patch
16 URL:            https://packages.debian.org/unstable/admin/devscripts
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  dpkg
19 BuildRequires:  libxslt
20 BuildRequires:  perl-DB_File
21 BuildRequires:  perl-File-DesktopEntry
22 BuildRequires:  perl-Parse-DebControl
23 BuildRequires:  perl-base
24 BuildRequires:  perl-libwww
25 BuildRequires:  perl-modules
26 BuildRequires:  po4a
27 BuildRequires:  python3-devel
28 BuildRequires:  python3-setuptools
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 # man for manpage-alert
33 Requires:       %{_bindir}/man
34 Requires:       checkbashisms = %{version}-%{release}
35 #Requires:      dpkg-dev
36 #Requires:      sensible-utils
37 Conflicts:      rpmdevtools < 8.4
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Scripts to make the life of a Debian Package maintainer easier.
42
43 %package -n checkbashisms
44 Summary:        Check shell scripts for common bash-specific contructs
45 Group:          Development
46 %if "%{_rpmversion}" >= "5"
47 BuildArch:      noarch
48 %endif
49
50 %description -n checkbashisms
51 checkbashisms checks whether a /bin/sh script contains any common
52 bash-specific contructs.
53
54 %prep
55 %setup -q
56 %patch0 -p1
57 %patch1 -p1
58 %patch2 -p1
59
60 # PLD package names
61 # grep -r 'you must have the.*package installed' .
62 %{__sed} -i -e 's/liburi-perl/perl-URI/g' scripts/*.pl
63 %{__sed} -i -e 's/liblwp-protocol-https-perl/perl-LWP-Protocol-https/g' scripts/*.pl
64 %{__sed} -i -e 's/libtimedate-perl/perl-TimeDate/g' scripts/*.pl
65 %{__sed} -i -e 's/libfile-desktopentry-perl/perl-File-DesktopEntry/g' scripts/*.pl
66 %{__sed} -i -e 's/libwww-perl/perl-libwww/g' scripts/*.pl
67 %{__sed} -i -e 's/libdigest-md5-perl/perl-Digest-MD5/g' scripts/*.pl
68
69 %build
70 # LIBDIR determines where libvfork gets installed, see scripts/Makefile for LIBDIR
71 %{__make} \
72         LIBDIR=%{_libdir}/%{name} \
73         CFLAGS="$RPM_OPT_FLAGS" \
74         LDFLAGS="$RPM_LD_FLAGS"
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT \
80         LIBDIR=%{_libdir}/%{name}
81
82 # Install docs through %doc
83 rm -r $RPM_BUILD_ROOT%{_docdir}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc README
91 %attr(755,root,root) %{_bindir}/add-patch
92 %attr(755,root,root) %{_bindir}/annotate-output
93 %attr(755,root,root) %{_bindir}/archpath
94 %attr(755,root,root) %{_bindir}/bts
95 %attr(755,root,root) %{_bindir}/build-rdeps
96 %attr(755,root,root) %{_bindir}/chdist
97 %attr(755,root,root) %{_bindir}/cowpoke
98 %attr(755,root,root) %{_bindir}/cvs-debi
99 %attr(755,root,root) %{_bindir}/cvs-debrelease
100 %attr(755,root,root) %{_bindir}/cvs-debuild
101 %attr(755,root,root) %{_bindir}/dcmd
102 %attr(755,root,root) %{_bindir}/dcontrol
103 %attr(755,root,root) %{_bindir}/dd-list
104 %attr(755,root,root) %{_bindir}/deb-reversion
105 %attr(755,root,root) %{_bindir}/debchange
106 %attr(755,root,root) %{_bindir}/debcheckout
107 %attr(755,root,root) %{_bindir}/debclean
108 %attr(755,root,root) %{_bindir}/debcommit
109 %attr(755,root,root) %{_bindir}/debdiff
110 %attr(755,root,root) %{_bindir}/debi
111 %attr(755,root,root) %{_bindir}/debpkg
112 %attr(755,root,root) %{_bindir}/debrelease
113 %attr(755,root,root) %{_bindir}/debrsign
114 %attr(755,root,root) %{_bindir}/debsign
115 %attr(755,root,root) %{_bindir}/debsnap
116 %attr(755,root,root) %{_bindir}/debuild
117 %attr(755,root,root) %{_bindir}/dep3changelog
118 %attr(755,root,root) %{_bindir}/desktop2menu
119 %attr(755,root,root) %{_bindir}/dget
120 %attr(755,root,root) %{_bindir}/diff2patches
121 %attr(755,root,root) %{_bindir}/dpkg-depcheck
122 %attr(755,root,root) %{_bindir}/dpkg-genbuilddeps
123 %attr(755,root,root) %{_bindir}/dscextract
124 %attr(755,root,root) %{_bindir}/dscverify
125 %attr(755,root,root) %{_bindir}/edit-patch
126 %attr(755,root,root) %{_bindir}/getbuildlog
127 %attr(755,root,root) %{_bindir}/grep-excuses
128 %attr(755,root,root) %{_bindir}/licensecheck
129 %attr(755,root,root) %{_bindir}/list-unreleased
130 %attr(755,root,root) %{_bindir}/manpage-alert
131 %attr(755,root,root) %{_bindir}/mass-bug
132 %attr(755,root,root) %{_bindir}/mergechanges
133 %attr(755,root,root) %{_bindir}/mk-build-deps
134 %attr(755,root,root) %{_bindir}/mk-origtargz
135 %attr(755,root,root) %{_bindir}/namecheck
136 %attr(755,root,root) %{_bindir}/nmudiff
137 %attr(755,root,root) %{_bindir}/origtargz
138 %attr(755,root,root) %{_bindir}/plotchangelog
139 %attr(755,root,root) %{_bindir}/pts-subscribe
140 %attr(755,root,root) %{_bindir}/rc-alert
141 %attr(755,root,root) %{_bindir}/rmadison
142 %attr(755,root,root) %{_bindir}/sadt
143 %attr(755,root,root) %{_bindir}/suspicious-source
144 %attr(755,root,root) %{_bindir}/svnpath
145 %attr(755,root,root) %{_bindir}/tagpending
146 %attr(755,root,root) %{_bindir}/transition-check
147 %attr(755,root,root) %{_bindir}/uscan
148 %attr(755,root,root) %{_bindir}/uupdate
149 %attr(755,root,root) %{_bindir}/what-patch
150 %attr(755,root,root) %{_bindir}/who-permits-upload
151 %attr(755,root,root) %{_bindir}/who-uploads
152 %attr(755,root,root) %{_bindir}/whodepends
153 %attr(755,root,root) %{_bindir}/wnpp-alert
154 %attr(755,root,root) %{_bindir}/wnpp-check
155 %attr(755,root,root) %{_bindir}/wrap-and-sort
156 %{_mandir}/man1/add-patch.1
157 %{_mandir}/man1/annotate-output.1*
158 %{_mandir}/man1/archpath.1*
159 %{_mandir}/man1/bts.1*
160 %{_mandir}/man1/build-rdeps.1*
161 %{_mandir}/man1/chdist.1*
162 %{_mandir}/man1/cowpoke.1*
163 %{_mandir}/man1/cvs-debc.1*
164 %{_mandir}/man1/cvs-debi.1*
165 %{_mandir}/man1/cvs-debrelease.1*
166 %{_mandir}/man1/cvs-debuild.1*
167 %{_mandir}/man1/dcmd.1*
168 %{_mandir}/man1/dcontrol.1*
169 %{_mandir}/man1/dd-list.1*
170 %{_mandir}/man1/deb-reversion.1*
171 %{_mandir}/man1/debc.1*
172 %{_mandir}/man1/debchange.1*
173 %{_mandir}/man1/debcheckout.1*
174 %{_mandir}/man1/debclean.1*
175 %{_mandir}/man1/debcommit.1*
176 %{_mandir}/man1/debdiff.1*
177 %{_mandir}/man1/debi.1*
178 %{_mandir}/man1/debpkg.1*
179 %{_mandir}/man1/debrelease.1*
180 %{_mandir}/man1/debrsign.1*
181 %{_mandir}/man1/debsign.1*
182 %{_mandir}/man1/debsnap.1*
183 %{_mandir}/man1/debuild.1*
184 %{_mandir}/man1/dep3changelog.1*
185 %{_mandir}/man1/desktop2menu.1*
186 %{_mandir}/man1/devscripts.1*
187 %{_mandir}/man1/dget.1*
188 %{_mandir}/man1/diff2patches.1*
189 %{_mandir}/man1/dpkg-depcheck.1*
190 %{_mandir}/man1/dpkg-genbuilddeps.1*
191 %{_mandir}/man1/dscextract.1*
192 %{_mandir}/man1/dscverify.1*
193 %{_mandir}/man1/edit-patch.1*
194 %{_mandir}/man1/getbuildlog.1*
195 %{_mandir}/man1/grep-excuses.1*
196 %{_mandir}/man1/licensecheck.1*
197 %{_mandir}/man1/list-unreleased.1*
198 %{_mandir}/man1/manpage-alert.1*
199 %{_mandir}/man1/mass-bug.1*
200 %{_mandir}/man1/mergechanges.1*
201 %{_mandir}/man1/mk-build-deps.1*
202 %{_mandir}/man1/mk-origtargz.1*
203 %{_mandir}/man1/namecheck.1*
204 %{_mandir}/man1/nmudiff.1*
205 %{_mandir}/man1/origtargz.1*
206 %{_mandir}/man1/plotchangelog.1*
207 %{_mandir}/man1/pts-subscribe.1*
208 %{_mandir}/man1/rc-alert.1*
209 %{_mandir}/man1/rmadison.1*
210 %{_mandir}/man1/sadt.1*
211 %{_mandir}/man1/suspicious-source.1*
212 %{_mandir}/man1/svnpath.1*
213 %{_mandir}/man1/tagpending.1*
214 %{_mandir}/man1/transition-check.1*
215 %{_mandir}/man1/uscan.1*
216 %{_mandir}/man1/uupdate.1*
217 %{_mandir}/man1/what-patch.1*
218 %{_mandir}/man1/who-permits-upload.1*
219 %{_mandir}/man1/who-uploads.1*
220 %{_mandir}/man1/whodepends.1*
221 %{_mandir}/man1/wnpp-alert.1*
222 %{_mandir}/man1/wnpp-check.1*
223 %{_mandir}/man1/wrap-and-sort.1*
224 %{py3_sitescriptdir}/%{name}
225 %{py3_sitescriptdir}/%{name}*.egg-info
226 %{_datadir}/%{name}
227 %{perl_vendorlib}/Devscripts
228
229 %files -n checkbashisms
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_bindir}/checkbashisms
232 %{_mandir}/man1/checkbashisms.1*
This page took 0.084012 seconds and 4 git commands to generate.