]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
Zmieniony /dev/log - nalezy wstawic do sysklog'a
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(fr):    Entrées de /dev.
3 Summary(de):    /dev-Einträge
4 Summary(pl):    Pliki specjalne /dev/*
5 Summary(tr):    /dev dizini
6 Name:           dev
7 Version:        2.5.9
8 Release:        4
9 #######         From ftp.redhat.com/rawhide
10 Source:         %{name}-%{version}.cpio
11 Copyright:      public domain
12 Group:          Base
13 Buildroot:      /tmp/%{name}-%{version}-root
14 Autoreqprov:    no
15
16 %description
17 Unix and unix like systems (including Linux) use file system entries
18 to represent devices attached to the machine. All of these entries
19 are in the /dev tree (though they don't have to be), and this package
20 contains the most commonly used /dev entries. These files are essential
21 for a system to function properly.
22
23 %description -l pl
24 Wszystkie systemy Unix, jak na przyk³ad Linux, u¿ywaj± plików do przedstawienia 
25 urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki znajduj± siê zwykle w 
26 katalogu /dev. Pakiet ten zawiera wiêkszo¶æ popularnych plików specjalnych, 
27 s± one jedn± z wa¿niejszych czê¶ci prawid³owo dzia³aj±cego systemu operacyjnego.
28
29 %description -l fr
30 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
31 représenter les périphériques reliés à la machine. Toutes ces entrées
32 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
33 contient les entrées /dev les plus courantes. Elles sont essentielles
34 pour qu'un système fonctionne correctement.
35
36 %description -l tr
37 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya baðlý
38 aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel dosyalarýn tümü
39 /dev dizin yapýsý altýndadýr. Bu paket en çok kullanýlan /dev dosyalarýný
40 içerir. Bu dosyalar, bir sistemin düzgün olarak iþleyebilmesi için temel
41 gereksinimlerdendir.
42
43 %description -l de
44 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
45 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge befinden
46 sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses Paket enthält
47 die üblichsten /dev-Einträge. Diese Dateien sind für das Funktionieren
48 eines Systems unbedingt erforderlich.
49
50 %prep
51 %setup -q -c -T
52 rm -rf $RPM_BUILD_ROOT
53
54 install -d $RPM_BUILD_ROOT
55 BUILD_DIR=`pwd`
56
57 # unpack in build root
58 ( cd $RPM_BUILD_ROOT
59   cpio -iumd < %{SOURCE0}
60 )
61
62 # do some cleanup in build root
63 cd $RPM_BUILD_ROOT
64
65 %ifarch sparc
66 # SPARC specific devices
67 ln -s sunmouse dev/mouse
68 mknod dev/fb0 c 29 0
69 mknod dev/fb1 c 29 32
70 mknod dev/kbd c 11 0
71 mknod dev/openprom c 10 139
72 ln -s fb0 dev/fb
73 chmod 666 dev/fb*
74
75 # remove devices that will *never* exist on a SPARC
76 rm -f dev/hd* dev/aztcd dev/mcd dev/sbpcd1 dev/cdu31a dev/sbpcd2 dev/scd3
77 rm -f dev/sjcd dev/cdu535 dev/sbpcd3 dev/sonycd dev/cm206cd dev/sbpcd
78 rm -f dev/gscd dev/sbpcd0 dev/atibm dev/inportbm dev/logibm dev/psaux
79
80 %endif
81
82 chmod 660 dev/lp*
83 chgrp daemon dev/lp*
84
85 for I in 9 10 11 12; do
86         mknod dev/tty$I c 4 $I
87         chown root:tty dev/tty$I
88         chmod 600 dev/tty$I
89 done
90
91 cd dev
92
93 chgrp floppy fd?*
94
95 ln -s ram0 ramdisk
96 ln -s ../proc/self/fd fd
97
98 mknod pda  b 45 0
99 mknod pda1 b 45 1
100 mknod pda2 b 45 2
101 mknod pda3 b 45 3
102 mknod pda4 b 45 4
103
104 mknod pdb  b 45 16
105 mknod pdb1 b 45 17
106 mknod pdb2 b 45 18
107 mknod pdb3 b 45 19
108 mknod pdb4 b 45 20
109
110 mknod pdc  b 45 32
111 mknod pdc1 b 45 33
112 mknod pdc2 b 45 34
113 mknod pdc3 b 45 35
114 mknod pdc4 b 45 36
115
116 mknod pdd  b 45 48
117 mknod pdd1 b 45 49
118 mknod pdd2 b 45 50
119 mknod pdd3 b 45 51
120 mknod pdd4 b 45 52
121
122 mknod pcd0 b 46 0
123 mknod pcd1 b 46 1
124 mknod pcd2 b 46 2
125 mknod pcd3 b 46 3
126
127 mknod pf0 b 47 0
128 mknod pf1 b 47 1
129 mknod pf2 b 47 2
130 mknod pf3 b 47 3
131
132 mknod pt0  c 96 0
133 mknod pt1  c 96 1
134 mknod pt2  c 96 2
135 mknod pt3  c 96 3
136
137 chmod 0660      pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
138 chown root:disk pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
139
140 # unix98 pty support 
141 mknod ptmx c 5 2
142 chmod 666 ptmx; chown root.tty ptmx
143 install -d -m 755 pts
144
145 # framebuffer support
146 mknod fb0 b 29 0
147 mknod fb1 b 29 32
148 mknod fb2 b 29 64
149 mknod fb3 b 29 96
150 mknod fb4 b 29 128
151 mknod fb5 b 29 160
152 mknod fb6 b 29 192
153 mknod fb7 b 29 224
154
155 ln -s fb0 fb0current
156 ln -s fb1 fb1current
157 ln -s fb2 fb2current
158 ln -s fb3 fb3current
159 ln -s fb4 fb4current
160 ln -s fb5 fb5current
161 ln -s fb6 fb6current
162 ln -s fb7 fb7current
163
164 # watchdog support
165 mknod watchdog c 10 130 
166
167 # route 
168 mknod route c 36 0
169
170 %clean 
171 rm -rf $RPM_BUILD_ROOT
172
173 %files 
174 %defattr(644,root,root,755)
175
176 %dir /dev/pts
177
178 #a#
179 %attr(664,root,root) /dev/atibm
180 %attr(662,root, sys) /dev/audio
181 %attr(662,root, sys) /dev/audio1
182 %attr(664,root,root) /dev/aztcd
183
184 #b#
185 %attr(664,root,root) /dev/bpcd
186
187 #c#
188 %attr(664,root,root) /dev/cdu31a
189 %attr(640,root,disk) /dev/cdu535
190 %attr(664,root,root) /dev/cm206cd
191 %attr(600,root,root) /dev/console
192 %attr(666,root,root) /dev/cui*
193
194 #d#
195 %attr(662,root,sys) /dev/dsp
196 %attr(662,root,sys) /dev/dsp1
197
198 #e#
199
200 #f#
201 %attr(644,root,  root) /dev/fb*
202 %attr(664,root,floppy) /dev/fd*
203
204 #g#
205 %attr(664,root,root) /dev/gscd
206
207 #h#
208 %attr(660,root,disk) /dev/hd*
209 %attr(660,root,disk) /dev/ht0
210
211 #i#
212 %attr(664,root,root) /dev/inportbm
213 %attr(600,root,root) /dev/ippp*
214 %attr(600,root,root) /dev/isdnctrl*
215 %attr(444,root,root) /dev/isdninfo
216
217 #j#
218
219 #k#
220 %attr(640,root,kmem) /dev/kmem
221
222 #l#
223 %attr(666,root,root) /dev/log
224 %attr(664,root,root) /dev/logibm
225 %attr(660,root,disk) /dev/loop*
226
227 %attr(660,root,daemon) /dev/lp*
228
229 #m#
230 %attr(640,root,disk) /dev/mcd
231 %attr(640,root,kmem) /dev/mem
232 %attr(666,root, sys) /dev/midi*
233 %attr(666,root, sys) /dev/mixer
234 %attr(666,root, sys) /dev/mixer1
235
236 #n#
237 %attr(660,root,disk) /dev/nht0
238 %attr(660,root,disk) /dev/nrft*
239 %attr(660,root,disk) /dev/nst*
240 %attr(666,root,root) /dev/null
241
242 #o#
243 %attr(664,root,root) /dev/optcd
244
245 #p#
246 %attr(640,root,daemon) /dev/par*
247
248 %attr(660,root,disk) /dev/pcd*
249 %attr(660,root,disk) /dev/pd*
250 %attr(660,root,disk) /dev/pf*
251
252 %attr(640,root,kmem) /dev/port
253 %attr(600,root,root) /dev/printer
254 %attr(664,root,root) /dev/psaux
255
256 %attr(660,root,disk) /dev/pt0
257 %attr(660,root,disk) /dev/pt1
258 %attr(660,root,disk) /dev/pt2
259 %attr(660,root,disk) /dev/pt3
260
261 %attr(666,root,tty) /dev/ptmx
262 %attr(666,root,tty) /dev/pty*
263
264 #r#
265 %attr(640,root,disk) /dev/ram
266 %attr(660,root,disk) /dev/ram0
267 %attr(660,root,disk) /dev/ram1*
268 %attr(660,root,disk) /dev/ram2
269 %attr(660,root,disk) /dev/ram3
270 %attr(660,root,disk) /dev/ram4
271 %attr(660,root,disk) /dev/ram5
272 %attr(660,root,disk) /dev/ram6
273 %attr(660,root,disk) /dev/ram7
274 %attr(660,root,disk) /dev/ram8
275 %attr(660,root,disk) /dev/ram9
276
277 %attr(644,root,root) /dev/random
278 %attr(660,root,disk) /dev/rft*
279 %attr(644,root,root) /dev/route
280 %attr(664,root,root) /dev/rtc
281
282 #s#
283 %attr(640,root,disk) /dev/sbpc*
284
285 %attr(660,root,disk) /dev/scd*
286
287 %attr(660,root,disk) /dev/sda*
288 %attr(660,root,disk) /dev/sdb*
289 %attr(660,root,disk) /dev/sdc*
290 %attr(660,root,disk) /dev/sdd*
291 %attr(660,root,disk) /dev/sde*
292 %attr(660,root,disk) /dev/sdf*
293 %attr(660,root,disk) /dev/sdg*
294
295 %attr(664,root,sys) /dev/sequencer
296
297 %attr(600,root,sys) /dev/sg*
298
299 %attr(664,root,root) /dev/sjcd
300 %attr(666,root, sys) /dev/sndstat
301
302 %attr(640,root,disk) /dev/sonycd
303
304 %attr(660,root,disk) /dev/st*
305
306 %attr(664,root,root) /dev/sunmouse
307 %attr(600,root,root) /dev/systty
308
309 #t#
310 %attr(666,root,root) /dev/tty
311
312 %attr(600,root, tty) /dev/tty0
313 %attr(600,root, tty) /dev/tty1*
314 %attr(600,root, tty) /dev/tty2
315 %attr(600,root, tty) /dev/tty3
316 %attr(600,root, tty) /dev/tty4
317 %attr(600,root, tty) /dev/tty5
318 %attr(600,root, tty) /dev/tty6
319 %attr(600,root, tty) /dev/tty7
320 %attr(600,root, tty) /dev/tty8
321 %attr(600,root, tty) /dev/tty9
322
323 %attr(666,root,root) /dev/ttyI*
324
325 %attr(644,root,root) /dev/ttyS*
326
327 %attr(666,root, tty) /dev/ttya*
328 %attr(666,root, tty) /dev/ttyb*
329 %attr(666,root, tty) /dev/ttyc*
330 %attr(666,root, tty) /dev/ttyd*
331 %attr(666,root, tty) /dev/ttye*
332 %attr(666,root, tty) /dev/ttyp*
333 %attr(666,root, tty) /dev/ttyq*
334 %attr(666,root, tty) /dev/ttyr*
335 %attr(666,root, tty) /dev/ttys*
336 %attr(666,root, tty) /dev/ttyt*
337 %attr(666,root, tty) /dev/ttyu*
338 %attr(666,root, tty) /dev/ttyv*
339 %attr(666,root, tty) /dev/ttyw*
340 %attr(666,root, tty) /dev/ttyx*
341 %attr(666,root, tty) /dev/ttyy*
342 %attr(666,root, tty) /dev/ttyz*
343
344 #u#
345 %attr(644,root,root) /dev/urandom
346
347 #v#
348 %attr(620,root,tty) /dev/vcs*
349
350 #w#
351 %attr(600,root,root) /dev/watchdog
352
353 #x#
354 %attr(640,root,disk) /dev/xd*
355
356 #y#
357
358 #z#
359 %attr(666,root,root) /dev/zero
360
361 %changelog
362 * Thu Apr 22 1999 Wojciech "Sas" Ciêciwa <cieciwa@alpha.zarz.agh.edu.pl>
363   [2.5.9-4]
364 - /dev/log moved to sysklog package.
365
366 * Sat Dec 12 1998 Sergiusz Paw³owicz <ser@hyperreal.art.pl>
367   [2.5.9-1d]
368 - added polish translation to spec (regards to PLD Team),
369 - added handles to Unix98 pty support,
370 - added handles to framebuffer support,
371 - revised spec file, adding group 'floppy' removed.
372 - removed initctl -- SysVinit provides it.
373 - rewrote spec && major changes. 
374
375 * Fri May 08 1998 Michael K. Johnson <johnsonm@redhat.com>
376 - added paride devices
377
378 * Tue May 05 1998 Erik Troan <ewt@redhat.com>
379 - uses a filelist
380 - ghosts /dev/log
381
382 * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
383 - fixed groupadd call in the %install
384
385 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
386 - translations modified for de
387
388 * Thu Apr 23 1998 Prospector System <bugs@redhat.com>
389 - translations modified for fr, tr
390
391 * Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
392 - fixed preinstall script
393
394 * Tue Apr 21 1998 Erik Troan <ewt@redhat.com>
395 - updated groupadd to work with upgrades where the floppy group already exists
396
397 * Mon Nov 10 1997 Michael K. Johnson <johnsonm@redhat.com>
398 - Added more ramdisk entries
399
400 * Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
401 - Added fd and ramdisk symlinks
402
403 * Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
404 - Added floppy group for floppies; made them group-writable.
405
406 * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
407 - added bpcd device
408
409 * Thu Apr 10 1997 Erik Troan <ewt@redhat.com>
410 - Added ftape devices
411
412 * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
413 - Fixed stdin, stdout devices.
414 - Moved rtc to cpio archive
415 - Added ISDN devices
This page took 0.0922500000000001 seconds and 4 git commands to generate.