]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
Rel 12; disable debug packages
[packages/dev.git] / dev.spec
1 Summary:        /dev entries
2 Summary(de.UTF-8):      /dev-Einträge
3 Summary(fr.UTF-8):      Entrées de /dev
4 Summary(pl.UTF-8):      Pliki specjalne /dev/*
5 Summary(tr.UTF-8):      /dev dizini
6 Name:           dev
7 Version:        3.4
8 Release:        12
9 License:        Public Domain
10 Group:          Base
11 Source0:        %{name}-list
12 Requires:       setup >= 2.6.1-1
13 Provides:       devfs
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %define _enable_debug_packages  0
17
18 %description
19 Unix and Unix-like systems (including Linux) use file system entries
20 to represent devices attached to the machine. All of these entries are
21 in the /dev tree (though they don't have to be), and this package
22 contains the most commonly used /dev entries. These files are
23 essential for a system to function properly.
24
25 %description -l de.UTF-8
26 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
27 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge
28 befinden sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses
29 Paket enthält die üblichsten /dev-Einträge. Diese Dateien sind für das
30 Funktionieren eines Systems unbedingt erforderlich.
31
32 %description -l fr.UTF-8
33 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
34 représenter les périphériques reliés à la machine. Toutes ces entrées
35 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
36 contient les entrées /dev les plus courantes. Elles sont essentielles
37 pour qu'un système fonctionne correctement.
38
39 %description -l pl.UTF-8
40 Wszystkie systemy klasy unices, w tym Linux, używają plików do
41 przedstawiania urządzeń podłączonych do komputera. Wszystkie te pliki
42 znajdują się zwykle w katalogu /dev. Pakiet ten zawiera większość
43 popularnych plików specjalnych, są one jedną z ważniejszych części
44 prawidłowo działającego systemu operacyjnego.
45
46 %description -l tr.UTF-8
47 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya
48 bağlı aygıtları göstermek için özel dosyalar kullanırlar. Bu özel
49 dosyaların tümü /dev dizin yapısı altındadır. Bu paket en çok
50 kullanılan /dev dosyalarını içerir. Bu dosyalar, bir sistemin düzgün
51 olarak işleyebilmesi için temel gereksinimlerdendir.
52
53 %prep
54 %setup -q -c -T
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT/dev/{ataraid,cciss,cdemu,cdroms,cpu/{0,1,2,3,4,5,6,7},cgroup,cpuset} \
59         $RPM_BUILD_ROOT/dev/{discs,dri,etherd,i2o,ida,input,mapper,net,pts,raw,rd,usb,shm,snd,zap}
60
61 install %{SOURCE0} .
62
63 cd $RPM_BUILD_ROOT/dev
64 ln -sf adsp0 adsp
65 ln -sf amidi0 amidi
66 ln -sf audio0 audio
67 ln -sf dsp0 dsp
68 ln -sf fb0 fb
69 ln -sf rft0 ftape
70 ln -sf isdnctrl0 isdnctrl
71 ln -sf midi00 midi
72 ln -sf mixer0 mixer
73 ln -sf nrft0 nftape
74 ln -sf ram0 ramdisk
75
76 ln -sf em8300-0         em8300
77 ln -sf em8300_ma-0      em8300_ma
78 ln -sf em8300_mv-0      em8300_mv
79 ln -sf em8300_sp-0      em8300_sp
80 for i in `seq 0 31`; do
81         ln -sf fb$i fb${i}current
82 done
83 ln -sf /proc/self/fd fd
84 ln -sf fd/0 stdin
85 ln -sf fd/1 stdout
86 ln -sf fd/2 stderr
87 i=0;
88 for l in a b c d e f g h i j k l m n o p; do
89         ln -sf sg$l sg$i
90         i=$((i+1))
91 done
92 ln -sf radio0 radio
93 ln -sf music sequencer2
94 ln -sf vbi0 vbi
95 ln -sf video0 video
96 ln -sf vtx0 vtx
97
98 # prepared for SysVinit
99 mkfifo initctl
100
101 mkfifo lircm
102 mkfifo printer
103
104 # prepared for Log Daemon
105 mkfifo syslog
106
107 %ifarch m68k
108 ln -sf amigamouse mouse
109 %endif
110
111 %ifarch ppc
112 ln -sf adbmouse mouse
113 %endif
114
115 %ifarch sparc sparc64 sparcv9
116 ln -sf sunmouse mouse
117 %endif
118
119 # PLD-forklor:
120 ln -sf null drzewo
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %files -f dev-list
126 %defattr(644,root,root,755)
127 %dir /dev/ataraid
128 %dir /dev/cciss
129 %dir /dev/cdemu
130 %dir /dev/cgroup
131 %dir /dev/cpu
132 %dir /dev/cpu/0
133 %dir /dev/cpu/1
134 %dir /dev/cpu/2
135 %dir /dev/cpu/3
136 %dir /dev/cpu/4
137 %dir /dev/cpu/5
138 %dir /dev/cpu/6
139 %dir /dev/cpu/7
140 %dir /dev/cpuset
141 %dir /dev/dri
142 %attr(750,root,disk) %dir /dev/cdroms
143 %attr(750,root,disk) %dir /dev/discs
144 %dir /dev/etherd
145 %dir /dev/i2o
146 %dir /dev/ida
147 %dir /dev/input
148 %dir /dev/mapper
149 %dir /dev/net
150 %dir /dev/pts
151 %dir /dev/raw
152 %dir /dev/rd
153 %dir /dev/usb
154 %dir /dev/zap
155 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/adsp
156 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/amidi
157 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/audio
158 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/dsp
159 %config(noreplace) %verify(not link) %attr(660,root,video) /dev/fb
160 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ftape
161 %config(noreplace) %verify(not link) %attr(600,root,root) /dev/isdnctrl
162 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/midi
163 %config(noreplace) %verify(not link) %attr(660,root,audio) /dev/mixer
164 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/nftape
165 %config(noreplace) %verify(not link) %attr(660,root,disk) /dev/ramdisk
166 %attr(660,root,video) /dev/em8300*
167 %attr(660,root,video) /dev/fb[0-9]*current
168 /dev/fd
169 /dev/stdin
170 /dev/stdout
171 /dev/stderr
172 %attr(660,root,video) /dev/radio
173 %attr(660,root,audio) /dev/sequencer2
174 %attr(600,root,root) /dev/sg[0-9]
175 %attr(600,root,root) /dev/sg1[0-5]
176 %attr(1777,root,root) %dir /dev/shm
177 %dir /dev/snd
178 %attr(660,root,video) /dev/vbi
179 %attr(660,root,video) /dev/video
180 %attr(660,root,video) /dev/vtx
181 %attr(600,root,root) /dev/initctl
182 %attr(660,root,root) /dev/lircm
183 %attr(600,root,root) /dev/printer
184 %attr(666,root,root) /dev/syslog
185 %attr(666,root,root) /dev/drzewo
186
187 %ifarch %{ix86}
188 %dev(c,10,181) %attr(666,root,root) /dev/toshiba
189 %dev(c,212,0) %attr(600,root,root) /dev/slamr0
190 %dev(c,213,0) %attr(600,root,root) /dev/slusb0
191 %dev(c,226,0) %attr(660,root,video) /dev/dri/card0
192 %dev(c,226,1) %attr(660,root,video) /dev/dri/card1
193 %dev(c,226,2) %attr(660,root,video) /dev/dri/card2
194 %dev(c,226,3) %attr(660,root,video) /dev/dri/card3
195 %dev(c,226,4) %attr(660,root,video) /dev/dri/card4
196 %dev(c,226,5) %attr(660,root,video) /dev/dri/card5
197 %dev(c,226,6) %attr(660,root,video) /dev/dri/card6
198 %dev(c,226,7) %attr(660,root,video) /dev/dri/card7
199 %endif
200
201 %ifarch %{ix86} %{x8664}
202 %dev(c,10,227) %attr(600,root,root) /dev/mcelog
203 %dev(c,10,184) %attr(666,root,root) /dev/cpu/microcode
204 %endif
205
206 %ifarch m68k
207 %dev(b,2,4) %attr(660,root,floppy) /dev/fdhd0
208 %dev(b,2,5) %attr(660,root,floppy) /dev/fdhd1
209 # XXX: which permissions???
210 %dev(c,10,4) %attr(664,root,root) /dev/amigamouse
211 %attr(664,root,root) /dev/mouse
212 %dev(c,10,5) %attr(664,root,root) /dev/atarimouse
213 %dev(c,10,7) %attr(664,root,root) /dev/apollomouse
214 %endif
215
216 %ifarch ppc
217 %dev(c,56,0) /dev/adb
218 %dev(c,10,10) /dev/adbmouse
219 /dev/mouse
220 %dev(c,10,154) /dev/pmu
221 %dev(c,10,198) /dev/sheep_net
222 %endif
223
224 %ifarch sparc sparc64 sparcv9
225 %dev(c,14,7) %attr(660,root,audio) /dev/audioctl
226 # XXX: which permissions ???
227 %dev(c,10,139) %attr(600,root,root) /dev/openprom
228 %dev(c,10,6) %attr(664,root,root) /dev/sunmouse
229 %attr(664,root,root) /dev/mouse
230 %endif
231
232 %ifarch m68k sparc sparc64 sparcv9
233 # XXX: which permissions???
234 %dev(c,11,00) %attr(600,root,root) /dev/kbd
235 %endif
236
237 %ifnarch m68k sparc sparc64 sparcv9
238 %dev(c,10,3) %attr(664,root,root) /dev/atibm
239 %dev(b,29,0) %attr(660,root,disk) /dev/aztcd
240 %dev(b,15,0) %attr(660,root,disk) /dev/cdu31a
241 %dev(b,24,0) %attr(660,root,disk) /dev/cdu535
242 %dev(b,32,0) %attr(660,root,disk) /dev/cm206cd
243 %dev(b,16,0) %attr(660,root,disk) /dev/gscd
244 %dev(c,10,2) %attr(664,root,root) /dev/inportbm
245 %dev(c,10,0) %attr(664,root,root) /dev/logibm
246 %dev(b,23,0) %attr(660,root,disk) /dev/mcd
247 %dev(c,10,1) %attr(664,root,root) /dev/psaux
248 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd
249 %dev(b,25,0) %attr(660,root,disk) /dev/sbpcd0
250 %dev(b,25,1) %attr(660,root,disk) /dev/sbpcd1
251 %dev(b,25,2) %attr(660,root,disk) /dev/sbpcd2
252 %dev(b,25,3) %attr(660,root,disk) /dev/sbpcd3
253 %dev(b,18,0) %attr(660,root,disk) /dev/sjcd
254 %dev(b,15,0) %attr(660,root,disk) /dev/sonycd
255 %endif
This page took 0.0763 seconds and 4 git commands to generate.