]> git.pld-linux.org Git - packages/dev.git/blob - dev.spec
- added Group(pl)
[packages/dev.git] / dev.spec
1 Summary:     /dev entries
2 Summary(fr): Entrées de /dev.
3 Summary(tr): /dev dizini
4 Summary(de): /dev-Einträge
5 Summary(pl): Pliki specjalne /dev/*
6 Name:        dev
7 Version:     2.5.9
8 Release:     2d
9 #######      From ftp.redhat.com/rawhide
10 Source:      %{name}-%{version}.cpio
11 Copyright:   public domain
12 Group:       Base
13 Group(pl):   Bazowe
14 Autoreqprov: no
15 Requires:    shadow
16 Buildroot:   /tmp/buildroot-%{name}-%{version}
17
18 %description
19 Unix and unix like systems (including Linux) use file system entries
20 to represent devices attached to the machine. All of these entries
21 are in the /dev tree (though they don't have to be), and this package
22 contains the most commonly used /dev entries. These files are essential
23 for a system to function properly.
24
25 %description -l fr
26 Unix et les systèmes apparentés (dont Linux) utilise des fichiers pour
27 représenter les périphériques reliés à la machine. Toutes ces entrées
28 sont dans l'arborescence /dev (ce n'est pas obligatoire). Ce paquetage
29 contient les entrées /dev les plus courantes. Elles sont essentielles
30 pour qu'un système fonctionne correctement.
31
32 %description -l tr
33 Unix ve Unix benzeri sistemler (Linux da dahil olmak üzere), makinaya baðlý
34 aygýtlarý göstermek için özel dosyalar kullanýrlar. Bu özel dosyalarýn tümü
35 /dev dizin yapýsý altýndadýr. Bu paket en çok kullanýlan /dev dosyalarýný
36 içerir. Bu dosyalar, bir sistemin düzgün olarak iþleyebilmesi için temel
37 gereksinimlerdendir.
38
39 %description -l de
40 Unix und Unix-ähnliche Systeme (inkl. Linux) verwenden Dateisystem-
41 Einträge zum Darstellen angeschlossener Geräte. Diese Einträge befinden
42 sich (nicht notwendigerweise) im Verzeichnis /dev. Dieses Paket enthält
43 die üblichsten /dev-Einträge. Diese Dateien sind für das Funktionieren
44 eines Systems unbedingt erforderlich.
45
46 %description -l pl
47 Systemy Unix i unixopodobne (np. Linux) u¿ywaj± plików do przedstawienia
48 urz±dzeñ pod³±czonych do komputera. Wszystkie te pliki znajduj± siê zwykle
49 w katalogu /dev. Pakiet ten zawiera wiêkszo¶æ popularnych plików specjalnych.
50 S± one jedn± z wa¿niejszych czê¶ci prawid³owo dzia³aj±cego systemu.
51
52 %prep
53 %setup -q -c -T
54 rm -rf $RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT
57 BUILD_DIR=`pwd`
58
59 # unpack in build root
60 ( cd $RPM_BUILD_ROOT
61   cpio -iumd < %{SOURCE0}
62 )
63
64 # do some cleanup in build root
65 cd $RPM_BUILD_ROOT
66
67 %ifarch sparc
68 # SPARC specific devices
69 ln -s sunmouse dev/mouse
70 mknod dev/fb0 c 29 0
71 mknod dev/fb1 c 29 32
72 mknod dev/kbd c 11 0
73 mknod dev/openprom c 10 139
74 ln -s fb0 dev/fb
75 chmod 666 dev/fb*
76
77 # remove devices that will *never* exist on a SPARC
78 rm -f dev/hd* dev/aztcd dev/mcd dev/sbpcd1 dev/cdu31a dev/sbpcd2 dev/scd3
79 rm -f dev/sjcd dev/cdu535 dev/sbpcd3 dev/sonycd dev/cm206cd dev/sbpcd
80 rm -f dev/gscd dev/sbpcd0 dev/atibm dev/inportbm dev/logibm dev/psaux
81
82 %endif
83
84 chmod 660 dev/lp*
85 chgrp daemon dev/lp*
86
87 for I in 9 10 11 12; do
88         mknod dev/tty$I c 4 $I
89         chown root:tty dev/tty$I
90         chmod 600 dev/tty$I
91 done
92
93 cd dev
94
95 chgrp floppy fd?*
96
97 ln -s ram0 ramdisk
98 ln -s ../proc/self/fd fd
99
100 mknod pda  b 45 0
101 mknod pda1 b 45 1
102 mknod pda2 b 45 2
103 mknod pda3 b 45 3
104 mknod pda4 b 45 4
105
106 mknod pdb  b 45 16
107 mknod pdb1 b 45 17
108 mknod pdb2 b 45 18
109 mknod pdb3 b 45 19
110 mknod pdb4 b 45 20
111
112 mknod pdc  b 45 32
113 mknod pdc1 b 45 33
114 mknod pdc2 b 45 34
115 mknod pdc3 b 45 35
116 mknod pdc4 b 45 36
117
118 mknod pdd  b 45 48
119 mknod pdd1 b 45 49
120 mknod pdd2 b 45 50
121 mknod pdd3 b 45 51
122 mknod pdd4 b 45 52
123
124 mknod pcd0 b 46 0
125 mknod pcd1 b 46 1
126 mknod pcd2 b 46 2
127 mknod pcd3 b 46 3
128
129 mknod pf0 b 47 0
130 mknod pf1 b 47 1
131 mknod pf2 b 47 2
132 mknod pf3 b 47 3
133
134 mknod pt0  c 96 0
135 mknod pt1  c 96 1
136 mknod pt2  c 96 2
137 mknod pt3  c 96 3
138
139 chmod 0660      pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
140 chown root:disk pd[a-d]* pcd[0-3] pf[0-3] pt[0-3]
141
142 # unix98 pty support 
143 mknod ptmx c 5 2
144 chmod 666 ptmx; chown root.tty ptmx
145 install -d -m 755 pts
146
147 # framebuffer support
148 mknod fb0 b 29 0
149 mknod fb1 b 29 32
150 mknod fb2 b 29 64
151 mknod fb3 b 29 96
152 mknod fb4 b 29 128
153 mknod fb5 b 29 160
154 mknod fb6 b 29 192
155 mknod fb7 b 29 224
156
157 ln -s fb0 fb0current
158 ln -s fb1 fb1current
159 ln -s fb2 fb2current
160 ln -s fb3 fb3current
161 ln -s fb4 fb4current
162 ln -s fb5 fb5current
163 ln -s fb6 fb6current
164 ln -s fb7 fb7current
165
166 # watchdog support
167 mknod watchdog c 10 130 
168
169 # /dev/log support
170 touch log
171
172 # scsi directory
173 install -d scsi
174
175 %clean 
176 rm -rf $RPM_BUILD_ROOT
177
178 %files 
179 %defattr(644,root,root,755)
180
181 %dir /dev/pts
182 %dir /dev/scsi
183
184 #a#
185 %attr(664,root,root) /dev/atibm
186 %attr(662,root, sys) /dev/audio
187 %attr(662,root, sys) /dev/audio1
188 %attr(664,root,root) /dev/aztcd
189
190 #b#
191 %attr(664,root,root) /dev/bpcd
192
193 #c#
194 %attr(664,root,root) /dev/cdu31a
195 %attr(640,root,disk) /dev/cdu535
196 %attr(664,root,root) /dev/cm206cd
197 %attr(600,root,root) /dev/console
198 %attr(666,root,root) /dev/cui*
199
200 #d#
201 %attr(662,root,sys) /dev/dsp
202 %attr(662,root,sys) /dev/dsp1
203
204 #e#
205
206 #f#
207 %attr(644,root,  root) /dev/fb*
208 %attr(664,root,floppy) /dev/fd*
209
210 #g#
211 %attr(664,root,root) /dev/gscd
212
213 #h#
214 %attr(660,root,disk) /dev/hd*
215 %attr(660,root,disk) /dev/ht0
216
217 #i#
218 %attr(664,root,root) /dev/inportbm
219 %attr(600,root,root) /dev/ippp*
220 %attr(600,root,root) /dev/isdnctrl*
221 %attr(444,root,root) /dev/isdninfo
222
223 #j#
224
225 #k#
226 %attr(640,root,kmem) /dev/kmem
227
228 #l#
229 %attr(666,root,root) /dev/log
230 %attr(664,root,root) /dev/logibm
231 %attr(660,root,disk) /dev/loop*
232
233 %attr(660,root,daemon) /dev/lp*
234
235 #m#
236 %attr(640,root,disk) /dev/mcd
237 %attr(640,root,kmem) /dev/mem
238 %attr(666,root, sys) /dev/midi*
239 %attr(666,root, sys) /dev/mixer
240 %attr(666,root, sys) /dev/mixer1
241
242 #n#
243 %attr(660,root,disk) /dev/nht0
244 %attr(660,root,disk) /dev/nrft*
245 %attr(660,root,disk) /dev/nst*
246 %attr(666,root,root) /dev/null
247
248 #o#
249 %attr(664,root,root) /dev/optcd
250
251 #p#
252 %attr(640,root,daemon) /dev/par*
253
254 %attr(660,root,disk) /dev/pcd*
255 %attr(660,root,disk) /dev/pd*
256 %attr(660,root,disk) /dev/pf*
257
258 %attr(640,root,kmem) /dev/port
259 %attr(600,root,root) /dev/printer
260 %attr(664,root,root) /dev/psaux
261
262 %attr(660,root,disk) /dev/pt0
263 %attr(660,root,disk) /dev/pt1
264 %attr(660,root,disk) /dev/pt2
265 %attr(660,root,disk) /dev/pt3
266
267 %attr(666,root,tty) /dev/ptmx
268 %attr(666,root,tty) /dev/pty*
269
270 #r#
271 %attr(640,root,disk) /dev/ram
272 %attr(660,root,disk) /dev/ram0
273 %attr(660,root,disk) /dev/ram1*
274 %attr(660,root,disk) /dev/ram2
275 %attr(660,root,disk) /dev/ram3
276 %attr(660,root,disk) /dev/ram4
277 %attr(660,root,disk) /dev/ram5
278 %attr(660,root,disk) /dev/ram6
279 %attr(660,root,disk) /dev/ram7
280 %attr(660,root,disk) /dev/ram8
281 %attr(660,root,disk) /dev/ram9
282
283 %attr(644,root,root) /dev/random
284 %attr(660,root,disk) /dev/rft*
285 %attr(664,root,root) /dev/rtc
286
287 #s#
288 %attr(640,root,disk) /dev/sbpc*
289
290 %attr(660,root,disk) /dev/scd*
291
292 %attr(660,root,disk) /dev/sda*
293 %attr(660,root,disk) /dev/sdb*
294 %attr(660,root,disk) /dev/sdc*
295 %attr(660,root,disk) /dev/sdd*
296 %attr(660,root,disk) /dev/sde*
297 %attr(660,root,disk) /dev/sdf*
298 %attr(660,root,disk) /dev/sdg*
299
300 %attr(664,root,sys) /dev/sequencer
301
302 %attr(600,root,sys) /dev/sg*
303
304 %attr(664,root,root) /dev/sjcd
305 %attr(666,root, sys) /dev/sndstat
306
307 %attr(640,root,disk) /dev/sonycd
308
309 %attr(660,root,disk) /dev/st*
310
311 %attr(664,root,root) /dev/sunmouse
312 %attr(600,root,root) /dev/systty
313
314 #t#
315 %attr(666,root,root) /dev/tty
316
317 %attr(600,root, tty) /dev/tty0
318 %attr(600,root, tty) /dev/tty1*
319 %attr(600,root, tty) /dev/tty2
320 %attr(600,root, tty) /dev/tty3
321 %attr(600,root, tty) /dev/tty4
322 %attr(600,root, tty) /dev/tty5
323 %attr(600,root, tty) /dev/tty6
324 %attr(600,root, tty) /dev/tty7
325 %attr(600,root, tty) /dev/tty8
326 %attr(600,root, tty) /dev/tty9
327
328
329 %attr(666,root,root) /dev/ttyI*
330
331 %attr(644,root,root) /dev/ttyS*
332
333 %attr(666,root, tty) /dev/ttya*
334 %attr(666,root, tty) /dev/ttyb*
335 %attr(666,root, tty) /dev/ttyc*
336 %attr(666,root, tty) /dev/ttyd*
337 %attr(666,root, tty) /dev/ttye*
338 %attr(666,root, tty) /dev/ttyp*
339 %attr(666,root, tty) /dev/ttyq*
340 %attr(666,root, tty) /dev/ttyr*
341 %attr(666,root, tty) /dev/ttys*
342 %attr(666,root, tty) /dev/ttyt*
343 %attr(666,root, tty) /dev/ttyu*
344 %attr(666,root, tty) /dev/ttyv*
345 %attr(666,root, tty) /dev/ttyw*
346 %attr(666,root, tty) /dev/ttyx*
347 %attr(666,root, tty) /dev/ttyy*
348 %attr(666,root, tty) /dev/ttyz*
349
350 #u#
351 %attr(644,root,root) /dev/urandom
352
353 #v#
354 %attr(620,root,tty) /dev/vcs*
355
356 #w#
357 %attr(600,root,root) /dev/watchdog
358
359 #x#
360 %attr(640,root,disk) /dev/xd*
361
362 #y#
363
364 #z#
365 %attr(666,root,root) /dev/zero
366
367 %changelog
368 * Sat Feb  6 1999 Micha³ Kuratczyk <kurkens@polbox.com>
369   [2.5.9-2d]
370 - added Group(pl)
371 - fixed pl translation
372 - cosmetic changes
373
374 * Sat Dec 12 1998 Sergiusz Paw³owicz <ser@hyperreal.art.pl>
375 [2.5.9-1d]
376 - added polish translation to spec (regards to PLD Team),
377 - added handles to Unix98 pty support,
378 - added handles to framebuffer support,
379 - revised spec file, adding group 'floppy' removed.
380 - removed initctl -- SysVinit provides it.
381 - rewrote spec && major changes. 
382
383 * Fri May 08 1998 Michael K. Johnson <johnsonm@redhat.com>
384 - added paride devices
385
386 * Tue May 05 1998 Erik Troan <ewt@redhat.com>
387 - uses a filelist
388 - ghosts /dev/log
389
390 * Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
391 - fixed groupadd call in the %install
392
393 * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
394 - translations modified for de
395
396 * Thu Apr 23 1998 Prospector System <bugs@redhat.com>
397 - translations modified for fr, tr
398
399 * Thu Apr 23 1998 Erik Troan <ewt@redhat.com>
400 - fixed preinstall script
401
402 * Tue Apr 21 1998 Erik Troan <ewt@redhat.com>
403 - updated groupadd to work with upgrades where the floppy group already exists
404
405 * Mon Nov 10 1997 Michael K. Johnson <johnsonm@redhat.com>
406 - Added more ramdisk entries
407
408 * Wed Oct 29 1997 Michael K. Johnson <johnsonm@redhat.com>
409 - Added fd and ramdisk symlinks
410
411 * Fri Oct 24 1997 Michael K. Johnson <johnsonm@redhat.com>
412 - Added floppy group for floppies; made them group-writable.
413
414 * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
415 - added bpcd device
416
417 * Thu Apr 10 1997 Erik Troan <ewt@redhat.com>
418 - Added ftape devices
419
420 * Tue Mar 25 1997 Erik Troan <ewt@redhat.com>
421 - Fixed stdin, stdout devices.
422 - Moved rtc to cpio archive
423 - Added ISDN devices
This page took 0.097574 seconds and 4 git commands to generate.