]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
fix packaged file permissions; package is noarch now
[packages/depot_tools.git] / depot_tools.spec
1 %define         snap    20130619
2 %define         rel             0.5
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{snap}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        https://src.chromium.org/svn/trunk/tools/depot_tools.zip?/%{name}-svn%{snap}.zip
10 # Source0-md5:  6cf6483d6da8d15848cbaa8857aae3ae
11 URL:            http://dev.chromium.org/developers/how-tos/depottools
12 BuildRequires:  unzip
13 Requires:       python
14 BuildArch:      noarch
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Chromium uses a package of scripts, the depot_tools, to manage
19 interaction with the Chromium source code repository and the Chromium
20 development process. It contains the following utilities:
21
22 - gclient: Meta-checkout tool managing both subversion and git
23   checkouts. It is similar to repo tool except that it works on Linux,
24   OS X, and Windows and supports both svn and git. On the other hand,
25   gclient doesn't integrate any code review functionality.
26 - gcl: Rietveld code review tool for subversion. The gcl tool runs
27   presubmit scripts.
28 - git-cl: Rietveld code review tool for git. The git-cl tool runs
29   presubmit scripts.
30 - hammer: (Obsolete) Wrapper script for building Chromium with the
31   SCons software construction tool.
32 - drover: Quickly revert svn commits.
33 - cpplint.py: Checks for C++ style compliance.
34 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
35 - repo: The repo tool.
36 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
37 - git-try: Try change tool for git users
38 - wtf: Displays the active git branches in a chromium os checkout.
39 - weekly: Displays the log of checkins for a particular developer
40   since a particular date for git checkouts.
41 - git-gs: Wrapper for git grep with relevant source types.
42 - zsh-goodies: Completion for zsh users.
43
44 %prep
45 %setup -qc
46 mv depot_tools/* .
47 rm -r depot_tools
48
49 # python 2.4 components
50 rm -r third_party/pymox
51 rm cpplint.py
52
53 # screw binaries and shipped dependencies and things useless to this platform
54 rm ninja*
55 find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
56 rm create-ntfs-junction.c
57
58 # tests
59 rm -r testing_support
60 rm -r tests
61
62 # other junk
63 rm -r bootstrap
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
68 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
69 # already in %doc
70 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
71
72 install -d $RPM_BUILD_ROOT%{_bindir}
73 cat > $RPM_BUILD_ROOT%{_bindir}/gclient <<'EOF'
74 #!/bin/sh
75 %{_datadir}/%{name}/gclient "$@"
76 EOF
77 chmod +x $RPM_BUILD_ROOT%{_bindir}/gclient
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc LICENSE README README.gclient
85 %attr(755,root,root) %{_bindir}/gclient
86 %dir %{_datadir}/%{name}
87 %attr(755,root,root) %{_datadir}/%{name}/apply_issue
88 %attr(755,root,root) %{_datadir}/%{name}/cbuildbot
89 %attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
90 %attr(755,root,root) %{_datadir}/%{name}/codereview.settings
91 %attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
92 %attr(755,root,root) %{_datadir}/%{name}/cros
93 %attr(755,root,root) %{_datadir}/%{name}/cros_sdk
94 %attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
95 %attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
96 %attr(755,root,root) %{_datadir}/%{name}/drover
97 %attr(755,root,root) %{_datadir}/%{name}/fetch
98 %attr(755,root,root) %{_datadir}/%{name}/gcl
99 %attr(755,root,root) %{_datadir}/%{name}/gclient
100 %attr(755,root,root) %{_datadir}/%{name}/git-cl
101 %attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
102 %attr(755,root,root) %{_datadir}/%{name}/git-crsync
103 %attr(755,root,root) %{_datadir}/%{name}/git-crup
104 %attr(755,root,root) %{_datadir}/%{name}/git-gs
105 %attr(755,root,root) %{_datadir}/%{name}/git-lkgr
106 %attr(755,root,root) %{_datadir}/%{name}/git-runhooks
107 %attr(755,root,root) %{_datadir}/%{name}/git-try
108 %attr(755,root,root) %{_datadir}/%{name}/hammer
109 %attr(755,root,root) %{_datadir}/%{name}/pylint
110 %attr(755,root,root) %{_datadir}/%{name}/pylintrc
111 %attr(755,root,root) %{_datadir}/%{name}/repo
112 %attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
113 %attr(755,root,root) %{_datadir}/%{name}/weekly
114 %attr(755,root,root) %{_datadir}/%{name}/wtf
115
116 %{_datadir}/%{name}/*.py
117 %{_datadir}/%{name}/profile.xml
118 %{_datadir}/%{name}/git-templates/
119 %{_datadir}/%{name}/git_utils/
120 %{_datadir}/%{name}/recipes/
121 %{_datadir}/%{name}/support/
122 %{_datadir}/%{name}/third_party/
123 %{_datadir}/%{name}/zsh-goodies/
This page took 0.097261 seconds and 4 git commands to generate.