]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
up to fresh snapshot (20131210, git aeab41a)
[packages/depot_tools.git] / depot_tools.spec
1 %define         subver  20131210
2 %define         rel             0.11
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{subver}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        %{name}-%{subver}-aeab41a.tar.xz
10 # Source0-md5:  5dd469c8ec03d03d48b7db886475bbfa
11 Patch0:         adjust-path.patch
12 URL:            http://dev.chromium.org/developers/how-tos/depottools
13 BuildRequires:  tar >= 1:1.22
14 BuildRequires:  xz
15 Requires:       python
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Chromium uses a package of scripts, the depot_tools, to manage
21 interaction with the Chromium source code repository and the Chromium
22 development process. It contains the following utilities:
23
24 - gclient: Meta-checkout tool managing both subversion and git
25   checkouts. It is similar to repo tool except that it works on Linux,
26   OS X, and Windows and supports both svn and git. On the other hand,
27   gclient doesn't integrate any code review functionality.
28 - gcl: Rietveld code review tool for subversion. The gcl tool runs
29   presubmit scripts.
30 - git-cl: Rietveld code review tool for git. The git-cl tool runs
31   presubmit scripts.
32 - hammer: (Obsolete) Wrapper script for building Chromium with the
33   SCons software construction tool.
34 - drover: Quickly revert svn commits.
35 - cpplint.py: Checks for C++ style compliance.
36 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
37 - repo: The repo tool.
38 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
39 - git-try: Try change tool for git users
40 - wtf: Displays the active git branches in a chromium os checkout.
41 - weekly: Displays the log of checkins for a particular developer
42   since a particular date for git checkouts.
43 - git-gs: Wrapper for git grep with relevant source types.
44 - zsh-goodies: Completion for zsh users.
45
46 %prep
47 %setup -qn %{name}-%{subver}
48 %patch0 -p1
49
50 cat > py-wrap.sh <<'EOF'
51 #!/bin/sh
52 exec %{__python} -B %{_datadir}/%{name}/$(basename "$0").py "$@"
53 EOF
54 chmod +x *.sh
55 ln -s git_cl.py git-cl.py
56
57 # python 2.4 components
58 rm -r third_party/pymox
59
60 # screw binaries and shipped dependencies and things useless to this platform
61 rm ninja*
62 find -type f '(' -name '*.exe' -o -name '*.bat' ')' | xargs rm -v
63 rm create-ntfs-junction.c
64
65 # tests
66 rm -r testing_support
67 rm -r tests
68
69 # other irrelevant junk
70 rm -r bootstrap
71 rm .gitignore
72 rm OWNERS WATCHLISTS
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT{%{_datadir}/%{name},%{_bindir}}
77 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
78 # already in %doc
79 rm $RPM_BUILD_ROOT%{_datadir}/%{name}/{LICENSE,README*}
80
81 for a in gclient gcl git-cl fetch; do
82         ln -s %{_datadir}/%{name}/py-wrap.sh $RPM_BUILD_ROOT%{_bindir}/$a
83 done
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc LICENSE README README.gclient
91 %attr(755,root,root) %{_bindir}/gcl
92 %attr(755,root,root) %{_bindir}/gclient
93 %attr(755,root,root) %{_bindir}/git-cl
94 %attr(755,root,root) %{_bindir}/fetch
95 %dir %{_datadir}/%{name}
96 %attr(755,root,root) %{_datadir}/%{name}/apply_issue
97 %attr(755,root,root) %{_datadir}/%{name}/cbuildbot
98 %attr(755,root,root) %{_datadir}/%{name}/chrome_set_ver
99 %attr(755,root,root) %{_datadir}/%{name}/codereview.settings
100 %attr(755,root,root) %{_datadir}/%{name}/create-chromium-git-src
101 %attr(755,root,root) %{_datadir}/%{name}/cros
102 %attr(755,root,root) %{_datadir}/%{name}/cros_sdk
103 %attr(755,root,root) %{_datadir}/%{name}/crup-runner.sh
104 %attr(755,root,root) %{_datadir}/%{name}/download_from_google_storage
105 %attr(755,root,root) %{_datadir}/%{name}/drover
106 %attr(755,root,root) %{_datadir}/%{name}/fetch
107 %attr(755,root,root) %{_datadir}/%{name}/gcl
108 %attr(755,root,root) %{_datadir}/%{name}/gclient
109 %attr(755,root,root) %{_datadir}/%{name}/git-cl
110 %attr(755,root,root) %{_datadir}/%{name}/git-cl-upload-hook
111 %attr(755,root,root) %{_datadir}/%{name}/git-crsync
112 %attr(755,root,root) %{_datadir}/%{name}/git-crup
113 %attr(755,root,root) %{_datadir}/%{name}/git-gs
114 %attr(755,root,root) %{_datadir}/%{name}/git-lkgr
115 %attr(755,root,root) %{_datadir}/%{name}/git-number
116 %attr(755,root,root) %{_datadir}/%{name}/git-runhooks
117 %attr(755,root,root) %{_datadir}/%{name}/git-try
118 %attr(755,root,root) %{_datadir}/%{name}/gn
119 %attr(755,root,root) %{_datadir}/%{name}/hammer
120 %attr(755,root,root) %{_datadir}/%{name}/py-wrap.sh
121 %attr(755,root,root) %{_datadir}/%{name}/pylint
122 %attr(755,root,root) %{_datadir}/%{name}/pylintrc
123 %attr(755,root,root) %{_datadir}/%{name}/repo
124 %attr(755,root,root) %{_datadir}/%{name}/update_depot_tools
125 %attr(755,root,root) %{_datadir}/%{name}/weekly
126 %attr(755,root,root) %{_datadir}/%{name}/wtf
127
128 %{_datadir}/%{name}/*.py
129 %{_datadir}/%{name}/profile.xml
130 %{_datadir}/%{name}/git-templates/
131 %{_datadir}/%{name}/git_utils/
132 %{_datadir}/%{name}/recipes/
133 %{_datadir}/%{name}/support/
134 %{_datadir}/%{name}/third_party/
135 %{_datadir}/%{name}/zsh-goodies/
This page took 0.03455 seconds and 4 git commands to generate.