]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
new, version 20101127 snapshot
[packages/depot_tools.git] / depot_tools.spec
1 %define         snap    20101127
2 %define         rel             0.1
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{snap}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 # svn co http://src.chromium.org/svn/trunk/tools/depot_tools
10 # mv depot_tools/ depot_tools-svn20101127
11 # tar cjvf ../SOURCES/depot_tools-svn20101127.tar.bz2
12 Source0:        http://src.chromium.org/%{name}-svn%{snap}.tar.bz2
13 # Source0-md5:  055bda1558ed3411e95dddcdd2575f11
14 URL:            http://dev.chromium.org/developers/how-tos/depottools
15 Requires:       python
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Chromium uses a package of scripts, the depot_tools, to manage
20 interaction with the Chromium source code repository and the Chromium
21 development process. It contains the following utilities: gclient:
22 Meta-checkout tool managing both subversion and git checkouts. It is
23 similar to repo tool except that it works on linux, mac and windows
24 and supports both svn and git. On the other hand, gclient doesn't
25 integrate any code review functionality.
26
27 - gcl: Rietveld code review tool for subversion. The gcl tool runs
28   presubmit scripts.
29 - git-cl: Rietveld code review tool for git. The git-cl tool runs
30   presubmit scripts.
31 - hammer: (Obsolete) Wrapper script for building Chromium with the
32   SCons software construction tool.
33 - drover: Quickly revert svn commits.
34 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
35 - repo: The repo tool.
36 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
37 - git-try: Try change tool for git users
38 - wtf: Displays the active git branches in a chromium os checkout.
39 - weekly: Displays the log of checkins for a particular developer
40   since a particular date for git checkouts.
41 - git-gs: Wrapper for git grep with relevant source types.
42 - zsh-goodies: Completion for zsh users.
43
44 %prep
45 %setup -q -n depot_tools-svn%{snap}
46 find . -type d -name .svn -exec rm -rf {} \; || true
47
48 # python 2.4 components
49 rm -rf third_party/pymox
50 rm -rf cpplint.py
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
55 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
56 install -d $RPM_BUILD_ROOT%{_bindir}
57 cat > $RPM_BUILD_ROOT%{_bindir}/gclient <<'EOF'
58 #!/bin/sh
59 %{_datadir}/%{name}/gclient "$@"
60 EOF
61 chmod +x $RPM_BUILD_ROOT%{_bindir}/gclient
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc LICENSE README README.gclient
69 %attr(755,root,root) %{_bindir}/gclient
70 %dir %{_datadir}/depot_tools
71 %{_datadir}/depot_tools/*
This page took 0.059603 seconds and 4 git commands to generate.