]> git.pld-linux.org Git - packages/depot_tools.git/blob - depot_tools.spec
up to 20130619 snapshot as .zip source
[packages/depot_tools.git] / depot_tools.spec
1 %define         snap    20130619
2 %define         rel             0.3
3 Summary:        A package of scripts called used to manage checkouts and code reviews
4 Name:           depot_tools
5 Version:        0.1
6 Release:        0.%{snap}.%{rel}
7 License:        BSD
8 Group:          Development/Tools
9 Source0:        https://src.chromium.org/svn/trunk/tools/depot_tools.zip?/%{name}-svn%{snap}.zip
10 # Source0-md5:  6cf6483d6da8d15848cbaa8857aae3ae
11 URL:            http://dev.chromium.org/developers/how-tos/depottools
12 BuildRequires:  unzip
13 Requires:       python
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Chromium uses a package of scripts, the depot_tools, to manage
18 interaction with the Chromium source code repository and the Chromium
19 development process. It contains the following utilities:
20
21 - gclient: Meta-checkout tool managing both subversion and git
22   checkouts. It is similar to repo tool except that it works on Linux,
23   OS X, and Windows and supports both svn and git. On the other hand,
24   gclient doesn't integrate any code review functionality.
25 - gcl: Rietveld code review tool for subversion. The gcl tool runs
26   presubmit scripts.
27 - git-cl: Rietveld code review tool for git. The git-cl tool runs
28   presubmit scripts.
29 - hammer: (Obsolete) Wrapper script for building Chromium with the
30   SCons software construction tool.
31 - drover: Quickly revert svn commits.
32 - cpplint.py: Checks for C++ style compliance.
33 - presubmit_support.py: Runs PRESUBMIT.py presubmit checks.
34 - repo: The repo tool.
35 - trychange.py: Try server tool. It is wrapped by gcl try and git-try.
36 - git-try: Try change tool for git users
37 - wtf: Displays the active git branches in a chromium os checkout.
38 - weekly: Displays the log of checkins for a particular developer
39   since a particular date for git checkouts.
40 - git-gs: Wrapper for git grep with relevant source types.
41 - zsh-goodies: Completion for zsh users.
42
43 %prep
44 %setup -qc
45 mv depot_tools/* .
46 rm -r depot_tools
47
48 # python 2.4 components
49 rm -r third_party/pymox
50 rm cpplint.py
51
52 %install
53 rm -rf $RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
55 cp -a . $RPM_BUILD_ROOT%{_datadir}/%{name}
56 install -d $RPM_BUILD_ROOT%{_bindir}
57 cat > $RPM_BUILD_ROOT%{_bindir}/gclient <<'EOF'
58 #!/bin/sh
59 %{_datadir}/%{name}/gclient "$@"
60 EOF
61 chmod +x $RPM_BUILD_ROOT%{_bindir}/gclient
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc LICENSE README README.gclient
69 %attr(755,root,root) %{_bindir}/gclient
70 %dir %{_datadir}/%{name}
71 %{_datadir}/%{name}/*
This page took 0.039924 seconds and 4 git commands to generate.