]> git.pld-linux.org Git - packages/dee.git/blob - dee.spec
move gi/overrides to python-dee package
[packages/dee.git] / dee.spec
1 Summary:        Model to synchronize multiple instances over DBus
2 Name:           dee
3 Version:        1.0.14
4 Release:        2
5 # GPLv3-licensed tests and examples are in the tarball, but not installed
6 License:        LGPL v3
7 Group:          Libraries
8 URL:            https://launchpad.net/dee
9 Source0:        http://launchpad.net/dee/1.0/%{version}/+download/%{name}-%{version}.tar.gz
10 # Source0-md5:  473b4181e26538af0fb753255da7945c
11 BuildRequires:  dbus-glib-devel
12 BuildRequires:  gobject-introspection-devel
13 BuildRequires:  gtk-doc
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildRequires:  vala
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 Libdee is a library that uses DBus to provide objects allowing you to
20 create Model-View-Controller type programs across DBus. It also
21 consists of utility objects which extend DBus allowing for
22 peer-to-peer discoverability of known objects without needing a
23 central registrar.
24
25 %package devel
26 Summary:        Development files for %{name}
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 The %{name}-devel package contains libraries and header files for
32 developing applications that use %{name}.
33
34 %package apidocs
35 Summary:        %{name} API documentation
36 Summary(pl.UTF-8):      Dokumentacja API biblioteki %{name}
37 Group:          Documentation
38
39 %description apidocs
40 API and internal documentation for %{name} library.
41
42 %description apidocs -l pl.UTF-8
43 Dokumentacja API biblioteki %{name}.
44
45 %package -n python-dee
46 Summary:        Python bindings for dee
47 Group:          Development/Languages/Python
48 Requires:       python-pygobject
49
50 %description -n python-dee
51 Python bindings for dee.
52
53 %prep
54 %setup -q
55
56 %build
57 %configure \
58         --disable-static \
59         --with-html-dir=%{_gtkdocdir}
60
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %py_postclean
71
72 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdee*.la
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %attr(755,root,root) %{_bindir}/dee-tool
83 %{_libdir}/girepository-1.0/*.typelib
84 %attr(755,root,root) %{_libdir}/libdee-*.so.*.*.*
85 %ghost %{_libdir}/libdee-*.so.4
86
87 %files  devel
88 %defattr(644,root,root,755)
89 %{_includedir}/dee-1.0
90 %{_libdir}/libdee*.so
91 %{_pkgconfigdir}/*.pc
92 %{_datadir}/gir-1.0/*.gir
93 %{_datadir}/vala/vapi/*.vapi
94 %{_datadir}/vala/vapi/*.deps
95
96 %files apidocs
97 %defattr(644,root,root,755)
98 %{_gtkdocdir}/dee-1.0
99
100 %files -n python-dee
101 %defattr(644,root,root,755)
102 %{py_sitedir}/gi/overrides/Dee.py[co]
This page took 0.194022 seconds and 3 git commands to generate.