]> git.pld-linux.org Git - packages/dee.git/blob - dee.spec
- release 10 (by relup.sh)
[packages/dee.git] / dee.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library build
4
5 Summary:        Model to synchronize multiple instances over DBus
6 Summary(pl.UTF-8):      Model synchronizacji wielu instancji poprzez DBus
7 Name:           dee
8 Version:        1.0.14
9 Release:        10
10 # GPLv3-licensed tests and examples are in the tarball, but not installed
11 License:        LGPL v3
12 Group:          Libraries
13 Source0:        http://launchpad.net/dee/1.0/%{version}/+download/%{name}-%{version}.tar.gz
14 # Source0-md5:  473b4181e26538af0fb753255da7945c
15 URL:            https://launchpad.net/dee
16 BuildRequires:  dbus-glib-devel
17 BuildRequires:  glib2-devel >= 1:2.26
18 BuildRequires:  gobject-introspection-devel >= 0.10.2
19 BuildRequires:  gtk-doc >= 1.8
20 BuildRequires:  libicu-devel >= 4.6
21 BuildRequires:  pkgconfig
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 # not needed for releases
24 #BuildRequires: vala
25 Requires:       glib2 >= 1:2.26
26 Requires:       libicu >= 4.6
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Libdee is a library that uses DBus to provide objects allowing you to
31 create Model-View-Controller type programs across DBus. It also
32 consists of utility objects which extend DBus allowing for
33 peer-to-peer discoverability of known objects without needing a
34 central registrar.
35
36 %description -l pl.UTF-8
37 Libdee to biblioteka wykorzystująca DBus w celu zapewnienia obiektów
38 pozwalających na tworzenie programów typu model-widok-kontroler
39 poprzez DBus. Składa się z obiektów narzędziowych rozszerzających DBus
40 o możliwość widzenia znanych obiektów w komunikacji peer-to-peer bez
41 potrzeby centralnego rejestru.
42
43 %package devel
44 Summary:        Development files for libdee
45 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libdee
46 Group:          Development/Libraries
47 Requires:       %{name} = %{version}-%{release}
48 Requires:       glib2-devel >= 1:2.26
49 Requires:       libicu-devel >= 4.6
50
51 %description devel
52 This package contains the header files for developing applications
53 that use libdee library.
54
55 %description devel -l pl.UTF-8
56 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia aplikacji
57 wykorzystujących bibliotekę libdee.
58
59 %package static
60 Summary:        Static libdee library
61 Summary(pl.UTF-8):      Biblioteka statyczna libdee
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static libdee library.
67
68 %description static -l pl.UTF-8
69 Biblioteka statyczna libdee.
70
71 %package apidocs
72 Summary:        Libdee API documentation
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki libdee
74 Group:          Documentation
75 %if "%{_rpmversion}" >= "5"
76 BuildArch:      noarch
77 %endif
78
79 %description apidocs
80 API documentation for libdee library.
81
82 %description apidocs -l pl.UTF-8
83 Dokumentacja API biblioteki libdee.
84
85 %package -n python-dee
86 Summary:        Python bindings for libdee
87 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libdee
88 Group:          Development/Languages/Python
89 Requires:       python-pygobject3
90
91 %description -n python-dee
92 Python bindings for libdee.
93
94 %description -n python-dee -l pl.UTF-8
95 Wiązania Pythona do biblioteki libdee.
96
97 %package -n vala-dee
98 Summary:        Libdee API for Vala language
99 Summary(pl.UTF-8):      API libdee dla języka Vala
100 Group:          Development/Libraries
101 Requires:       %{name}-devel = %{version}-%{release}
102 Requires:       vala
103
104 %description -n vala-dee
105 Libdee API for Vala language.
106
107 %description -n vala-dee -l pl.UTF-8
108 API libdee dla języka Vala.
109
110 %prep
111 %setup -q
112
113 %build
114 %configure \
115         --disable-silent-rules \
116         %{?with_static_libs:--enable-static} \
117         --with-html-dir=%{_gtkdocdir}
118
119 %{__make}
120
121 %install
122 rm -rf $RPM_BUILD_ROOT
123 install -d $RPM_BUILD_ROOT%{_gtkdocdir}
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %py_postclean
129
130 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdee*.la
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %post   -p /sbin/ldconfig
136 %postun -p /sbin/ldconfig
137
138 %files
139 %defattr(644,root,root,755)
140 %doc AUTHORS
141 %attr(755,root,root) %{_bindir}/dee-tool
142 %attr(755,root,root) %{_libdir}/libdee-1.0.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/libdee-1.0.so.4
144 %{_libdir}/girepository-1.0/Dee-1.0.typelib
145
146 %files devel
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libdee-1.0.so
149 %{_includedir}/dee-1.0
150 %{_pkgconfigdir}/dee-1.0.pc
151 %{_pkgconfigdir}/dee-icu-1.0.pc
152 %{_datadir}/gir-1.0/Dee-1.0.gir
153
154 %if %{with static_libs}
155 %files static
156 %defattr(644,root,root,755)
157 %{_libdir}/libdee-1.0.a
158 %endif
159
160 %files apidocs
161 %defattr(644,root,root,755)
162 %{_gtkdocdir}/dee-1.0
163
164 %files -n python-dee
165 %defattr(644,root,root,755)
166 %{py_sitedir}/gi/overrides/Dee.py[co]
167
168 %files -n vala-dee
169 %defattr(644,root,root,755)
170 %{_datadir}/vala/vapi/dee-1.0.vapi
171 %{_datadir}/vala/vapi/dee-1.0.deps
This page took 0.049771 seconds and 3 git commands to generate.