]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- builds now but not tested!
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5.9
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://download.sourceforge.net/ddt/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am_ac.patch
10 Patch1:         %{name}-cgi-to-cgic.patch
11 Patch2:         %{name}-bind-includes-hack.patch
12 URL:            http://www.ddts.org/
13 Source1:        %{name}-client.init
14 Source2:        %{name}-server.init
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  bind-devel >= 9.2.1-10
18 BuildRequires:  cgilibc-devel
19 BuildRequires:  openssl-devel >= 0.9.7
20 BuildRequires:  postgresql-c++-devel
21 BuildRequires:  libgcrypt-devel
22 BuildRequires:  regexx-devel
23 BuildRequires:  macrosystem-devel
24 BuildRequires:  opt
25 BuildRequires:  sgml-tools
26 Prereq:         chkconfig
27 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 DDT stands for Dynamic Dns Tools. The goal of the project is to
31 provide an open and free (in the GPL-sense) set of tools that will
32 permit the deployment of secure and reliable dynamic DNS services.
33
34 %description -l pl
35 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
36 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
37 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
38
39 %package clients
40 Summary:        Dynamic DNS Tools Client
41 Summary(pl):    Klient Dynamicznego DNSu
42 Group:          Applications/Networking
43
44 %description clients
45 Dynamic DNS Tools Client.
46
47 %description clients -l pl
48 Klient Dynamicznego DNSu.
49
50 %package cgi
51 Summary:        CGI scripts for Dynamic DNS Tools Server
52 Summary(pl):    Skrypty CGI do Serwera Dynamicznego DNSu
53 Group:          Applications/Networking
54 Requires:       webserver
55
56 %description cgi
57 CGI scripts for Dynamic DNS Tools Server.
58
59 %description cgi -l pl
60 Skrypty CGI do Serwera Dynamicznego DNSu.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 rm -f missing
70 %{__aclocal}
71 %{__autoconf}
72 %{__automake}
73 CPPFLAGS="-I%{_includedir}/cgilibc"; export CPPFLAGS
74 %configure \
75         --enable-docs \
76         --enable-server \
77         --enable-admin \
78         --with-pgsql-incdir=%{_includedir} \
79         --with-pgsql-libdir=%{_libdir}
80 # fixme
81 echo "all install:" > docs/Makefile
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
88 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
89 install -d $RPM_BUILD_ROOT/etc/logrotate.d
90 install -d $RPM_BUILD_ROOT/var/{lib/ddt-client,run/ddt}
91 install -d $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95         
96 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
97 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
98 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
99 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
100
101 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
102 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post
108 /sbin/chkconfig --add %{name}-server
109 if [ -f /var/lock/subsys/%{name}-server ]; then
110         /etc/rc.d/init.d/%{name}-server restart >&2
111 else
112         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
113 fi
114
115 %preun
116 if [ "$1" = "0" ]; then
117         if [ -f /var/lock/subsys/%{name}-server ]; then
118                 /etc/rc.d/init.d/%{name}-server stop >&2
119         fi
120         /sbin/chkconfig --del %{name}-server
121 fi
122
123 %post clients
124 /sbin/chkconfig --add %{name}-client
125 if [ -f /var/lock/subsys/%{name}-client ]; then
126         /etc/rc.d/init.d/%{name}-client restart >&2
127 else
128         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
129 fi
130
131 %preun clients
132 if [ "$1" = "0" ]; then
133         if [ -f /var/lock/subsys/%{name}-client ]; then
134                 /etc/rc.d/init.d/%{name}-client stop >&2
135         fi
136         /sbin/chkconfig --del %{name}-client
137 fi
138
139 %files
140 %defattr(644,root,root,755)
141 %doc AUTHORS BUGS NEWS README THANKS TODO
142 %doc docs/*.sgml docs/include/{named.conf,zonedb}
143 %doc server/*.sql
144 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
145 %attr(755,root,root) %{_sbindir}/ddtd
146 %{_mandir}/man8/ddtd.8*
147 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
148 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
149 %attr(644,root,root) %dir /var/lib/ddt-client
150 %attr(644,root,root) %dir /var/run/ddt
151
152 %files clients
153 %defattr(644,root,root,755)
154 %doc docs/DDT*.sgml
155 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
156 %attr(755,root,root) %{_sbindir}/ddtc
157 %attr(755,root,root) %{_sbindir}/ddtcd
158 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
159 %{_mandir}/man8/ddtc.8*
160 %{_mandir}/man8/ddtcd.8*
161 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
162
163 %files cgi
164 %defattr(644,root,root,755)
165 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
166 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
167 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.06293 seconds and 4 git commands to generate.