]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- /srv shouldn't be used, adding a blocker
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools server
2 Summary(pl):    Serwer dynamicznego DNS-u
3 Name:           ddt
4 Version:        0.5.9
5 Release:        3
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  30bb784bde3eef1e1a6eb61ab77f4b90
10 Source1:        %{name}-client.init
11 Source2:        %{name}-server.init
12 Patch0:         %{name}-am_ac.patch
13 Patch1:         %{name}-cgi-to-cgic.patch
14 Patch2:         %{name}-bind-includes-hack.patch
15 Patch3:         %{name}-nobody.patch
16 Patch4:         %{name}-postgresql.patch
17 URL:            http://www.ddts.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bind-devel >= 9.2.1-10
21 BuildRequires:  cgilibc-devel
22 BuildRequires:  fhs-compliance
23 BuildRequires:  libgcrypt-devel
24 BuildRequires:  macrosystem-devel
25 BuildRequires:  openssl-devel >= 0.9.7d
26 BuildRequires:  opt
27 BuildRequires:  postgresql-c++-devel
28 BuildRequires:  regexx-devel
29 BuildRequires:  sgml-tools
30 PreReq:         rc-scripts
31 Requires(post,preun):   /sbin/chkconfig
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 DDT stands for Dynamic DNS Tools. The goal of the project is to
36 provide an open and free (in the GPL-sense) set of tools that will
37 permit the deployment of secure and reliable dynamic DNS services.
38
39 %description -l pl
40 DDT oznacza Dynamiczne Narzêdzia DNS-u. Celem projektu jest
41 dostarczenie otwartego i wolnego (w sensie GPL) zestawu narzêdzi
42 pozwalaj±cych na stworzenie bezpiecznego i niezawodnego systemu
43 dynamicznego DNS-u.
44
45 %package clients
46 Summary:        Dynamic DNS Tools client
47 Summary(pl):    Klient dynamicznego DNS-u
48 Group:          Applications/Networking
49 PreReq:         rc-scripts
50 Requires(post,preun):   /sbin/chkconfig
51
52 %description clients
53 Dynamic DNS Tools client.
54
55 %description clients -l pl
56 Klient dynamicznego DNS-u.
57
58 %package cgi
59 Summary:        CGI scripts for Dynamic DNS Tools server
60 Summary(pl):    Skrypty CGI do serwera dynamicznego DNS-u
61 Group:          Applications/Networking
62 Requires:       webserver
63
64 %description cgi
65 CGI scripts for Dynamic DNS Tools server.
66
67 %description cgi -l pl
68 Skrypty CGI do serwera dynamicznego DNS-u.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p1
76 %patch4 -p1
77
78 %build
79 rm -f missing
80 %{__aclocal}
81 %{__autoconf}
82 %{__automake}
83 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
84 %configure \
85         --enable-docs \
86         --enable-server \
87         --enable-admin \
88         --with-pgsql-incdir=%{_includedir} \
89         --with-pgsql-libdir=%{_libdir}
90 # fixme
91 echo "all install:" > docs/Makefile
92
93 %{__make}
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
98         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d} \
99         $RPM_BUILD_ROOT{/etc/logrotate.d,/var/{lib/ddt-client,run/ddt}} \
100         $RPM_BUILD_ROOT/srv/httpd/{cgi-bin,html/%{name}}
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
106 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
107 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
108 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
109
110 install admin/templates/* $RPM_BUILD_ROOT/srv/httpd/html/%{name}
111 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/srv/httpd/cgi-bin
112
113 %clean
114 rm -rf $RPM_BUILD_ROOT
115
116 %post
117 /sbin/chkconfig --add %{name}-server
118 if [ -f /var/lock/subsys/%{name}-server ]; then
119         /etc/rc.d/init.d/%{name}-server restart >&2
120 else
121         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
122 fi
123
124 %preun
125 if [ "$1" = "0" ]; then
126         if [ -f /var/lock/subsys/%{name}-server ]; then
127                 /etc/rc.d/init.d/%{name}-server stop >&2
128         fi
129         /sbin/chkconfig --del %{name}-server
130 fi
131
132 %post clients
133 /sbin/chkconfig --add %{name}-client
134 if [ -f /var/lock/subsys/%{name}-client ]; then
135         /etc/rc.d/init.d/%{name}-client restart >&2
136 else
137         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
138 fi
139
140 %preun clients
141 if [ "$1" = "0" ]; then
142         if [ -f /var/lock/subsys/%{name}-client ]; then
143                 /etc/rc.d/init.d/%{name}-client stop >&2
144         fi
145         /sbin/chkconfig --del %{name}-client
146 fi
147
148 %files
149 %defattr(644,root,root,755)
150 %doc AUTHORS BUGS NEWS README THANKS TODO
151 %doc docs/*.sgml docs/include/{named.conf,zonedb}
152 %doc server/*.sql
153 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
154 %attr(755,root,root) %{_sbindir}/ddtd
155 %{_mandir}/man8/ddtd.8*
156 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
157 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
158 %attr(644,root,root) %dir /var/lib/ddt-client
159 %attr(644,root,root) %dir /var/run/ddt
160
161 %files clients
162 %defattr(644,root,root,755)
163 %doc docs/DDT*.sgml
164 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
165 %attr(755,root,root) %{_sbindir}/ddtc
166 %attr(755,root,root) %{_sbindir}/ddtcd
167 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
168 %{_mandir}/man8/ddtc.8*
169 %{_mandir}/man8/ddtcd.8*
170 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
171
172 %files cgi
173 %defattr(644,root,root,755)
174 %attr(755,root,root) /srv/httpd/cgi-bin/*.cgi
175 %attr(644,root,root) /srv/httpd/cgi-bin/*.conf
176 %attr(755,root,root) /srv/httpd/html/%{name}
This page took 1.092268 seconds and 4 git commands to generate.