]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- use nobody group instead of nogroup group
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5.9
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://download.sourceforge.net/ddt/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am_ac.patch
10 Patch1:         %{name}-cgi-to-cgic.patch
11 Patch2:         %{name}-bind-includes-hack.patch
12 Patch3:         %{name}-nobody.patch
13 URL:            http://www.ddts.org/
14 Source1:        %{name}-client.init
15 Source2:        %{name}-server.init
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  bind-devel >= 9.2.1-10
19 BuildRequires:  cgilibc-devel
20 BuildRequires:  openssl-devel >= 0.9.7
21 BuildRequires:  postgresql-c++-devel
22 BuildRequires:  libgcrypt-devel
23 BuildRequires:  regexx-devel
24 BuildRequires:  macrosystem-devel
25 BuildRequires:  opt
26 BuildRequires:  sgml-tools
27 Prereq:         chkconfig
28 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 DDT stands for Dynamic Dns Tools. The goal of the project is to
32 provide an open and free (in the GPL-sense) set of tools that will
33 permit the deployment of secure and reliable dynamic DNS services.
34
35 %description -l pl
36 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
37 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
38 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
39
40 %package clients
41 Summary:        Dynamic DNS Tools Client
42 Summary(pl):    Klient Dynamicznego DNSu
43 Group:          Applications/Networking
44
45 %description clients
46 Dynamic DNS Tools Client.
47
48 %description clients -l pl
49 Klient Dynamicznego DNSu.
50
51 %package cgi
52 Summary:        CGI scripts for Dynamic DNS Tools Server
53 Summary(pl):    Skrypty CGI do Serwera Dynamicznego DNSu
54 Group:          Applications/Networking
55 Requires:       webserver
56
57 %description cgi
58 CGI scripts for Dynamic DNS Tools Server.
59
60 %description cgi -l pl
61 Skrypty CGI do Serwera Dynamicznego DNSu.
62
63 %prep
64 %setup -q
65 %patch0 -p1
66 %patch1 -p1
67 %patch2 -p1
68 %patch3 -p1
69
70 %build
71 rm -f missing
72 %{__aclocal}
73 %{__autoconf}
74 %{__automake}
75 CPPFLAGS="-I%{_includedir}/cgilibc"; export CPPFLAGS
76 %configure \
77         --enable-docs \
78         --enable-server \
79         --enable-admin \
80         --with-pgsql-incdir=%{_includedir} \
81         --with-pgsql-libdir=%{_libdir}
82 # fixme
83 echo "all install:" > docs/Makefile
84
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
90 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
91 install -d $RPM_BUILD_ROOT/etc/logrotate.d
92 install -d $RPM_BUILD_ROOT/var/{lib/ddt-client,run/ddt}
93 install -d $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97         
98 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
99 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
100 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
101 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
102
103 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
104 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post
110 /sbin/chkconfig --add %{name}-server
111 if [ -f /var/lock/subsys/%{name}-server ]; then
112         /etc/rc.d/init.d/%{name}-server restart >&2
113 else
114         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
115 fi
116
117 %preun
118 if [ "$1" = "0" ]; then
119         if [ -f /var/lock/subsys/%{name}-server ]; then
120                 /etc/rc.d/init.d/%{name}-server stop >&2
121         fi
122         /sbin/chkconfig --del %{name}-server
123 fi
124
125 %post clients
126 /sbin/chkconfig --add %{name}-client
127 if [ -f /var/lock/subsys/%{name}-client ]; then
128         /etc/rc.d/init.d/%{name}-client restart >&2
129 else
130         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
131 fi
132
133 %preun clients
134 if [ "$1" = "0" ]; then
135         if [ -f /var/lock/subsys/%{name}-client ]; then
136                 /etc/rc.d/init.d/%{name}-client stop >&2
137         fi
138         /sbin/chkconfig --del %{name}-client
139 fi
140
141 %files
142 %defattr(644,root,root,755)
143 %doc AUTHORS BUGS NEWS README THANKS TODO
144 %doc docs/*.sgml docs/include/{named.conf,zonedb}
145 %doc server/*.sql
146 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
147 %attr(755,root,root) %{_sbindir}/ddtd
148 %{_mandir}/man8/ddtd.8*
149 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
150 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
151 %attr(644,root,root) %dir /var/lib/ddt-client
152 %attr(644,root,root) %dir /var/run/ddt
153
154 %files clients
155 %defattr(644,root,root,755)
156 %doc docs/DDT*.sgml
157 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
158 %attr(755,root,root) %{_sbindir}/ddtc
159 %attr(755,root,root) %{_sbindir}/ddtcd
160 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
161 %{_mandir}/man8/ddtc.8*
162 %{_mandir}/man8/ddtcd.8*
163 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
164
165 %files cgi
166 %defattr(644,root,root,755)
167 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
168 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
169 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.061145 seconds and 4 git commands to generate.