]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- caps unification, other cosmetics
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools server
2 Summary(pl):    Serwer dynamicznego DNS-u
3 Name:           ddt
4 Version:        0.5.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  30bb784bde3eef1e1a6eb61ab77f4b90
10 Source1:        %{name}-client.init
11 Source2:        %{name}-server.init
12 Patch0:         %{name}-am_ac.patch
13 Patch1:         %{name}-cgi-to-cgic.patch
14 Patch2:         %{name}-bind-includes-hack.patch
15 Patch3:         %{name}-nobody.patch
16 Patch4:         %{name}-postgresql.patch
17 URL:            http://www.ddts.org/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bind-devel >= 9.2.1-10
21 BuildRequires:  cgilibc-devel
22 BuildRequires:  libgcrypt-devel
23 BuildRequires:  macrosystem-devel
24 BuildRequires:  openssl-devel >= 0.9.7c
25 BuildRequires:  opt
26 BuildRequires:  postgresql-c++-devel
27 BuildRequires:  regexx-devel
28 BuildRequires:  sgml-tools
29 PreReq:         rc-scripts
30 Requires(post,preun):   /sbin/chkconfig
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 DDT stands for Dynamic DNS Tools. The goal of the project is to
35 provide an open and free (in the GPL-sense) set of tools that will
36 permit the deployment of secure and reliable dynamic DNS services.
37
38 %description -l pl
39 DDT oznacza Dynamiczne Narzêdzia DNS-u. Celem projektu jest
40 dostarczenie otwartego i wolnego (w sensie GPL) zestawu narzêdzi
41 pozwalaj±cych na stworzenie bezpiecznego i niezawodnego systemu
42 dynamicznego DNS-u.
43
44 %package clients
45 Summary:        Dynamic DNS Tools client
46 Summary(pl):    Klient dynamicznego DNS-u
47 Group:          Applications/Networking
48 PreReq:         rc-scripts
49 Requires(post,preun):   /sbin/chkconfig
50
51 %description clients
52 Dynamic DNS Tools client.
53
54 %description clients -l pl
55 Klient dynamicznego DNS-u.
56
57 %package cgi
58 Summary:        CGI scripts for Dynamic DNS Tools server
59 Summary(pl):    Skrypty CGI do serwera dynamicznego DNS-u
60 Group:          Applications/Networking
61 Requires:       webserver
62
63 %description cgi
64 CGI scripts for Dynamic DNS Tools server.
65
66 %description cgi -l pl
67 Skrypty CGI do serwera dynamicznego DNS-u.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74 %patch3 -p1
75 %patch4 -p1
76
77 %build
78 rm -f missing
79 %{__aclocal}
80 %{__autoconf}
81 %{__automake}
82 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
83 %configure \
84         --enable-docs \
85         --enable-server \
86         --enable-admin \
87         --with-pgsql-incdir=%{_includedir} \
88         --with-pgsql-libdir=%{_libdir}
89 # fixme
90 echo "all install:" > docs/Makefile
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
97         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d} \
98         $RPM_BUILD_ROOT{/etc/logrotate.d,/var/{lib/ddt-client,run/ddt}} \
99         $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
105 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
106 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
107 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
108
109 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
110 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %post
116 /sbin/chkconfig --add %{name}-server
117 if [ -f /var/lock/subsys/%{name}-server ]; then
118         /etc/rc.d/init.d/%{name}-server restart >&2
119 else
120         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
121 fi
122
123 %preun
124 if [ "$1" = "0" ]; then
125         if [ -f /var/lock/subsys/%{name}-server ]; then
126                 /etc/rc.d/init.d/%{name}-server stop >&2
127         fi
128         /sbin/chkconfig --del %{name}-server
129 fi
130
131 %post clients
132 /sbin/chkconfig --add %{name}-client
133 if [ -f /var/lock/subsys/%{name}-client ]; then
134         /etc/rc.d/init.d/%{name}-client restart >&2
135 else
136         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
137 fi
138
139 %preun clients
140 if [ "$1" = "0" ]; then
141         if [ -f /var/lock/subsys/%{name}-client ]; then
142                 /etc/rc.d/init.d/%{name}-client stop >&2
143         fi
144         /sbin/chkconfig --del %{name}-client
145 fi
146
147 %files
148 %defattr(644,root,root,755)
149 %doc AUTHORS BUGS NEWS README THANKS TODO
150 %doc docs/*.sgml docs/include/{named.conf,zonedb}
151 %doc server/*.sql
152 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
153 %attr(755,root,root) %{_sbindir}/ddtd
154 %{_mandir}/man8/ddtd.8*
155 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
156 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
157 %attr(644,root,root) %dir /var/lib/ddt-client
158 %attr(644,root,root) %dir /var/run/ddt
159
160 %files clients
161 %defattr(644,root,root,755)
162 %doc docs/DDT*.sgml
163 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
164 %attr(755,root,root) %{_sbindir}/ddtc
165 %attr(755,root,root) %{_sbindir}/ddtcd
166 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
167 %{_mandir}/man8/ddtc.8*
168 %{_mandir}/man8/ddtcd.8*
169 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
170
171 %files cgi
172 %defattr(644,root,root,755)
173 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
174 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
175 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.045776 seconds and 4 git commands to generate.