]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- postgresql-c++-devel -> libpqxx-devel
[packages/ddt.git] / ddt.spec
1 # TODO
2 #  - postgres deps and headers not working. (i failed to solve it)
3 #  - URL inexistent, http://sourceforge.net/projects/ddt/
4 Summary:        Dynamic DNS Tools server
5 Summary(pl):    Serwer dynamicznego DNS-u
6 Name:           ddt
7 Version:        0.5.9
8 Release:        3
9 License:        GPL
10 Group:          Networking/Daemons
11 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
12 # Source0-md5:  30bb784bde3eef1e1a6eb61ab77f4b90
13 Source1:        %{name}-client.init
14 Source2:        %{name}-server.init
15 Patch0:         %{name}-am_ac.patch
16 Patch1:         %{name}-cgi-to-cgic.patch
17 Patch2:         %{name}-bind-includes-hack.patch
18 Patch3:         %{name}-nobody.patch
19 Patch4:         %{name}-postgresql.patch
20 URL:            http://www.ddts.org/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  bind-devel >= 9.2.1-10
24 BuildRequires:  cgilibc-devel
25 BuildRequires:  fhs-compliance
26 BuildRequires:  libgcrypt-devel
27 BuildRequires:  macrosystem-devel
28 BuildRequires:  openssl-devel >= 0.9.7d
29 BuildRequires:  opt
30 BuildRequires:  libpqxx-devel
31 BuildRequires:  regexx-devel
32 BuildRequires:  sgml-tools
33 PreReq:         rc-scripts
34 Requires(post,preun):   /sbin/chkconfig
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 DDT stands for Dynamic DNS Tools. The goal of the project is to
39 provide an open and free (in the GPL-sense) set of tools that will
40 permit the deployment of secure and reliable dynamic DNS services.
41
42 %description -l pl
43 DDT oznacza Dynamiczne Narzêdzia DNS-u. Celem projektu jest
44 dostarczenie otwartego i wolnego (w sensie GPL) zestawu narzêdzi
45 pozwalaj±cych na stworzenie bezpiecznego i niezawodnego systemu
46 dynamicznego DNS-u.
47
48 %package clients
49 Summary:        Dynamic DNS Tools client
50 Summary(pl):    Klient dynamicznego DNS-u
51 Group:          Applications/Networking
52 PreReq:         rc-scripts
53 Requires(post,preun):   /sbin/chkconfig
54
55 %description clients
56 Dynamic DNS Tools client.
57
58 %description clients -l pl
59 Klient dynamicznego DNS-u.
60
61 %package cgi
62 Summary:        CGI scripts for Dynamic DNS Tools server
63 Summary(pl):    Skrypty CGI do serwera dynamicznego DNS-u
64 Group:          Applications/Networking
65 Requires:       webserver
66
67 %description cgi
68 CGI scripts for Dynamic DNS Tools server.
69
70 %description cgi -l pl
71 Skrypty CGI do serwera dynamicznego DNS-u.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p1
78 %patch3 -p1
79 %patch4 -p1
80
81 %build
82 rm -f missing
83 %{__aclocal}
84 %{__autoconf}
85 %{__automake}
86 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
87 %configure \
88         --enable-docs \
89         --enable-server \
90         --enable-admin \
91         --with-pgsql-incdir=%{_includedir} \
92         --with-pgsql-libdir=%{_libdir}
93 # fixme
94 echo "all install:" > docs/Makefile
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
101         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d} \
102         $RPM_BUILD_ROOT{/etc/logrotate.d,/var/{lib/ddt-client,run/ddt}} \
103         $RPM_BUILD_ROOT/srv/httpd/{cgi-bin,html/%{name}}
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
109 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
110 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
111 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
112
113 install admin/templates/* $RPM_BUILD_ROOT/srv/httpd/html/%{name}
114 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/srv/httpd/cgi-bin
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %post
120 /sbin/chkconfig --add %{name}-server
121 if [ -f /var/lock/subsys/%{name}-server ]; then
122         /etc/rc.d/init.d/%{name}-server restart >&2
123 else
124         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
125 fi
126
127 %preun
128 if [ "$1" = "0" ]; then
129         if [ -f /var/lock/subsys/%{name}-server ]; then
130                 /etc/rc.d/init.d/%{name}-server stop >&2
131         fi
132         /sbin/chkconfig --del %{name}-server
133 fi
134
135 %post clients
136 /sbin/chkconfig --add %{name}-client
137 if [ -f /var/lock/subsys/%{name}-client ]; then
138         /etc/rc.d/init.d/%{name}-client restart >&2
139 else
140         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
141 fi
142
143 %preun clients
144 if [ "$1" = "0" ]; then
145         if [ -f /var/lock/subsys/%{name}-client ]; then
146                 /etc/rc.d/init.d/%{name}-client stop >&2
147         fi
148         /sbin/chkconfig --del %{name}-client
149 fi
150
151 %files
152 %defattr(644,root,root,755)
153 %doc AUTHORS BUGS NEWS README THANKS TODO
154 %doc docs/*.sgml docs/include/{named.conf,zonedb}
155 %doc server/*.sql
156 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
157 %attr(755,root,root) %{_sbindir}/ddtd
158 %{_mandir}/man8/ddtd.8*
159 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
160 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
161 %attr(644,root,root) %dir /var/lib/ddt-client
162 %attr(644,root,root) %dir /var/run/ddt
163
164 %files clients
165 %defattr(644,root,root,755)
166 %doc docs/DDT*.sgml
167 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
168 %attr(755,root,root) %{_sbindir}/ddtc
169 %attr(755,root,root) %{_sbindir}/ddtcd
170 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
171 %{_mandir}/man8/ddtc.8*
172 %{_mandir}/man8/ddtcd.8*
173 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
174
175 %files cgi
176 %defattr(644,root,root,755)
177 %attr(755,root,root) /srv/httpd/cgi-bin/*.cgi
178 %attr(644,root,root) /srv/httpd/cgi-bin/*.conf
179 %attr(755,root,root) /srv/httpd/html/%{name}
This page took 0.113069 seconds and 4 git commands to generate.