]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- cosmetics Source0 url
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  30bb784bde3eef1e1a6eb61ab77f4b90
10 Patch0:         %{name}-am_ac.patch
11 Patch1:         %{name}-cgi-to-cgic.patch
12 Patch2:         %{name}-bind-includes-hack.patch
13 Patch3:         %{name}-nobody.patch
14 Patch4:         %{name}-postgresql.patch
15 URL:            http://www.ddts.org/
16 Source1:        %{name}-client.init
17 Source2:        %{name}-server.init
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bind-devel >= 9.2.1-10
21 BuildRequires:  cgilibc-devel
22 BuildRequires:  openssl-devel >= 0.9.7
23 BuildRequires:  postgresql-c++-devel
24 BuildRequires:  libgcrypt-devel
25 BuildRequires:  regexx-devel
26 BuildRequires:  macrosystem-devel
27 BuildRequires:  opt
28 BuildRequires:  sgml-tools
29 Prereq:         chkconfig
30 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 DDT stands for Dynamic Dns Tools. The goal of the project is to
34 provide an open and free (in the GPL-sense) set of tools that will
35 permit the deployment of secure and reliable dynamic DNS services.
36
37 %description -l pl
38 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
39 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
40 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
41
42 %package clients
43 Summary:        Dynamic DNS Tools Client
44 Summary(pl):    Klient Dynamicznego DNSu
45 Group:          Applications/Networking
46
47 %description clients
48 Dynamic DNS Tools Client.
49
50 %description clients -l pl
51 Klient Dynamicznego DNSu.
52
53 %package cgi
54 Summary:        CGI scripts for Dynamic DNS Tools Server
55 Summary(pl):    Skrypty CGI do Serwera Dynamicznego DNSu
56 Group:          Applications/Networking
57 Requires:       webserver
58
59 %description cgi
60 CGI scripts for Dynamic DNS Tools Server.
61
62 %description cgi -l pl
63 Skrypty CGI do Serwera Dynamicznego DNSu.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68 %patch1 -p1
69 %patch2 -p1
70 %patch3 -p1
71 %patch4 -p1
72
73 %build
74 rm -f missing
75 %{__aclocal}
76 %{__autoconf}
77 %{__automake}
78 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
79 %configure \
80         --enable-docs \
81         --enable-server \
82         --enable-admin \
83         --with-pgsql-incdir=%{_includedir} \
84         --with-pgsql-libdir=%{_libdir}
85 # fixme
86 echo "all install:" > docs/Makefile
87
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8}
93 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
94 install -d $RPM_BUILD_ROOT/etc/logrotate.d
95 install -d $RPM_BUILD_ROOT/var/{lib/ddt-client,run/ddt}
96 install -d $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100         
101 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
102 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
103 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
104 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
105
106 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
107 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin/
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /sbin/chkconfig --add %{name}-server
114 if [ -f /var/lock/subsys/%{name}-server ]; then
115         /etc/rc.d/init.d/%{name}-server restart >&2
116 else
117         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
118 fi
119
120 %preun
121 if [ "$1" = "0" ]; then
122         if [ -f /var/lock/subsys/%{name}-server ]; then
123                 /etc/rc.d/init.d/%{name}-server stop >&2
124         fi
125         /sbin/chkconfig --del %{name}-server
126 fi
127
128 %post clients
129 /sbin/chkconfig --add %{name}-client
130 if [ -f /var/lock/subsys/%{name}-client ]; then
131         /etc/rc.d/init.d/%{name}-client restart >&2
132 else
133         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
134 fi
135
136 %preun clients
137 if [ "$1" = "0" ]; then
138         if [ -f /var/lock/subsys/%{name}-client ]; then
139                 /etc/rc.d/init.d/%{name}-client stop >&2
140         fi
141         /sbin/chkconfig --del %{name}-client
142 fi
143
144 %files
145 %defattr(644,root,root,755)
146 %doc AUTHORS BUGS NEWS README THANKS TODO
147 %doc docs/*.sgml docs/include/{named.conf,zonedb}
148 %doc server/*.sql
149 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
150 %attr(755,root,root) %{_sbindir}/ddtd
151 %{_mandir}/man8/ddtd.8*
152 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
153 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
154 %attr(644,root,root) %dir /var/lib/ddt-client
155 %attr(644,root,root) %dir /var/run/ddt
156
157 %files clients
158 %defattr(644,root,root,755)
159 %doc docs/DDT*.sgml
160 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
161 %attr(755,root,root) %{_sbindir}/ddtc
162 %attr(755,root,root) %{_sbindir}/ddtcd
163 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
164 %{_mandir}/man8/ddtc.8*
165 %{_mandir}/man8/ddtcd.8*
166 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
167
168 %files cgi
169 %defattr(644,root,root,755)
170 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
171 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
172 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.08184 seconds and 4 git commands to generate.