]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
cosmetics
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5.9
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
9 # Source0-md5:  30bb784bde3eef1e1a6eb61ab77f4b90
10 Patch0:         %{name}-am_ac.patch
11 Patch1:         %{name}-cgi-to-cgic.patch
12 Patch2:         %{name}-bind-includes-hack.patch
13 Patch3:         %{name}-nobody.patch
14 Patch4:         %{name}-postgresql.patch
15 URL:            http://www.ddts.org/
16 Source1:        %{name}-client.init
17 Source2:        %{name}-server.init
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  bind-devel >= 9.2.1-10
21 BuildRequires:  cgilibc-devel
22 BuildRequires:  libgcrypt-devel
23 BuildRequires:  macrosystem-devel
24 BuildRequires:  openssl-devel >= 0.9.7
25 BuildRequires:  opt
26 BuildRequires:  postgresql-c++-devel
27 BuildRequires:  regexx-devel
28 BuildRequires:  sgml-tools
29 PreReq:         rc-scripts
30 Requires(post,preun):   /sbin/chkconfig
31 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 DDT stands for Dynamic Dns Tools. The goal of the project is to
35 provide an open and free (in the GPL-sense) set of tools that will
36 permit the deployment of secure and reliable dynamic DNS services.
37
38 %description -l pl
39 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
40 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
41 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
42
43 %package clients
44 Summary:        Dynamic DNS Tools Client
45 Summary(pl):    Klient Dynamicznego DNSu
46 Group:          Applications/Networking
47 PreReq:         rc-scripts
48 Requires(post,preun):   /sbin/chkconfig
49
50 %description clients
51 Dynamic DNS Tools Client.
52
53 %description clients -l pl
54 Klient Dynamicznego DNSu.
55
56 %package cgi
57 Summary:        CGI scripts for Dynamic DNS Tools Server
58 Summary(pl):    Skrypty CGI do Serwera Dynamicznego DNSu
59 Group:          Applications/Networking
60 Requires:       webserver
61
62 %description cgi
63 CGI scripts for Dynamic DNS Tools Server.
64
65 %description cgi -l pl
66 Skrypty CGI do Serwera Dynamicznego DNSu.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75
76 %build
77 rm -f missing
78 %{__aclocal}
79 %{__autoconf}
80 %{__automake}
81 CPPFLAGS="-I%{_includedir}/cgilibc -I%{_includedir}/postgresql/server"; export CPPFLAGS
82 %configure \
83         --enable-docs \
84         --enable-server \
85         --enable-admin \
86         --with-pgsql-incdir=%{_includedir} \
87         --with-pgsql-libdir=%{_libdir}
88 # fixme
89 echo "all install:" > docs/Makefile
90
91 %{__make}
92
93 %install
94 rm -rf $RPM_BUILD_ROOT
95 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
96         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d} \
97         $RPM_BUILD_ROOT{/etc/logrotate.d,/var/{lib/ddt-client,run/ddt}} \
98         $RPM_BUILD_ROOT/home/services/httpd/{cgi-bin,html/%{name}}
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102         
103 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-client
104 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-server
105 install debian/ddt-client.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-client
106 install debian/ddt-server.logrotate $RPM_BUILD_ROOT/etc/logrotate.d/%{name}-server
107
108 install admin/templates/* $RPM_BUILD_ROOT/home/services/httpd/html/%{name}
109 install admin/*.{conf,cgi} $RPM_BUILD_ROOT/home/services/httpd/cgi-bin
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post
115 /sbin/chkconfig --add %{name}-server
116 if [ -f /var/lock/subsys/%{name}-server ]; then
117         /etc/rc.d/init.d/%{name}-server restart >&2
118 else
119         echo "Run \"/etc/rc.d/init.d/%{name}-server start\" to start ddtd daemon."
120 fi
121
122 %preun
123 if [ "$1" = "0" ]; then
124         if [ -f /var/lock/subsys/%{name}-server ]; then
125                 /etc/rc.d/init.d/%{name}-server stop >&2
126         fi
127         /sbin/chkconfig --del %{name}-server
128 fi
129
130 %post clients
131 /sbin/chkconfig --add %{name}-client
132 if [ -f /var/lock/subsys/%{name}-client ]; then
133         /etc/rc.d/init.d/%{name}-client restart >&2
134 else
135         echo "Run \"/etc/rc.d/init.d/%{name}-client start\" to start ddtcd daemon."
136 fi
137
138 %preun clients
139 if [ "$1" = "0" ]; then
140         if [ -f /var/lock/subsys/%{name}-client ]; then
141                 /etc/rc.d/init.d/%{name}-client stop >&2
142         fi
143         /sbin/chkconfig --del %{name}-client
144 fi
145
146 %files
147 %defattr(644,root,root,755)
148 %doc AUTHORS BUGS NEWS README THANKS TODO
149 %doc docs/*.sgml docs/include/{named.conf,zonedb}
150 %doc server/*.sql
151 %attr(754,root,root) /etc/rc.d/init.d/%{name}-server
152 %attr(755,root,root) %{_sbindir}/ddtd
153 %{_mandir}/man8/ddtd.8*
154 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtd.conf
155 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-server
156 %attr(644,root,root) %dir /var/lib/ddt-client
157 %attr(644,root,root) %dir /var/run/ddt
158
159 %files clients
160 %defattr(644,root,root,755)
161 %doc docs/DDT*.sgml
162 %attr(754,root,root) /etc/rc.d/init.d/%{name}-client
163 %attr(755,root,root) %{_sbindir}/ddtc
164 %attr(755,root,root) %{_sbindir}/ddtcd
165 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/ddtcd.conf
166 %{_mandir}/man8/ddtc.8*
167 %{_mandir}/man8/ddtcd.8*
168 %attr(644,root,root) %config(noreplace) %verify(not size mtime md5) /etc/logrotate.d/%{name}-client
169
170 %files cgi
171 %defattr(644,root,root,755)
172 %attr(755,root,root) /home/services/httpd/cgi-bin/*.cgi
173 %attr(644,root,root) /home/services/httpd/cgi-bin/*.conf
174 %attr(755,root,root) /home/services/httpd/html/%{name}
This page took 0.0410970000000001 seconds and 4 git commands to generate.