]> git.pld-linux.org Git - packages/ddt.git/blob - ddt.spec
- force to use openssl >= 0.9.7, idea by kloczek
[packages/ddt.git] / ddt.spec
1 Summary:        Dynamic DNS Tools Server
2 Summary(pl):    Serwer dynamicznego DNSu
3 Name:           ddt
4 Version:        0.5
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://download.sourceforge.net/ddt/%{name}-%{version}.tar.gz
9 Patch0:         %{name}-am_ac.patch
10 URL:            http://www.ddt.org/
11 Source1:        %{name}.init
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  bind-devel >= 9.2.1-10
15 BuildRequires:  cgilib-devel
16 BuildRequires:  openssl-devel >= 0.9.7
17 BuildRequires:  opt
18 Prereq:         chkconfig
19 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 DDT stands for Dynamic Dns Tools. The goal of the project is to
23 provide an open and free (in the GPL-sense) set of tools that will
24 permit the deployment of secure and reliable dynamic DNS services.
25
26 %description -l pl
27 DDT oznacza Dynamiczne Narzêdzia DNS. Celem projektu jest dostarczenie
28 otwartego i wolnego (w sensie GPL) zestawu narzêdzi pozwalaj±cych na
29 stworzenie bezpiecznego i niezawodnego systemu dynamicznego DNS.
30
31 %package clients
32 Summary:        Dynamic DNS Tools Client
33 Summary(pl):    Klient Dynamicznego DNSu
34 Group:          Applications/Networking
35
36 %description clients
37 Dynamic DNS Tools Client.
38
39 %description clients -l pl
40 Klient Dynamicznego DNSu.
41
42 %prep
43 %setup -q
44 %patch0 -p1
45
46 %build
47 rm -f missing
48 %{__aclocal}
49 %{__autoconf}
50 %{__automake}
51 %configure \
52         --enable-docs \
53         --enable-server \
54         --enable-admin \
55         --with-pgsql-lib=%{_libdir} \
56         --with-pgsql-include=%{_includedir}/postgresql/server
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
62         $RPM_BUILD_ROOT{%{_sysconfdir},/etc/rc.d/init.d}
63
64 install client/ddtcd.conf $RPM_BUILD_ROOT%{_sysconfdir}
65 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/ddtcd
66
67 install client/{ddtc,ddtcd} $RPM_BUILD_ROOT%{_sbindir}
68 install client/{ddtc,ddtcd}.8 $RPM_BUILD_ROOT%{_mandir}/man8
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %post
74 /sbin/chkconfig --add ddtcd
75 if [ -f /var/lock/subsys/ddtcd ]; then
76         /etc/rc.d/init.d/ddtcd restart >&2
77 else
78         echo "Run \"/etc/rc.d/init.d/ddtcd start\" to start ddtcd daemon."
79 fi
80
81 %preun
82 if [ "$1" = "0" ]; then
83         if [ -f /var/lock/subsys/ddtcd ]; then
84                 /etc/rc.d/init.d/ddtcd stop >&2
85         fi
86         /sbin/chkconfig --del ddtcd
87 fi
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS README INSTALL THANKS ddt.lsm
92 %attr(754,root,root) /etc/rc.d/init.d/ddtcd
93 %config(noreplace) %{_sysconfdir}/ddtcd.conf
94 %attr(755,root,root) %{_sbindir}/ddtc
95 %attr(755,root,root) %{_sbindir}/ddtcd
96 %{_mandir}/man8/ddtc.8*
97 %{_mandir}/man8/ddtcd.8*
This page took 0.04988 seconds and 4 git commands to generate.