]> git.pld-linux.org Git - packages/dcron.git/blame - dcron.spec
mention difference with vixie cron
[packages/dcron.git] / dcron.spec
CommitLineData
2f80c398
ER
1# TODO
2# - crontab spool dir not compatible with other cron implementations
3# - package default hourly,monhtly,etc and provide crontabs name
4# - provides anacron functionality, O/P name?
5# - triggers for switching with other crondaemons (after testing)
6# - logrotate?
7# - systemd init
8# - crontab system group
9Summary: Lightweight Cron Daemon
10Name: dcron
11Version: 4.5
12Release: 0.1
13License: GPL v2+
14Group: Daemons
15Source0: http://www.jimpryor.net/linux/releases/%{name}-%{version}.tar.gz
16# Source0-md5: 078833f3281f96944fc30392b1888326
17Source1: %{name}.init
18Patch1: %{name}-fix_makefile.patch
19URL: http://www.jimpryor.net/linux/dcron.html
20BuildRequires: pkgconfig
21Provides: crondaemon
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25This lightweight cron daemon aims to be simple and secure, with just
26enough features to stay useful. It was written from scratch by Matt
27Dillon in 1994. It's now developed and maintained by Jim Pryor.
28
baccd64a
ER
29Dcron aims to be a simple, elegant and secure implementation of cron.
30It does not allow the specification of environment variables in
31crontabs and all cron-jobs are run from /bin/sh . Like Vixie cron,
32each user has his own crontab.
33
2f80c398
ER
34In the author's opinion, having to combine a cron daemon with another
35daemon like anacron makes for too much complexity. So the goal is a
36simple cron daemon that can also take over the central functions of
37anacron.
38
39%prep
40%setup -q
41%patch1
42
43%build
44%{__make} \
45 CC="%{__cc}" \
46 OPTFLAGS="%{rpmcflags}" \
47 PREFIX=%{_prefix} \
48 INSTALL="install -p"
49
50%install
51rm -rf $RPM_BUILD_ROOT
52install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d}
53%{__make} install \
54 DESTDIR=$RPM_BUILD_ROOT
55
56install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
57install -d $RPM_BUILD_ROOT%{_var}/spool/%{name}/{crontabs,cronstamps}
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(644,root,root,755)
64%doc CHANGELOG README
65%dir /etc/cron.d
66%attr(754,root,root) /etc/rc.d/init.d/crond
67%attr(755,root,root) %{_bindir}/crontab
68%attr(755,root,root) %{_sbindir}/crond
69%{_mandir}/man1/crontab.1.*
70%{_mandir}/man8/crond.8.*
71%dir %attr(700,root,root) %{_var}/spool/%{name}
72%dir %attr(700,root,root) %{_var}/spool/%{name}/crontabs
73%dir %attr(700,root,root) %{_var}/spool/%{name}/cronstamps
This page took 0.050603 seconds and 4 git commands to generate.