]> git.pld-linux.org Git - packages/dcron.git/blob - dcron.spec
mention difference with vixie cron
[packages/dcron.git] / dcron.spec
1 # TODO
2 # - crontab spool dir not compatible with other cron implementations
3 # - package default hourly,monhtly,etc and provide crontabs name
4 # - provides anacron functionality, O/P name?
5 # - triggers for switching with other crondaemons (after testing)
6 # - logrotate?
7 # - systemd init
8 # - crontab system group
9 Summary:        Lightweight Cron Daemon
10 Name:           dcron
11 Version:        4.5
12 Release:        0.1
13 License:        GPL v2+
14 Group:          Daemons
15 Source0:        http://www.jimpryor.net/linux/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  078833f3281f96944fc30392b1888326
17 Source1:        %{name}.init
18 Patch1:         %{name}-fix_makefile.patch
19 URL:            http://www.jimpryor.net/linux/dcron.html
20 BuildRequires:  pkgconfig
21 Provides:       crondaemon
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This lightweight cron daemon aims to be simple and secure, with just
26 enough features to stay useful. It was written from scratch by Matt
27 Dillon in 1994. It's now developed and maintained by Jim Pryor.
28
29 Dcron aims to be a simple, elegant and secure implementation of cron.
30 It does not allow the specification of environment variables in
31 crontabs and all cron-jobs are run from /bin/sh . Like Vixie cron,
32 each user has his own crontab.
33
34 In the author's opinion, having to combine a cron daemon with another
35 daemon like anacron makes for too much complexity. So the goal is a
36 simple cron daemon that can also take over the central functions of
37 anacron.
38
39 %prep
40 %setup -q
41 %patch1
42
43 %build
44 %{__make} \
45         CC="%{__cc}" \
46         OPTFLAGS="%{rpmcflags}" \
47         PREFIX=%{_prefix} \
48         INSTALL="install -p"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d}
53 %{__make} install \
54     DESTDIR=$RPM_BUILD_ROOT
55
56 install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/crond
57 install -d $RPM_BUILD_ROOT%{_var}/spool/%{name}/{crontabs,cronstamps}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc CHANGELOG README
65 %dir /etc/cron.d
66 %attr(754,root,root) /etc/rc.d/init.d/crond
67 %attr(755,root,root) %{_bindir}/crontab
68 %attr(755,root,root) %{_sbindir}/crond
69 %{_mandir}/man1/crontab.1.*
70 %{_mandir}/man8/crond.8.*
71 %dir %attr(700,root,root) %{_var}/spool/%{name}
72 %dir %attr(700,root,root) %{_var}/spool/%{name}/crontabs
73 %dir %attr(700,root,root) %{_var}/spool/%{name}/cronstamps
This page took 0.065798 seconds and 3 git commands to generate.