]> git.pld-linux.org Git - packages/dcadec.git/blob - dcadec.spec
- ghost on proper file
[packages/dcadec.git] / dcadec.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Free DTS Coherent Acoustics decoder with support for HD extensions
6 Summary(pl.UTF-8):      Wolnodostępny dekoder DTS Coherent Acoustics z obsługą rozszerzeń HD
7 Name:           dcadec
8 Version:        0.2.0
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Applications/Sound
12 Source0:        https://github.com/foo86/dcadec/archive/v%{version}.tar.gz
13 # Source0-md5:  14005424ad2ee56ce3d33b921ef749cb
14 URL:            https://github.com/foo86/dcadec
15 Requires:       %{name}-libs = %{version}-%{release}
16 # dcadec binary
17 Obsoletes:      libdts-tools
18 Conflicts:      libdts < 0.0.5-4
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 dcadec is a free DTS Coherent Acoustics decoder with support for HD
23 extensions.
24
25 Supported features:
26 - Decoding of standard DTS core streams with up to 5.1 channels
27 - Decoding of DTS-ES streams with discrete back channel
28 - Decoding of High Resolution streams with up to 7.1 channels and
29   extended bitrate
30 - Decoding of 96/24 core streams
31 - Lossless decoding of Master Audio streams with up to 7.1 channels,
32   192 kHz
33 - Downmixing to stereo and 5.1 using embedded coefficients
34
35 Features not implemented:
36 - Decoding of DTS Express streams
37 - Applying dynamic range compression and dialog normalization
38
39 %description -l pl.UTF-8
40 dcadec to wolnodostępny dekoder formatu DTS Coherent Acoustics z
41 obsługą rozszerzeń HD.
42
43 Obsługiwane:
44 - dekodowanie standardowych strumieni podstawowych DTS o liczbie
45   kanałów do 5.1
46 - dekodowanie strumieni DTS-ES z dyskretnym kanałem tylnym
47 - dekodowanie strumieni HD o liczbie kanałów do 7.1 z rozszerzoną
48   prędkością bitową
49 - dekodowanie strumieni podstawowych 96/24
50 - bezstratne dekodowanie strumieni Master Audio o liczbie kanałów do
51   7.1, do 192 kHz
52 - miksowanie w dół do stereo i 5.1 przy użyciu wbudowanych
53   współczynników
54
55 Nie obsługiwane:
56 - dekodowanie strumieni DTS Express
57 - wykonywanie kompresji dynamiki oraz normalizacja dialogów
58
59 %package libs
60 Summary:        Free DTS Coherent Acoustics decoder library with support for HD extensions
61 Summary(pl.UTF-8):      Wolnodostępna biblioteka dekodera DTS Coherent Acoustics z obsługą rozszerzeń HD
62 Group:          Libraries
63
64 %description libs
65 libdcadec is a free DTS Coherent Acoustics decoder library with
66 support for HD extensions.
67
68 Supported features:
69 - Decoding of standard DTS core streams with up to 5.1 channels
70 - Decoding of DTS-ES streams with discrete back channel
71 - Decoding of High Resolution streams with up to 7.1 channels and
72   extended bitrate
73 - Decoding of 96/24 core streams
74 - Lossless decoding of Master Audio streams with up to 7.1 channels,
75   192 kHz
76 - Downmixing to stereo and 5.1 using embedded coefficients
77
78 Features not implemented:
79 - Decoding of DTS Express streams
80 - Applying dynamic range compression and dialog normalization
81
82 %description libs -l pl.UTF-8
83 libdcadec to wolnodostępna biblioteka dekodera formatu DTS Coherent
84 Acoustics z obsługą rozszerzeń HD.
85
86 Obsługiwane:
87 - dekodowanie standardowych strumieni podstawowych DTS o liczbie
88   kanałów do 5.1
89 - dekodowanie strumieni DTS-ES z dyskretnym kanałem tylnym
90 - dekodowanie strumieni HD o liczbie kanałów do 7.1 z rozszerzoną
91   prędkością bitową
92 - dekodowanie strumieni podstawowych 96/24
93 - bezstratne dekodowanie strumieni Master Audio o liczbie kanałów do
94   7.1, do 192 kHz
95 - miksowanie w dół do stereo i 5.1 przy użyciu wbudowanych
96   współczynników
97
98 Nie obsługiwane:
99 - dekodowanie strumieni DTS Express
100 - wykonywanie kompresji dynamiki oraz normalizacja dialogów
101
102 %package devel
103 Summary:        Header files for libdcadec library
104 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libdcadec
105 Group:          Development/Libraries
106 Requires:       %{name}-libs = %{version}-%{release}
107
108 %description devel
109 Header files for libdcadec library.
110
111 %description devel -l pl.UTF-8
112 Pliki nagłówkowe biblioteki libdcadec.
113
114 %package static
115 Summary:        Static libdcadec library
116 Summary(pl.UTF-8):      Statyczna biblioteka libdcadec
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119
120 %description static
121 Static libdcadec library.
122
123 %description static -l pl.UTF-8
124 Statyczna biblioteka libdcadec.
125
126 %prep
127 %setup -q
128
129 %build
130 CFLAGS="%{rpmcflags}" \
131 LDFLAGS="%{rpmldflags}" \
132 %{__make} all \
133         CC="%{__cc}" \
134         CONFIG_SHARED=1 \
135         PREFIX=%{_prefix} \
136         LIBDIR=%{_libdir}
137
138 %if %{with static_libs}
139 %{__make} libdcadec/libdcadec.a
140 %endif
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         CONFIG_SHARED=1 \
147         DESTDIR=$RPM_BUILD_ROOT \
148         PREFIX=%{_prefix} \
149         LIBDIR=%{_libdir}
150
151 %if %{with static_libs}
152 cp -p libdcadec/libdcadec.a $RPM_BUILD_ROOT%{_libdir}
153 %endif
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   libs -p /sbin/ldconfig
159 %postun libs -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc README.md
164 %attr(755,root,root) %{_bindir}/dcadec
165
166 %files libs
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %ghost %{_libdir}/libdcadec.so.0
169 %attr(755,root,root) %{_libdir}/libdcadec.so.*.*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %{_includedir}/libdcadec
174 %{_pkgconfigdir}/dcadec.pc
175 %attr(755,root,root) %{_libdir}/libdcadec.so
176
177 %if %{with static_libs}
178 %files static
179 %defattr(644,root,root,755)
180 %{_libdir}/libdcadec.a
181 %endif
This page took 0.094553 seconds and 3 git commands to generate.