]> git.pld-linux.org Git - packages/dbus-1-tqt.git/blob - dbus-1-tqt.spec
build with tqt3
[packages/dbus-1-tqt.git] / dbus-1-tqt.spec
1 #
2 # Conditional build:
3 %bcond_with             qt3     # Build with Qt3 instead TQt3
4
5 %define tde_ver R14.0.0
6 Summary:        DBus bindings for the Trinity Qt interface
7 Name:           dbus-1-tqt
8 Version:        0.9
9 Release:        0.2
10 # AFL v2.1 or GPL v2+, but Qt license enforces GPL
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        http://tde-mirror.yosemite.net/trinity/releases/R14.0.0/dependencies/%{name}-%{tde_ver}.tar.bz2
14 # Source0-md5:  851c2184a4fcf2df48601499b793a74f
15 Patch0:         qt.patch
16 URL:            http://www.freedesktop.org/Software/DBusBindings
17 BuildRequires:  cmake >= 2.8
18 BuildRequires:  dbus-devel >= 0.91
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  pkgconfig
21 %if %{with qt3}
22 BuildRequires:  qt-devel >= 6:3.1.0
23 %else
24 BuildRequires:  libtqt3-mt-devel >= 3.5.0
25 BuildRequires:  tqt3-dev-tools >= 3.5.0
26 BuildConflicts: qt-devel
27 %endif
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 D-BUS add-on library to integrate the standard D-BUS library with the
32 Qt thread abstraction and main loop.
33
34 %description -l pl.UTF-8
35 Dodatkowa biblioteka D-BUS do integracji standardowej biblioteki D-BUS
36 z abstrakcją wątków i główną pętlą Qt.
37
38 %package devel
39 Summary:        Header files for Qt-based library for using D-BUS
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki do używania D-BUS opartej o Qt
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       dbus-devel >= 0.91
44
45 %description devel
46 Header files for Qt-based library for using D-BUS.
47
48 %description devel -l pl.UTF-8
49 Pliki nagłówkowe biblioteki do używania D-BUS opartej o Qt.
50
51 %package static
52 Summary:        Static Qt-based library for using D-BUS
53 Summary(pl.UTF-8):      Statyczna biblioteka do używania D-BUS oparta o Qt
54 Group:          Development/Libraries
55 Requires:       %{name}-devel = %{version}-%{release}
56
57 %description static
58 Static Qt-based library for using D-BUS.
59
60 %description static -l pl.UTF-8
61 Statyczna biblioteka do używania D-BUS oparta o Qt.
62
63 %prep
64 %setup -qc
65 mv dependencies/dbus-1-tqt/* .
66 %if %{with qt3}
67 %patch0 -p1
68 %endif
69
70 %build
71 install -d build
72 cd build
73 %cmake \
74         -DWITH_GCC_VISIBILITY=ON \
75         ..
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} -C build install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc AUTHORS ChangeLog README TODO
92 %attr(755,root,root) %{_libdir}/libdbus-1-tqt.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libdbus-1-tqt.so.0
94 %attr(755,root,root) %{_bindir}/dbusxml2qt3
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libdbus-1-tqt.so
99 %{_libdir}/libdbus-1-tqt.la
100 %{_includedir}/dbus-1-tqt
101 %{_pkgconfigdir}/dbus-1-tqt.pc
This page took 0.0963 seconds and 3 git commands to generate.