]> git.pld-linux.org Git - packages/dbh.git/blob - dbh.spec
- pl, cleanups, BRs, fixed file lists
[packages/dbh.git] / dbh.spec
1 %define         ver             1.0
2 %define         rel             14
3
4 Summary:        Disk based hash library
5 Summary(pl):    Biblioteka obs³uguj±ca tablice haszuj±ce na dysku
6 Name:           dbh
7 Version:        %{ver}.%{rel}
8 Release:        0.1
9 License:        LGPL
10 Group:          Libraries
11 Source0:        http://dl.sourceforge.net/dbh/%{name}_%{ver}-%{rel}.tgz
12 # Source0-md5:  11352e539a3e40f23d539a52f2153b95
13 URL:            http://dbh.sourceforge.net/
14 BuildRequires:  autoconf >= 2.52
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description 
20 Disk based hashes is a method to create multidimensional binary trees
21 on disk. This library permits the extension of database concept to a
22 plethora of electronic data, such as graphic information. With the
23 multidimensional binary tree it is possible to mathematically prove
24 that access time to any particular record is minimized (using the
25 concept of critical points from calculus), which provides the means to
26 construct optimized databases for particular applications.  
27
28 %description -l pl
29 Hasze przechowywane na dysku to metoda tworzenia wielowymiarowych
30 drzew binarnych na dysku. Biblioteka pozwala rozszerzaæ pojêcie bazy
31 danych o bogactwo danych elektronicznych, takich jak informacje
32 graficzne. Mo¿na udowodniæ matematycznie, ¿e przy u¿yciu
33 wielowymiarowego drzewa binarnego czas dostêpu do ka¿dego konkretnego
34 rekordu jest minimalny (u¿ywaj±c zasady punktów krytycznych), co
35 daje ¶rodki do tworzenia zoptymalizowanych baz danych dla aplikacji.
36
37 %package devel
38 Summary:        Disk based hash library development files
39 Summary(pl):    Pliki nag³ówkowe biblioteki dbh
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}
42 Obsoletes:      dbh-examples
43
44 %description devel
45 Disk based hash library development files.
46
47 %description devel -l pl
48 Pliki nag³ówkowe biblioteki dbh.
49
50 %package static
51 Summary:        Disk based hash static library
52 Summary(pl):    Statyczna biblioteka dbh
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}
55
56 %description static
57 Disk based hash static library.
58
59 %description static -l pl
60 Statyczna biblioteka dbh.
61
62 %prep
63 %setup -q -n %{name}_%{ver}-%{rel}
64
65 %build
66 %{__libtoolize}
67 %{__aclocal}
68 %{__automake}
69 %{__autoconf}
70 %configure 
71
72 %{__make}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT 
80
81 cd examples
82 install simple_hash.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
83 install trafico.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
84 install Makefile $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post   -p /sbin/ldconfig
90 %postun -p /sbin/ldconfig
91
92 %files
93 %defattr(644,root,root,755)
94 %doc AUTHORS ChangeLog
95 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %doc doc/*.html
100 %attr(755,root,root) %{_libdir}/lib*.so
101 %{_libdir}/lib*.la
102 %{_includedir}/*.h
103 %{_pkgconfigdir}/*.pc
104 %{_examplesdir}/%{name}-%{version}
105
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/lib*.a
This page took 0.06773 seconds and 3 git commands to generate.