]> git.pld-linux.org Git - packages/db6.1.git/blob - db6.1.spec
- up to 6.1.36
[packages/db6.1.git] / db6.1.spec
1 # WARNING:
2 # - 6.1.29->6.1.36 changes __db_env ABI (adds convert in the middle of public handle list in struct)
3 # - contains changes similar to 6.2.32, which is not compatible with rpm 5.4.17
4 #
5 # Conditional build:
6 %bcond_without  java            # don't build Java bindings
7 %bcond_without  tcl             # don't build Tcl bindings
8 %bcond_without  static_libs     # don't build static libraries
9 %bcond_with     sqlite3         # build Sqlite3 API libraries
10 %bcond_with     default_db      # use this db as default system db [Th uses DB 5.3]
11 %bcond_with     rpm_db          # install library to rootfs for /bin/rpm
12
13 %{load:/usr/lib/rpm/macros.d/java}
14
15 %define         major           6
16 %define         libver          %{major}.1
17 %define         ver             %{libver}.36
18 %define         patchlevel      0
19 Summary:        Berkeley DB database library for C
20 Summary(pl.UTF-8):      Biblioteka C do obsługi baz Berkeley DB
21 Name:           db6.1
22 Version:        %{ver}.%{patchlevel}
23 Release:        1
24 License:        AGPL v3
25 Group:          Libraries
26 #Source0Download: http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/downloads/index-082944.html
27 Source0:        http://download.oracle.com/berkeley-db/db-%{ver}.tar.gz
28 # Source0-md5:  7504e31df4e3bef7a984913070733262
29 Patch0:         %{name}-sql-features.patch
30 URL:            http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/downloads/index.html
31 BuildRequires:  automake
32 %if %{with java}
33 BuildRequires:  jdk
34 BuildRequires:  rpm-javaprov
35 %endif
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  rpmbuild(macros) >= 1.426
38 BuildRequires:  sed >= 4.0
39 %{?with_tcl:BuildRequires:      tcl-devel >= 8.4.0}
40 Requires:       uname(release) >= 2.6.0
41 %if %{with default_db}
42 Provides:       db = %{version}-%{release}
43 Provides:       db = %{libver}
44 Obsoletes:      db4
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %if %{without default_db}
49 %define         _includedir     %{_prefix}/include/db%{libver}
50 %endif
51
52 %description
53 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
54 provides embedded database support for both traditional and
55 client/server applications. Berkeley DB is used by many applications,
56 including Python and Perl, so this should be installed on all systems.
57
58 %description -l pl.UTF-8
59 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
60 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
61 klient-serwer. Berkeley db jest używana w wielu aplikacjach, w tym w
62 Pythonie i Perlu.
63
64 %package devel
65 Summary:        Header files for Berkeley database library
66 Summary(pl.UTF-8):      Pliki nagłówkowe do biblioteki Berkeley Database
67 Group:          Development/Libraries
68 Requires:       %{name} = %{version}-%{release}
69 %if %{with default_db}
70 Provides:       db-devel = %{version}-%{release}
71 Obsoletes:      db-devel
72 Obsoletes:      db3-devel
73 Obsoletes:      db4-devel
74 %endif
75
76 %description devel
77 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
78 provides embedded database support for both traditional and
79 client/server applications. Berkeley DB includes B+tree, Extended
80 Linear Hashing, Fixed and Variable-length record access methods,
81 transactions, locking, logging, shared memory caching and database
82 recovery. DB supports C, C++, Java and Perl APIs.
83
84 This package contains the header files, libraries, and documentation
85 for building programs which use Berkeley DB.
86
87 %description devel -l pl.UTF-8
88 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
89 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
90 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
91 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
92 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
93 dla C, C++, Javy i Perla.
94
95 Ten pakiet zawiera pliki nagłówkowe i dokumentację do budowania
96 programów używających Berkeley DB.
97
98 %package static
99 Summary:        Static libraries for Berkeley database library
100 Summary(pl.UTF-8):      Statyczne biblioteki Berkeley Database
101 Group:          Development/Libraries
102 Requires:       %{name}-devel = %{version}-%{release}
103 %if %{with default_db}
104 Provides:       db-static = %{version}-%{release}
105 Obsoletes:      db-static
106 Obsoletes:      db3-static
107 Obsoletes:      db4-static
108 %endif
109
110 %description static
111 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
112 provides embedded database support for both traditional and
113 client/server applications. Berkeley DB includes B+tree, Extended
114 Linear Hashing, Fixed and Variable-length record access methods,
115 transactions, locking, logging, shared memory caching and database
116 recovery. DB supports C, C++, Java and Perl APIs.
117
118 This package contains the static libraries for building programs which
119 use Berkeley DB.
120
121 %description static -l pl.UTF-8
122 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
123 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
124 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
125 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
126 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
127 dla C, C++, Javy i Perla.
128
129 Ten pakiet zawiera statyczne biblioteki do budowania programów
130 używających Berkeley DB.
131
132 %package cxx
133 Summary:        Berkeley database library for C++
134 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla C++
135 Group:          Libraries
136 %if %{with default_db}
137 Provides:       db-cxx = %{version}-%{release}
138 Obsoletes:      db4-cxx
139 %endif
140
141 %description cxx
142 Berkeley database library for C++.
143
144 %description cxx -l pl.UTF-8
145 Biblioteka baz danych Berkeley dla C++.
146
147 %package cxx-devel
148 Summary:        Header files for db-cxx library
149 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki db-cxx
150 Group:          Development/Libraries
151 Requires:       %{name}-cxx = %{version}-%{release}
152 Requires:       %{name}-devel = %{version}-%{release}
153 %if %{with default_db}
154 Provides:       db-cxx-devel = %{version}-%{release}
155 Obsoletes:      db-cxx-devel
156 %endif
157 Conflicts:      db-devel < 4.1.25-3
158
159 %description cxx-devel
160 Header files for db-cxx library.
161
162 %description cxx-devel -l pl.UTF-8
163 Pliki nagłówkowe biblioteki db-cxx.
164
165 %package cxx-static
166 Summary:        Static version of db-cxx library
167 Summary(pl.UTF-8):      Statyczna wersja biblioteki db-cxx
168 Group:          Development/Libraries
169 Requires:       %{name}-cxx-devel = %{version}-%{release}
170 %if %{with default_db}
171 Provides:       db-cxx-static = %{version}-%{release}
172 Obsoletes:      db-cxx-static
173 %endif
174 Conflicts:      db-static < 4.2.50-1
175
176 %description cxx-static
177 Static version of db-cxx library.
178
179 %description cxx-static -l pl.UTF-8
180 Statyczna wersja biblioteki db-cxx.
181
182 %package java
183 Summary:        Berkeley database library for Java
184 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla Javy
185 Group:          Libraries
186 Requires:       jpackage-utils
187 %if %{with default_db}
188 Provides:       db-java = %{version}-%{release}
189 Obsoletes:      db-java
190 %endif
191
192 %description java
193 Berkeley database library for Java.
194
195 %description java -l pl.UTF-8
196 Biblioteka baz danych Berkeley dla Javy.
197
198 %package java-devel
199 Summary:        Development files for db-java library
200 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-java
201 Group:          Development/Languages/Java
202 Requires:       %{name}-java = %{version}-%{release}
203 %if %{with default_db}
204 Provides:       db-java-devel = %{version}-%{release}
205 Obsoletes:      db-java-devel
206 %endif
207 Conflicts:      db-devel < 4.1.25-3
208
209 %description java-devel
210 Development files for db-java library.
211
212 %description java-devel -l pl.UTF-8
213 Pliki programistyczne biblioteki db-java.
214
215 %package tcl
216 Summary:        Berkeley database library for Tcl
217 Summary(pl.UTF-8):      Biblioteka baz danych Berkeley dla Tcl
218 Group:          Development/Languages/Tcl
219 Requires:       tcl
220 %if %{with default_db}
221 Provides:       db-tcl = %{version}-%{release}
222 Obsoletes:      db4-tcl
223 %endif
224
225 %description tcl
226 Berkeley database library for Tcl.
227
228 %description tcl -l pl.UTF-8
229 Biblioteka baz danych Berkeley dla Tcl.
230
231 %package tcl-devel
232 Summary:        Development files for db-tcl library
233 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-tcl
234 Group:          Development/Languages/Tcl
235 Requires:       %{name}-tcl = %{version}-%{release}
236 %if %{with default_db}
237 Provides:       db-tcl-devel = %{version}-%{release}
238 Obsoletes:      db-tcl-devel
239 %endif
240 Conflicts:      db-devel < 4.1.25-3
241
242 %description tcl-devel
243 Development files for db-tcl library.
244
245 %description tcl-devel -l pl.UTF-8
246 Pliki programistyczne biblioteki db-tcl.
247
248 %package sql
249 Summary:        SQL layer for Berkeley database library
250 Summary(pl.UTF-8):      Wartstwa SQL dla biblioteki baz danych Berkeley
251 Group:          Libraries
252 %if %{with default_db}
253 Provides:       db-sql = %{version}-%{release}
254 %endif
255
256 %description sql
257 SQL layer for Berkeley database library.
258
259 %description sql -l pl.UTF-8
260 Warstwa SQL dla biblioteki baz danych Berkeley.
261
262 %package sql-devel
263 Summary:        Development files for db-sql library
264 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-sql
265 Group:          Development/Libraries
266 Requires:       %{name}-sql = %{version}-%{release}
267 %if %{with default_db}
268 Provides:       db-sql-devel = %{version}-%{release}
269 Obsoletes:      db-sql-devel
270 %endif
271
272 %description sql-devel
273 Development files for db-sql library.
274
275 %description sql-devel -l pl.UTF-8
276 Pliki programistyczne biblioteki db-sql.
277
278 %package stl
279 Summary:        STL API for Berkeley Database library
280 Summary(pl.UTF-8):      API STL dla biblioteki Berkeley Database
281 Group:          Libraries
282 %if %{with default_db}
283 Provides:       db-stl = %{version}-%{release}
284 %endif
285
286 %description stl
287 STL API for Berkeley database library.
288
289 %description stl -l pl.UTF-8
290 API STL dla biblioteki Berkeley Database.
291
292 %package stl-devel
293 Summary:        Development files for db-stl library
294 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-stl
295 Group:          Development/Libraries
296 Requires:       %{name}-stl = %{version}-%{release}
297 %if %{with default_db}
298 Provides:       db-stl-devel = %{version}-%{release}
299 Obsoletes:      db-stl-devel
300 %endif
301
302 %description stl-devel
303 Development files for db-stl library.
304
305 %description stl-devel -l pl.UTF-8
306 Pliki programistyczne biblioteki db-stl.
307
308 %package sqlite3
309 Summary:        Sqlite3 API for Berkeley Database library
310 Summary(pl.UTF-8):      API Sqlite3 dla biblioteki Berkeley Database
311 Group:          Libraries
312 %if %{with default_db}
313 Provides:       db-sqlite3 = %{version}-%{release}
314 %endif
315
316 %description sqlite3
317 Sqlite3 API for Berkeley database library.
318
319 %description sqlite3 -l pl.UTF-8
320 API Sqlite3 dla biblioteki Berkeley Database.
321
322 %package sqlite3-devel
323 Summary:        Development files for db-sqlite3 library
324 Summary(pl.UTF-8):      Pliki programistyczne biblioteki db-sqlite3
325 Group:          Development/Libraries
326 Requires:       %{name}-sqlite3 = %{version}-%{release}
327 %if %{with default_db}
328 Provides:       db-sqlite3-devel = %{version}-%{release}
329 Obsoletes:      db-sqlite3-devel
330 %endif
331
332 %description sqlite3-devel
333 Development files for db-sqlite3 library.
334
335 %description sqlite3-devel -l pl.UTF-8
336 Pliki programistyczne biblioteki db-sqlite3.
337
338 %package utils
339 Summary:        Command line tools for managing Berkeley DB databases
340 Summary(pl.UTF-8):      Narzędzia do obsługi baz Berkeley DB z linii poleceń
341 Group:          Applications/Databases
342 Requires:       %{name} = %{version}-%{release}
343 Requires:       %{name}-sql = %{version}-%{release}
344 %if %{with default_db}
345 Provides:       db-utils = %{version}-%{release}
346 Obsoletes:      db-utils
347 Obsoletes:      db3-utils
348 Obsoletes:      db4-utils
349 %endif
350
351 %description utils
352 The Berkeley Database (Berkeley DB) is a programmatic toolkit that
353 provides embedded database support for both traditional and
354 client/server applications. Berkeley DB includes B+tree, Extended
355 Linear Hashing, Fixed and Variable-length record access methods,
356 transactions, locking, logging, shared memory caching and database
357 recovery. DB supports C, C++, Java and Perl APIs.
358
359 This package contains command line tools for managing Berkeley DB
360 databases.
361
362 %description utils -l pl.UTF-8
363 Berkeley Database (Berkeley DB) to zestaw narzędzi programistycznych
364 zapewniających obsługę baz danych w aplikacjach tradycyjnych jak i
365 klient-serwer. Berkeley DB obsługuje dostęp do bazy przez B-drzewa i
366 funkcje mieszające ze stałą lub zmienną wielkością rekordu,
367 transakcje, kroniki, pamięć dzieloną i odtwarzanie baz. Ma wsparcie
368 dla C, C++, Javy i Perla.
369
370 Ten pakiet zawiera narzędzia do obsługi baz Berkeley DB z linii
371 poleceń.
372
373 %prep
374 %setup -q -n db-%{ver}
375 %patch0 -p1
376
377 %build
378 cp -f /usr/share/automake/config.sub dist
379
380 JAVACFLAGS="-source 1.5 -target 1.5"
381 export JAVACFLAGS
382
383 %if %{with static_libs}
384 cp -a build_unix build_unix.static
385
386 cd build_unix.static
387
388 CC="%{__cc}"
389 CXX="%{__cxx}"
390 CFLAGS="%{rpmcflags}"
391 CXXFLAGS="%{rpmcflags} -fno-implicit-templates"
392 LDFLAGS="%{rpmcflags} %{rpmldflags}"
393 export CC CXX CFLAGS CXXFLAGS LDFLAGS
394
395 ../dist/%configure \
396         --disable-shared \
397         --enable-static \
398         --enable-compat185 \
399         --enable-cxx \
400         --enable-dbm \
401         --enable-build_dbm \
402         --enable-posixmutexes
403
404 # (temporarily?) disabled because of compilation errors:
405 #       --enable-dump185 \
406
407 %{__make} library_build
408 cd ..
409 %endif
410
411 cd build_unix
412
413 ../dist/%configure \
414         --prefix=%{_prefix} \
415         --libdir=%{_libdir} \
416         --enable-shared \
417         --disable-static \
418         --enable-compat185 \
419         --enable-cxx \
420         --enable-dbm \
421         --enable-build_dbm \
422         --enable-posixmutexes \
423         --enable-sql \
424         %{?with_sqlite3:--enable-sql_compat} \
425         --enable-sql_codegen \
426         --enable-stl \
427         %{?with_java:--enable-java} \
428         %{?with_tcl:--enable-tcl --with-tcl=/usr/lib}
429
430 %{__make} library_build \
431         TCFLAGS='-I$(builddir) -I%{_includedir}' \
432         LIBSO_LIBS="\$(LIBS)" \
433         LIBTSO_LIBS="\$(LIBS) -ltcl"
434
435 %install
436 rm -rf $RPM_BUILD_ROOT
437 install -d $RPM_BUILD_ROOT{%{_includedir},%{_libdir},%{_bindir}}
438 %if %{with java}
439 install -d $RPM_BUILD_ROOT%{_javadir}
440 %endif
441
442 %if %{with static_libs}
443 %{__make} -C build_unix.static library_install \
444         DESTDIR=$RPM_BUILD_ROOT \
445         docdir=%{_docdir}/db-%{version}-docs \
446         includedir=%{_includedir}
447 %endif
448
449 %{__make} -C build_unix library_install \
450         DESTDIR=$RPM_BUILD_ROOT \
451         LIB_INSTALL_FILE_LIST="" \
452         docdir=%{_docdir}/db-%{version}-docs \
453         includedir=%{_includedir}
454
455 %if %{with rpm_db}
456 install -d $RPM_BUILD_ROOT/%{_lib}
457 mv $RPM_BUILD_ROOT%{_libdir}/libdb-%{libver}.so $RPM_BUILD_ROOT/%{_lib}
458 ln -sf /%{_lib}/libdb-%{libver}.so $RPM_BUILD_ROOT%{_libdir}/libdb-%{libver}.so
459 %endif
460
461 cd $RPM_BUILD_ROOT%{_libdir}
462 %if %{with static_libs}
463 mv -f libdb.a libdb-%{libver}.a
464 mv -f libdb_cxx.a libdb_cxx-%{libver}.a
465 %endif
466 %if %{with java}
467 mv -f $RPM_BUILD_ROOT%{_libdir}/db.jar $RPM_BUILD_ROOT%{_javadir}/db-%{libver}.jar
468 %endif
469 %if %{with default_db}
470 ln -sf libdb-%{libver}.so libdb.so
471 ln -sf libdb-%{libver}.so libndbm.so
472 ln -sf libdb-%{libver}.la libdb.la
473 ln -sf libdb-%{libver}.la libndbm.la
474 ln -sf libdb_cxx-%{libver}.so libdb_cxx.so
475 ln -sf libdb_cxx-%{libver}.la libdb_cxx.la
476 %if %{with java}
477 ln -sf libdb_java-%{libver}.la libdb_java.la
478 ln -sf db-%{libver}.jar $RPM_BUILD_ROOT%{_javadir}/db.jar
479 %endif
480 %if %{with tcl}
481 ln -sf libdb_tcl-%{libver}.so libdb_tcl.so
482 ln -sf libdb_tcl-%{libver}.la libdb_tcl.la
483 %endif
484 %if %{with static_libs}
485 ln -sf libdb-%{libver}.a libdb.a
486 ln -sf libdb-%{libver}.a libndbm.a
487 ln -sf libdb_cxx-%{libver}.a libdb_cxx.a
488 %endif
489 %else
490 %{__rm} libdb.so
491 %{__rm} libdb_cxx.so
492 %{__rm} libdb_sql.so
493 %{__rm} libdb_stl.so
494 %{__rm} libdb-%{major}.so
495 %{__rm} libdb_cxx-%{major}.so
496 %{__rm} libdb_sql-%{major}.so
497 %{__rm} libdb_stl-%{major}.so
498 %if %{with java}
499 %{__rm} libdb_java.so
500 %{__rm} libdb_java-%{major}.so
501 %endif
502 %if %{with tcl}
503 %{__rm} libdb_tcl.so
504 %{__rm} libdb_tcl-%{major}.so
505 %endif
506 %endif
507
508 sed -i "s/old_library=''/old_library='libdb-%{libver}.a'/" libdb-%{libver}.la
509 sed -i "s/old_library=''/old_library='libdb_cxx-%{libver}.a'/" libdb_cxx-%{libver}.la
510
511 cd -
512
513 cd $RPM_BUILD_ROOT%{_bindir}
514 mv dbsql dbsql-%{libver}
515 %{?with_default_db:ln -sf dbsql-%{libver} dbsql}
516 for F in db_*; do
517   Fver=$(echo $F|sed 's/db_/db%{libver}_/')
518   mv $F $Fver
519   %{?with_default_db:ln -sf $Fver $F}
520 done
521 cd -
522
523 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-%{version}
524 cp -a examples/c/* $RPM_BUILD_ROOT%{_examplesdir}/db-%{version}
525
526 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-cxx-%{version}
527 cp -a examples/cxx/* $RPM_BUILD_ROOT%{_examplesdir}/db-cxx-%{version}
528
529 %if %{with java}
530 install -d $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
531 cp -a examples/java/* $RPM_BUILD_ROOT%{_examplesdir}/db-java-%{version}
532 %endif
533
534 # in %doc
535 %{__rm} $RPM_BUILD_ROOT%{_docdir}/db-%{version}-docs/{index.html,license/license_db.html}
536
537 # don't have csharp subpackages yet
538 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/db-%{version}-docs/csharp
539
540 %clean
541 rm -rf $RPM_BUILD_ROOT
542
543 %post   -p /sbin/ldconfig
544 %postun -p /sbin/ldconfig
545
546 %post   tcl -p /sbin/ldconfig
547 %postun tcl -p /sbin/ldconfig
548
549 %post   cxx -p /sbin/ldconfig
550 %postun cxx -p /sbin/ldconfig
551
552 %post   sql -p /sbin/ldconfig
553 %postun sql -p /sbin/ldconfig
554
555 %post   stl -p /sbin/ldconfig
556 %postun stl -p /sbin/ldconfig
557
558 %files
559 %defattr(644,root,root,755)
560 %doc LICENSE README docs/index.html docs/license
561 %if %{with rpm_db}
562 %attr(755,root,root) /%{_lib}/libdb-%{libver}.so
563 %else
564 %attr(755,root,root) %{_libdir}/libdb-%{libver}.so
565 %endif
566
567 %files devel
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_bindir}/db%{libver}_sql_codegen
570 %{_libdir}/libdb-%{libver}.la
571 %if %{with rpm_db}
572 %attr(755,root,root) %{_libdir}/libdb-%{libver}.so
573 %endif
574 %if %{with default_db}
575 %attr(755,root,root) %{_bindir}/db_sql_codegen
576 %attr(755,root,root) %{_libdir}/libdb-%{major}.so
577 %attr(755,root,root) %{_libdir}/libdb.so
578 %attr(755,root,root) %{_libdir}/libndbm.so
579 %{_libdir}/libdb.la
580 %{_libdir}/libndbm.la
581 %else
582 %dir %{_includedir}
583 %endif
584 %{_includedir}/db.h
585 %{_includedir}/db_185.h
586 %dir %{_docdir}/db-%{version}-docs
587 %dir %{_docdir}/db-%{version}-docs/api_reference
588 %{_docdir}/db-%{version}-docs/api_reference/C
589 %{_docdir}/db-%{version}-docs/articles
590 %dir %{_docdir}/db-%{version}-docs/gsg
591 %{_docdir}/db-%{version}-docs/gsg/C
592 %dir %{_docdir}/db-%{version}-docs/gsg_txn
593 %{_docdir}/db-%{version}-docs/gsg_txn/C
594 %dir %{_docdir}/db-%{version}-docs/gsg_db_rep
595 %{_docdir}/db-%{version}-docs/gsg_db_rep/C
596 %{_docdir}/db-%{version}-docs/installation
597 %{_docdir}/db-%{version}-docs/porting
598 %{_docdir}/db-%{version}-docs/programmer_reference
599 %{_docdir}/db-%{version}-docs/upgrading
600 %{_examplesdir}/db-%{version}
601
602 %if %{with static_libs}
603 %files static
604 %defattr(644,root,root,755)
605 %{_libdir}/libdb-%{libver}.a
606 %if %{with default_db}
607 %{_libdir}/libdb.a
608 %{_libdir}/libndbm.a
609 %endif
610 %endif
611
612 %files cxx
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_libdir}/libdb_cxx-%{libver}.so
615
616 %files cxx-devel
617 %defattr(644,root,root,755)
618 %{_libdir}/libdb_cxx-%{libver}.la
619 %if %{with default_db}
620 %attr(755,root,root) %{_libdir}/libdb_cxx-%{major}.so
621 %attr(755,root,root) %{_libdir}/libdb_cxx.so
622 %{_libdir}/libdb_cxx.la
623 %endif
624 %{_includedir}/db_cxx.h
625 %{_docdir}/db-%{version}-docs/api_reference/CXX
626 %{_docdir}/db-%{version}-docs/api_reference/STL
627 %{_docdir}/db-%{version}-docs/gsg/CXX
628 %{_docdir}/db-%{version}-docs/gsg_txn/CXX
629 %{_docdir}/db-%{version}-docs/gsg_db_rep/CXX
630 %{_examplesdir}/db-cxx-%{version}
631
632 %if %{with static_libs}
633 %files cxx-static
634 %defattr(644,root,root,755)
635 %{_libdir}/libdb_cxx-%{libver}.a
636 %if %{with default_db}
637 %{_libdir}/libdb_cxx.a
638 %endif
639 %endif
640
641 %if %{with java}
642 %files java
643 %defattr(644,root,root,755)
644 %attr(755,root,root) %{_libdir}/libdb_java-%{libver}.so
645 %attr(755,root,root) %{_libdir}/libdb_java-%{libver}_g.so
646 %{_javadir}/db-%{libver}.jar
647 %if %{with default_db}
648 %{_javadir}/db.jar
649 %endif
650
651 %files java-devel
652 %defattr(644,root,root,755)
653 %{_libdir}/libdb_java-%{libver}.la
654 %if %{with default_db}
655 %attr(755,root,root) %{_libdir}/libdb_java.so
656 %attr(755,root,root) %{_libdir}/libdb_java-%{major}.so
657 %{_libdir}/libdb_java.la
658 %endif
659 %{_docdir}/db-%{version}-docs/collections
660 %{_docdir}/db-%{version}-docs/gsg/JAVA
661 %{_docdir}/db-%{version}-docs/gsg_txn/JAVA
662 %{_docdir}/db-%{version}-docs/gsg_db_rep/JAVA
663 %{_docdir}/db-%{version}-docs/java
664 %{_examplesdir}/db-java-%{version}
665 %endif
666
667 %if %{with tcl}
668 %files tcl
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_libdir}/libdb_tcl-%{libver}.so
671
672 %files tcl-devel
673 %defattr(644,root,root,755)
674 %{_libdir}/libdb_tcl-%{libver}.la
675 %if %{with default_db}
676 %attr(755,root,root) %{_libdir}/libdb_tcl.so
677 %attr(755,root,root) %{_libdir}/libdb_tcl-%{major}.so
678 %{_libdir}/libdb_tcl.la
679 %endif
680 %{_docdir}/db-%{version}-docs/api_reference/TCL
681 %endif
682
683 %files sql
684 %defattr(644,root,root,755)
685 %attr(755,root,root) %{_libdir}/libdb_sql-%{libver}.so
686
687 %files sql-devel
688 %defattr(644,root,root,755)
689 %{_libdir}/libdb_sql-%{libver}.la
690 %if %{with default_db}
691 %attr(755,root,root) %{_libdir}/libdb_sql.so
692 %attr(755,root,root) %{_libdir}/libdb_sql-%{major}.so
693 %endif
694 %{_includedir}/dbsql.h
695 %{_docdir}/db-%{version}-docs/bdb-sql
696
697 %files stl
698 %defattr(644,root,root,755)
699 %attr(755,root,root) %{_libdir}/libdb_stl-%{libver}.so
700
701 %files stl-devel
702 %defattr(644,root,root,755)
703 %{_libdir}/libdb_stl-%{libver}.la
704 %if %{with default_db}
705 %attr(755,root,root) %{_libdir}/libdb_stl.so
706 %attr(755,root,root) %{_libdir}/libdb_stl-%{major}.so
707 %endif
708 %{_includedir}/dbstl_base_iterator.h
709 %{_includedir}/dbstl_common.h
710 %{_includedir}/dbstl_container.h
711 %{_includedir}/dbstl_dbc.h
712 %{_includedir}/dbstl_dbt.h
713 %{_includedir}/dbstl_element_ref.h
714 %{_includedir}/dbstl_exception.h
715 %{_includedir}/dbstl_inner_utility.h
716 %{_includedir}/dbstl_map.h
717 %{_includedir}/dbstl_resource_manager.h
718 %{_includedir}/dbstl_set.h
719 %{_includedir}/dbstl_utility.h
720 %{_includedir}/dbstl_vector.h
721
722 %if %{with sqlite3}
723 %files sqlite3
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_bindir}/sqlite3
726 %attr(755,root,root) %{_libdir}/libsqlite3.so
727
728 %files sqlite3-devel
729 %defattr(644,root,root,755)
730 %{_libdir}/libsqlite3.la
731 %{_includedir}/sqlite3.h
732 %endif
733
734 %files utils
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_bindir}/db%{libver}_archive
737 %attr(755,root,root) %{_bindir}/db%{libver}_checkpoint
738 %attr(755,root,root) %{_bindir}/db%{libver}_convert
739 %attr(755,root,root) %{_bindir}/db%{libver}_deadlock
740 %attr(755,root,root) %{_bindir}/db%{libver}_dump
741 %attr(755,root,root) %{_bindir}/db%{libver}_hotbackup
742 %attr(755,root,root) %{_bindir}/db%{libver}_load
743 %attr(755,root,root) %{_bindir}/db%{libver}_log_verify
744 %attr(755,root,root) %{_bindir}/db%{libver}_printlog
745 %attr(755,root,root) %{_bindir}/db%{libver}_recover
746 %attr(755,root,root) %{_bindir}/db%{libver}_replicate
747 %attr(755,root,root) %{_bindir}/db%{libver}_stat
748 %attr(755,root,root) %{_bindir}/db%{libver}_tuner
749 %attr(755,root,root) %{_bindir}/db%{libver}_upgrade
750 %attr(755,root,root) %{_bindir}/db%{libver}_verify
751 %attr(755,root,root) %{_bindir}/dbsql-%{libver}
752 %if %{with default_db}
753 %attr(755,root,root) %{_bindir}/db_archive
754 %attr(755,root,root) %{_bindir}/db_checkpoint
755 %attr(755,root,root) %{_bindir}/db_deadlock
756 %attr(755,root,root) %{_bindir}/db_dump
757 %attr(755,root,root) %{_bindir}/db_hotbackup
758 %attr(755,root,root) %{_bindir}/db_load
759 %attr(755,root,root) %{_bindir}/db_log_verify
760 %attr(755,root,root) %{_bindir}/db_printlog
761 %attr(755,root,root) %{_bindir}/db_recover
762 %attr(755,root,root) %{_bindir}/db_replicate
763 %attr(755,root,root) %{_bindir}/db_stat
764 %attr(755,root,root) %{_bindir}/db_tuner
765 %attr(755,root,root) %{_bindir}/db_upgrade
766 %attr(755,root,root) %{_bindir}/db_verify
767 %attr(755,root,root) %{_bindir}/dbsql
768 %endif
This page took 0.184898 seconds and 3 git commands to generate.