]> git.pld-linux.org Git - packages/dash.git/blob - dash.spec
- new
[packages/dash.git] / dash.spec
1 Summary:        POSIX-compliant implementation of /bin/sh
2 Summary(pl.UTF-8):      Zgodna z POSIX implementacja /bin/sh
3 Name:           dash
4 Version:        0.5.4
5 Release:        1
6 License:        GPL v2+
7 Group:          Applications/Shells
8 Source0:        http://gondor.apana.org.au/~herbert/dash/files/%{name}-%{version}.tar.gz
9 # Source0-md5:  bc457e490a589d2f87f2333616b67931
10 URL:            http://gondor.apana.org.au/~herbert/dash/
11 Requires(post): grep
12 Requires(preun):        sed >= 4.0
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         _bindir                 /bin
16 %define         _shell                  %{_bindir}/%{name}
17
18 %description
19 DASH is a POSIX-compliant implementation of /bin/sh that aims to be as
20 small as possible. It does this without sacrificing speed where
21 possible. In fact, it is significantly faster than bash (the GNU
22 Bourne-Again SHell) for most tasks.
23
24 DASH is a direct descendant of the NetBSD version of ash (the Almquist
25 SHell)
26
27 %description -l pl.UTF-8
28 DASH to zgodna z POSIX implementacja /bin/sh, której celem jest jak
29 najmniejszy rozmiar. Dokonano tego bez poświęcania szybkości jeśli to
30 możliwe. W rzeczywistości jest dash jest znacząco szybszy od basha
31 (GNU Bourne-Again SHell) przy większości zadań.
32
33 DASH to bezpośredni następca wersji NetBSD asha (powłoki Almquist
34 SHell).
35
36 %prep
37 %setup -q
38
39 %build
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %post
53 if [ ! -f /etc/shells ]; then
54         umask 022
55         echo '%{_shell}' > /etc/shells
56 else
57         grep -q '^%{_shell}$' /etc/shells || echo '%{_shell}' >> /etc/shells
58 fi
59
60 %preun
61 if [ "$1" = "0" ]; then
62         %{__sed} -i -e '/^%(echo %{_shell} | sed -e 's,/,\\/,g')$/d' /etc/shells
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %attr(755,root,root) %{_bindir}/dash
68 %{_mandir}/man1/dash.1*
This page took 0.53956 seconds and 3 git commands to generate.