]> git.pld-linux.org Git - packages/dahdi-linux.git/blob - dahdi-linux.spec
- rebuild for kernel.spec:auto/th/kernel-3.4.8-1 /home/users/baggins/devel/PLD/rpm...
[packages/dahdi-linux.git] / dahdi-linux.spec
1 #
2 # TODO:
3 # - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
4 # - Fix --without xpp:
5 #   + check_modules
6 #   unpackaged module: drivers/dahdi/xpp/xpd_bri
7 #   unpackaged module: drivers/dahdi/xpp/xpd_fxo
8 #   unpackaged module: drivers/dahdi/xpp/xpd_fxs
9 #   unpackaged module: drivers/dahdi/xpp/xpd_pri
10 #   unpackaged module: drivers/dahdi/xpp/xpp
11 #   unpackaged module: drivers/dahdi/xpp/xpp_usb
12 #
13 # Conditional build:
14 %bcond_without  dist_kernel     # without distribution kernel
15 %bcond_without  kernel          # don't build kernel modules
16 %bcond_with     oslec           # with Open Source Line Echo Canceller
17 %bcond_without  xpp             # without Astribank
18 %bcond_without  userspace       # don't build userspace packages
19 %bcond_with     verbose
20
21 %if "%{_alt_kernel}" != "%{nil}"
22 %undefine       with_userspace
23 %endif
24
25 %ifarch sparc
26 %undefine       with_smp
27 %endif
28 %ifarch alpha
29 %undefine       with_xpp
30 %endif
31 %if %{without kernel}
32 %undefine       with_dist_kernel
33 %endif
34
35 %define         rel     28
36 %define         pname   dahdi-linux
37 %define         FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
38 Summary:        DAHDI telephony device support
39 Summary(pl.UTF-8):      Obsługa urządzeń telefonicznych DAHDI
40 Name:           %{pname}%{_alt_kernel}
41 Version:        2.6.0
42 Release:        %{rel}
43 License:        GPL
44 Group:          Base/Kernel
45 Source0:        http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
46 # Source0-md5:  ea35ad29dafe5490028ff642c35ef9a2
47 Source3:        %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
48 # Source3-md5:  88db9b7a07d8392736171b1b3e6bcc66
49 Source4:        %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
50 # Source4-md5:  c1f1a18d3e20d283f42c71e580a64b5a
51 Source5:        %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
52 # Source5-md5:  e1c7231d6225ac999cb18f4e858f66b6
53 Source6:        %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
54 # Source6-md5:  2ea860bb8a9d8ede2858b9557b74ee3c
55 Source7:        %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
56 # Source7-md5:  a7f3886942bb3e9fed349a41b3390c9f
57 Patch0:         %{pname}-build.patch
58 # http://oss.axsentis.de/people/stkn/openzap/dahdi-2.4.0-linux-2.6.37.patch
59 Patch1:         dahdi-2.4.0-linux-2.6.37.patch
60 Patch2:         dahdi-linux-kernel-3.4.patch
61 URL:            http://www.asterisk.org/
62 %if %{with dist_kernel}
63 BuildRequires:  kernel%{_alt_kernel}-module-build
64 %endif
65 BuildRequires:  perl-base
66 BuildRequires:  rpmbuild(macros) >= 1.379
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 # Rules:
70 # - modules_X: single modules, just name module with no suffix
71 # - modules_X: subdir modules are just directory name with slash like dirname/
72 # - keep X and X_in in sync
73 # - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
74
75 %define modules_1       dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
76 %define modules_1_in    dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
77 %define modules_2       voicebus/ wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
78 %define modules_2_in    voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
79 %ifnarch alpha
80 %define modules_nalpha  wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
81 %define modules_nalpha_in       wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
82 %endif
83 %define modules         %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
84 %define modules_in      %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
85
86 %description
87 DAHDI telephony device driver.
88
89 %description -l pl.UTF-8
90 Sterownik do urządzeń telefonicznych DAHDI.
91
92 %package devel
93 Summary:        Header files for dahdi interface
94 Group:          Development/Libraries
95 # if base package contains shared library for which these headers are
96 #Requires:      %{name} = %{version}-%{release}
97 # if -libs package contains shared library for which these headers are
98 #Requires:      %{name}-libs = %{version}-%{release}
99
100 %description devel
101 Header files for dahdi interface.
102
103 %package udev
104 Summary:        udev rules for DAHDI kernel modules
105 Summary(pl.UTF-8):      Reguły udev dla modułów jądra Linuksa dla DAHDI
106 Release:        %{rel}
107 Group:          Base/Kernel
108 Requires:       dahdi-tools >= 2.2.0
109 Requires:       udev-core
110
111 %description udev
112 udev rules for DAHDI kernel modules.
113
114 %description udev -l pl.UTF-8
115 Reguły udev dla modułów jądra Linuksa dla DAHDI.
116
117 %package -n kernel%{_alt_kernel}-%{pname}
118 Summary:        DAHDI Linux kernel driver
119 Summary(pl.UTF-8):      Sterownik DAHDI dla jądra Linuksa
120 Release:        %{rel}@%{_kernel_ver_str}
121 Group:          Base/Kernel
122 Requires(post,postun):  /sbin/depmod
123 %if %{with dist_kernel}
124 %requires_releq_kernel
125 Requires(postun):       %releq_kernel
126 %{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
127 %endif
128
129 %description -n kernel%{_alt_kernel}-%{pname}
130 DAHDI telephony Linux kernel driver.
131
132 %description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
133 Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
134
135 %prep
136 %setup -q -n %{pname}-%{version}
137 %patch0 -p1
138 #%patch1 -p1
139 %patch2 -p1
140
141 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
142         ln -s $a drivers/dahdi/firmware
143         tar -C drivers/dahdi/firmware -xzf $a
144 done
145
146 cat > download-logger <<'EOF'
147 #!/bin/sh
148 # keep log of files make wanted to download in firmware/ dir
149 echo "$@" >> download.log
150 EOF
151 chmod a+rx download-logger
152
153 %build
154 %{__make} include/dahdi/version.h
155
156 %if %{with kernel}
157 %build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
158
159 # check that all built .ko is handled by build_kernel_modules
160 # (renamed to either -dist, -up, or -smp suffix)
161 # if some missing, check the 'modules*' macros above
162 check_modules() {
163         err=0
164         for a in drivers/dahdi/{*/,}*.ko; do
165                 [[ $a = *-dist.ko ]] && continue
166                 [[ $a = *-up.ko ]] && continue
167                 [[ $a = *-smp.ko ]] && continue
168                 echo >&2 "unpackaged module: ${a%.ko}"
169                 err=1
170         done
171
172         [ $err = 0 ] || exit 1
173 }
174 #check_modules
175 %endif
176
177 %install
178 rm -rf $RPM_BUILD_ROOT
179 mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
180 %if %{with kernel}
181 cd drivers/dahdi
182 %install_kernel_modules -m %{modules_in} -d misc
183 cd ../..
184 %endif
185
186 %if %{with userspace}
187 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
188
189 %{make} \
190         DESTDIR=$RPM_BUILD_ROOT \
191         install-devices \
192         install-include
193 %endif
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post -n kernel%{_alt_kernel}-%{pname}
199 %depmod %{_kernel_ver}
200
201 %postun -n kernel%{_alt_kernel}-%{pname}
202 %depmod %{_kernel_ver}
203
204 %if %{with userspace}
205 %files devel
206 %defattr(644,root,root,755)
207 %{_includedir}/dahdi
208
209 %files udev
210 %defattr(644,root,root,755)
211 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
212 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
213 %endif
214
215 %if %{with kernel}
216 %files -n kernel%{_alt_kernel}-%{pname}
217 %defattr(644,root,root,755)
218 /lib/modules/%{_kernel_ver}/misc/*.ko*
219 %endif
This page took 0.044594 seconds and 3 git commands to generate.