]> git.pld-linux.org Git - packages/dahdi-linux.git/blob - dahdi-linux.spec
- release 17
[packages/dahdi-linux.git] / dahdi-linux.spec
1 #
2 # TODO:
3 # - IMPORTANT rename: http://www.asterisk.org/zaptel-to-dahdi
4 # - Fix --without xpp:
5 #   + check_modules
6 #   unpackaged module: drivers/dahdi/xpp/xpd_bri
7 #   unpackaged module: drivers/dahdi/xpp/xpd_fxo
8 #   unpackaged module: drivers/dahdi/xpp/xpd_fxs
9 #   unpackaged module: drivers/dahdi/xpp/xpd_pri
10 #   unpackaged module: drivers/dahdi/xpp/xpp
11 #   unpackaged module: drivers/dahdi/xpp/xpp_usb
12 #
13 # Conditional build:
14 %bcond_without  dist_kernel     # without distribution kernel
15 %bcond_without  kernel          # don't build kernel modules
16 %bcond_with     oslec           # with Open Source Line Echo Canceller
17 %bcond_without  xpp             # without Astribank
18 %bcond_without  userspace       # don't build userspace packages
19 %bcond_with     verbose
20
21 %if "%{_alt_kernel}" != "%{nil}"
22 %undefine       with_userspace
23 %endif
24
25 %ifarch sparc
26 %undefine       with_smp
27 %endif
28 %ifarch alpha
29 %undefine       with_xpp
30 %endif
31 %if %{without kernel}
32 %undefine       with_dist_kernel
33 %endif
34
35 %define         rel     17
36 %define         pname   dahdi-linux
37 %define         FIRMWARE_URL http://downloads.digium.com/pub/telephony/firmware/releases
38 Summary:        DAHDI telephony device support
39 Summary(pl.UTF-8):      Obsługa urządzeń telefonicznych DAHDI
40 Name:           %{pname}%{_alt_kernel}
41 Version:        2.6.0
42 Release:        %{rel}
43 License:        GPL
44 Group:          Base/Kernel
45 Source0:        http://downloads.asterisk.org/pub/telephony/dahdi-linux/releases/dahdi-linux-%{version}.tar.gz
46 # Source0-md5:  ea35ad29dafe5490028ff642c35ef9a2
47 Source3:        %{FIRMWARE_URL}/dahdi-fw-oct6114-064-1.05.01.tar.gz
48 # Source3-md5:  88db9b7a07d8392736171b1b3e6bcc66
49 Source4:        %{FIRMWARE_URL}/dahdi-fw-oct6114-128-1.05.01.tar.gz
50 # Source4-md5:  c1f1a18d3e20d283f42c71e580a64b5a
51 Source5:        %{FIRMWARE_URL}/dahdi-fw-vpmadt032-1.07.tar.gz
52 # Source5-md5:  e1c7231d6225ac999cb18f4e858f66b6
53 Source6:        %{FIRMWARE_URL}/dahdi-fw-tc400m-MR6.12.tar.gz
54 # Source6-md5:  2ea860bb8a9d8ede2858b9557b74ee3c
55 Source7:        %{FIRMWARE_URL}/dahdi-fw-hx8-2.06.tar.gz
56 # Source7-md5:  a7f3886942bb3e9fed349a41b3390c9f
57 Patch0:         %{pname}-build.patch
58 # http://oss.axsentis.de/people/stkn/openzap/dahdi-2.4.0-linux-2.6.37.patch
59 Patch1:         dahdi-2.4.0-linux-2.6.37.patch
60 URL:            http://www.asterisk.org/
61 %if %{with dist_kernel}
62 BuildRequires:  kernel%{_alt_kernel}-module-build
63 %endif
64 BuildRequires:  perl-base
65 BuildRequires:  rpmbuild(macros) >= 1.379
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 # Rules:
69 # - modules_X: single modules, just name module with no suffix
70 # - modules_X: subdir modules are just directory name with slash like dirname/
71 # - keep X and X_in in sync
72 # - X is used for actual building (entries separated with space), X_in for pld macros (entries separated with comma)
73
74 %define modules_1       dahdi.o dahdi_dynamic.o dahdi_dynamic_eth.o dahdi_dynamic_ethmf.o dahdi_dynamic_loc.o dahdi_echocan_jpah.o dahdi_echocan_kb1.o dahdi_echocan_mg2.o dahdi_echocan_sec.o dahdi_echocan_sec2.o pciradio.o tor2.o wcfxo.o wct1xxp.o wctdm.o wcte11xp.o
75 %define modules_1_in    dahdi,dahdi_dynamic,dahdi_dynamic_eth,dahdi_dynamic_ethmf,dahdi_dynamic_loc,dahdi_echocan_jpah,dahdi_echocan_kb1,dahdi_echocan_mg2,dahdi_echocan_sec,dahdi_echocan_sec2,pciradio,tor2,wcfxo,wct1xxp,wctdm,wcte11xp
76 %define modules_2       voicebus/ wct4xxp/ wcte12xp/ %{?with_xpp:xpp/}
77 %define modules_2_in    voicebus/dahdi_voicebus,wct4xxp/wct4xxp,wcte12xp/wcte12xp,%{?with_xpp:xpp/xpd_bri,xpp/xpd_echo,xpp/xpd_fxo,xpp/xpd_fxs,xpp/xpd_pri,xpp/xpp,xpp/xpp_usb}
78 %ifnarch alpha
79 %define modules_nalpha  wctc4xxp/ wctdm24xxp/ dahdi_transcode.o wcb4xxp/
80 %define modules_nalpha_in       wctc4xxp/wctc4xxp,wctdm24xxp/wctdm24xxp,dahdi_transcode,wcb4xxp/wcb4xxp
81 %endif
82 %define modules         %{modules_1} %{modules_2}%{?modules_nalpha: %{modules_nalpha}}
83 %define modules_in      %{modules_1_in},%{modules_2_in}%{?modules_nalpha:,%{modules_nalpha_in}}
84
85 %description
86 DAHDI telephony device driver.
87
88 %description -l pl.UTF-8
89 Sterownik do urządzeń telefonicznych DAHDI.
90
91 %package devel
92 Summary:        Header files for dahdi interface
93 Group:          Development/Libraries
94 # if base package contains shared library for which these headers are
95 #Requires:      %{name} = %{version}-%{release}
96 # if -libs package contains shared library for which these headers are
97 #Requires:      %{name}-libs = %{version}-%{release}
98
99 %description devel
100 Header files for dahdi interface.
101
102 %package udev
103 Summary:        udev rules for DAHDI kernel modules
104 Summary(pl.UTF-8):      Reguły udev dla modułów jądra Linuksa dla DAHDI
105 Release:        %{rel}
106 Group:          Base/Kernel
107 Requires:       dahdi-tools >= 2.2.0
108 Requires:       udev-core
109
110 %description udev
111 udev rules for DAHDI kernel modules.
112
113 %description udev -l pl.UTF-8
114 Reguły udev dla modułów jądra Linuksa dla DAHDI.
115
116 %package -n kernel%{_alt_kernel}-%{pname}
117 Summary:        DAHDI Linux kernel driver
118 Summary(pl.UTF-8):      Sterownik DAHDI dla jądra Linuksa
119 Release:        %{rel}@%{_kernel_ver_str}
120 Group:          Base/Kernel
121 Requires(post,postun):  /sbin/depmod
122 %if %{with dist_kernel}
123 %requires_releq_kernel
124 Requires(postun):       %releq_kernel
125 %{?with_oslec:Requires: kernel-misc-oslec = 20070608-0.1@%{_kernel_ver_str}}
126 %endif
127
128 %description -n kernel%{_alt_kernel}-%{pname}
129 DAHDI telephony Linux kernel driver.
130
131 %description -n kernel%{_alt_kernel}-%{pname} -l pl.UTF-8
132 Sterownik dla jądra Linuksa do urządzeń telefonicznych DAHDI.
133
134 %prep
135 %setup -q -n %{pname}-%{version}
136 %patch0 -p1
137 #%patch1 -p1
138
139 for a in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} %{SOURCE7}; do
140         ln -s $a drivers/dahdi/firmware
141         tar -C drivers/dahdi/firmware -xzf $a
142 done
143
144 cat > download-logger <<'EOF'
145 #!/bin/sh
146 # keep log of files make wanted to download in firmware/ dir
147 echo "$@" >> download.log
148 EOF
149 chmod a+rx download-logger
150
151 %build
152 %{__make} include/dahdi/version.h
153
154 %if %{with kernel}
155 %build_kernel_modules SUBDIRS=$PWD/drivers/dahdi DAHDI_BUILD_ALL=m HOTPLUG_FIRMWARE=yes DAHDI_MODULES_EXTRA=" " -m %{modules_in} KSRC=$PWD/o -C drivers/dahdi DAHDI_INCLUDE=$PWD/../../include
156
157 # check that all built .ko is handled by build_kernel_modules
158 # (renamed to either -dist, -up, or -smp suffix)
159 # if some missing, check the 'modules*' macros above
160 check_modules() {
161         err=0
162         for a in drivers/dahdi/{*/,}*.ko; do
163                 [[ $a = *-dist.ko ]] && continue
164                 [[ $a = *-up.ko ]] && continue
165                 [[ $a = *-smp.ko ]] && continue
166                 echo >&2 "unpackaged module: ${a%.ko}"
167                 err=1
168         done
169
170         [ $err = 0 ] || exit 1
171 }
172 #check_modules
173 %endif
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177 mkdir $RPM_BUILD_ROOT%{_includedir}/dahdi -p
178 %if %{with kernel}
179 cd drivers/dahdi
180 %install_kernel_modules -m %{modules_in} -d misc
181 cd ../..
182 %endif
183
184 %if %{with userspace}
185 install -d $RPM_BUILD_ROOT/etc/udev/rules.d
186
187 %{make} \
188         DESTDIR=$RPM_BUILD_ROOT \
189         install-devices \
190         install-include
191 %endif
192
193 %clean
194 rm -rf $RPM_BUILD_ROOT
195
196 %post -n kernel%{_alt_kernel}-%{pname}
197 %depmod %{_kernel_ver}
198
199 %postun -n kernel%{_alt_kernel}-%{pname}
200 %depmod %{_kernel_ver}
201
202 %if %{with userspace}
203 %files devel
204 %defattr(644,root,root,755)
205 %{_includedir}/dahdi
206
207 %files udev
208 %defattr(644,root,root,755)
209 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/dahdi.rules
210 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/xpp.rules
211 %endif
212
213 %if %{with kernel}
214 %files -n kernel%{_alt_kernel}-%{pname}
215 %defattr(644,root,root,755)
216 /lib/modules/%{_kernel_ver}/misc/*.ko*
217 %endif
This page took 0.079195 seconds and 3 git commands to generate.