]> git.pld-linux.org Git - packages/daala.git/blob - daala.spec
- updated to todays snapshot
[packages/daala.git] / daala.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # do not build and package API docs
4 %bcond_without  tests           # unit tests
5 #
6 Summary:        Daala next-generation video codec
7 Summary(pl.UTF-8):      Daala - kodek obrazu następnej generacji
8 Name:           daala
9 Version:        0.0
10 %define snap    20140214
11 Release:        0.%{snap}.1
12 License:        BSD
13 Group:          Libraries
14 # git clone https://git.xiph.org/daala.git
15 # cd daala && ./update_version && cd ..
16 # tar cJf daala.tar.xz daala
17 Source0:        %{name}.tar.xz
18 # Source0-md5:  95bb883af28b16ff1312960cc52a2282
19 URL:            http://xiph.org/daala/
20 BuildRequires:  SDL-devel
21 BuildRequires:  autoconf >= 2.53
22 BuildRequires:  automake >= 1:1.11
23 %{?with_tests:BuildRequires:    check-devel >= 0.9.8}
24 BuildRequires:  libjpeg-devel
25 BuildRequires:  libogg-devel >= 1:1.3
26 BuildRequires:  libpng-devel
27 BuildRequires:  libtheora-devel
28 BuildRequires:  libtool >= 2:2
29 %if %{with apidocs}
30 BuildRequires:  doxygen
31 BuildRequires:  transfig
32 %endif
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 Daala is the code-name for a new video compression technology. The
37 effort is a collaboration between Mozilla Foundation, Xiph.Org
38 Foundation and other contributors.
39
40 The goal of the project is to provide a free to implement, use and
41 distribute digital media format and reference implementation with
42 technical performance superior to H.265.
43
44 %description -l pl.UTF-8
45 Daala to nazwa kodowa nowej technologii kompresji obrazu. Próby te
46 są efektem współpracy Mozilla Foundation, Xiph.Org oraz innych
47 współpracowników.
48
49 Celem projektu jest dostarczenie wolnego w implementacji, użyciu i
50 rozpowszechnianiu formatu treści cyfrowej oraz wzorcowej implementacji
51 o wydajności lepszej niż H.265.
52
53 %package devel
54 Summary:        Header files for Daala libraries
55 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Daala
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       libogg-devel >= 1.3
59 Requires:       libpng-devel
60
61 %description devel
62 Header files for Daala libraries.
63
64 %description devel -l pl.UTF-8
65 Pliki nagłówkowe bibliotek Daala.
66
67 %package static
68 Summary:        Static Daala libraries
69 Summary(pl.UTF-8):      Statyczne biblioteki Daala
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{version}-%{release}
72
73 %description static
74 Static Daala libraries.
75
76 %description static -l pl.UTF-8
77 Statyczne biblioteki Daala.
78
79 %package apidocs
80 Summary:        Daala API documentation
81 Summary(pl.UTF-8):      Dokumentacja API bibliotek Daala
82 Group:          Documentation
83
84 %description apidocs
85 API documentation for Daala libraries.
86
87 %description apidocs -l pl.UTF-8
88 Dokumentacja API bibliotek Daala.
89
90 %prep
91 %setup -q -n %{name}
92
93 %build
94 %{__libtoolize}
95 %{__aclocal} -I m4
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         %{!?with_apidocs:--disable-doc} \
101         --disable-silent-rules \
102         %{!?with_tests:--disable-unit-tests}
103 %{__make}
104
105 %if %{with tests}
106 %{__make} check
107 %endif
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # obsoleted by pkg-config
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libdaala*.la
117 # packaged as %doc
118 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/daala
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS COPYING README
129 %attr(755,root,root) %{_libdir}/libdaalabase.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libdaalabase.so.0
131 %attr(755,root,root) %{_libdir}/libdaaladec.so.*.*.*
132 %attr(755,root,root) %ghost %{_libdir}/libdaaladec.so.0
133 %attr(755,root,root) %{_libdir}/libdaalaenc.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libdaalaenc.so.0
135
136 %files devel
137 %defattr(644,root,root,755)
138 %attr(755,root,root) %{_libdir}/libdaalabase.so
139 %attr(755,root,root) %{_libdir}/libdaaladec.so
140 %attr(755,root,root) %{_libdir}/libdaalaenc.so
141 %{_includedir}/daala
142 %{_pkgconfigdir}/daaladec.pc
143 %{_pkgconfigdir}/daalaenc.pc
144
145 %files static
146 %defattr(644,root,root,755)
147 %{_libdir}/libdaalabase.a
148 %{_libdir}/libdaaladec.a
149 %{_libdir}/libdaalaenc.a
150
151 %if %{with apidocs}
152 %files apidocs
153 %defattr(644,root,root,755)
154 %doc doc/html/*
155 %endif
This page took 0.065976 seconds and 3 git commands to generate.