]> git.pld-linux.org Git - packages/czmq.git/blob - czmq.spec
- rel 3
[packages/czmq.git] / czmq.spec
1 Summary:        High-level C binding for 0MQ
2 Summary(pl.UTF-8):      Wysokopoziomowe wiązania C dla 0MQ
3 Name:           czmq
4 Version:        2.2.0
5 Release:        3
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        http://download.zeromq.org/%{name}-%{version}.tar.gz
9 # Source0-md5:  b9c060727275a98e866d4db26345c2d8
10 Patch0:         no-Werror.patch
11 URL:            http://zeromq.org/
12 BuildRequires:  asciidoc
13 BuildRequires:  libsodium-devel
14 BuildRequires:  libuuid-devel
15 BuildRequires:  xmlto
16 BuildRequires:  zeromq-devel >= 4
17 Requires:       zeromq >= 4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 High-level C binding for 0MQ.
22
23 %description -l pl.UTF-8
24 Wysokopoziomowe wiązania C dla 0MQ.
25
26 %package devel
27 Summary:        Header files for CZMQ library
28 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CZMQ
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31 Requires:       zeromq-devel >= 4
32
33 %description devel
34 Header files for CZMQ library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki CZMQ.
38
39 %package static
40 Summary:        Static CZMQ library
41 Summary(pl.UTF-8):      Statyczna biblioteka CZMQ
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static CZMQ library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka CZMQ.
50
51 %prep
52 %setup -q
53 %patch0 -p1
54
55 %build
56 # use include subdir - file names could be too common (zfile.h etc.)
57 %configure \
58         --disable-silent-rules \
59         --includedir=%{_includedir}/czmq
60 %{__make}
61
62 %install
63 rm -rf $RPM_BUILD_ROOT
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 # obsoleted by pkg-config
69 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libczmq.la
70
71 # too common name
72 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{makecert,czmq_makecert}
73
74 # gsl scripts, most likely shouldn't be installed
75 %{__rm} $RPM_BUILD_ROOT%{_bindir}/*.gsl
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %doc AUTHORS NEWS
83 %attr(755,root,root) %{_bindir}/czmq_makecert
84 %attr(755,root,root) %{_bindir}/czmq_selftest
85 %attr(755,root,root) %{_libdir}/libczmq.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libczmq.so.1
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libczmq.so
91 %{_includedir}/czmq
92 %{_pkgconfigdir}/libczmq.pc
93 %{_mandir}/man3/zauth.3*
94 %{_mandir}/man3/zbeacon.3*
95 %{_mandir}/man3/zcert.3*
96 %{_mandir}/man3/zcertstore.3*
97 %{_mandir}/man3/zchunk.3*
98 %{_mandir}/man3/zclock.3*
99 %{_mandir}/man3/zconfig.3*
100 %{_mandir}/man3/zctx.3*
101 %{_mandir}/man3/zdigest.3*
102 %{_mandir}/man3/zdir.3*
103 %{_mandir}/man3/zdir_patch.3*
104 %{_mandir}/man3/zfile.3*
105 %{_mandir}/man3/zframe.3*
106 %{_mandir}/man3/zhash.3*
107 %{_mandir}/man3/zlist.3*
108 %{_mandir}/man3/zlog.3*
109 %{_mandir}/man3/zloop.3*
110 %{_mandir}/man3/zmonitor.3*
111 %{_mandir}/man3/zmsg.3*
112 %{_mandir}/man3/zmutex.3*
113 %{_mandir}/man3/zpoller.3*
114 %{_mandir}/man3/zproxy.3*
115 %{_mandir}/man3/zrex.3*
116 %{_mandir}/man3/zsocket.3*
117 %{_mandir}/man3/zsockopt.3*
118 %{_mandir}/man3/zstr.3*
119 %{_mandir}/man3/zsys.3*
120 %{_mandir}/man3/zthread.3*
121 %{_mandir}/man3/zuuid.3*
122 %{_mandir}/man7/czmq.7*
123
124 %files static
125 %defattr(644,root,root,755)
126 %{_libdir}/libczmq.a
This page took 0.065968 seconds and 3 git commands to generate.