]> git.pld-linux.org Git - packages/czmq.git/blob - czmq.spec
- allow building without systemd
[packages/czmq.git] / czmq.spec
1 Summary:        High-level C binding for 0MQ
2 Summary(pl.UTF-8):      Wysokopoziomowe wiązania C dla 0MQ
3 Name:           czmq
4 Version:        3.0.2
5 Release:        1
6 License:        LGPL v3+
7 Group:          Libraries
8 Source0:        http://download.zeromq.org/%{name}-%{version}.tar.gz
9 # Source0-md5:  7697688bf65a35bc33ae2db51ebb0e3b
10 Patch0:         no-Werror.patch
11 Patch1:         %{name}-link.patch
12 URL:            http://zeromq.org/
13 BuildRequires:  asciidoc
14 BuildRequires:  autoconf >= 2.61
15 BuildRequires:  automake
16 BuildRequires:  libsodium-devel
17 BuildRequires:  libtool
18 BuildRequires:  libuuid-devel
19 BuildRequires:  xmlto
20 BuildRequires:  zeromq-devel >= 4
21 Requires:       zeromq >= 4
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 High-level C binding for 0MQ.
26
27 %description -l pl.UTF-8
28 Wysokopoziomowe wiązania C dla 0MQ.
29
30 %package devel
31 Summary:        Header files for CZMQ library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki CZMQ
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       zeromq-devel >= 4
36
37 %description devel
38 Header files for CZMQ library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki CZMQ.
42
43 %package static
44 Summary:        Static CZMQ library
45 Summary(pl.UTF-8):      Statyczna biblioteka CZMQ
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static CZMQ library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka CZMQ.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I config
63 %{__autoconf}
64 %{__autoheader}
65 %{__automake}
66 # use include subdir - file names could be too common (zfile.h etc.)
67 %configure \
68         --disable-silent-rules \
69         --includedir=%{_includedir}/czmq
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 # obsoleted by pkg-config
79 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libczmq.la
80
81 # too common name
82 %{__mv} $RPM_BUILD_ROOT%{_bindir}/{makecert,czmq_makecert}
83 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man1/{makecert,czmq_makecert}.1
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS NEWS README.md
91 %attr(755,root,root) %{_bindir}/czmq_makecert
92 %attr(755,root,root) %{_libdir}/libczmq.so.*.*.*
93 %attr(755,root,root) %ghost %{_libdir}/libczmq.so.3
94 %{_mandir}/man1/czmq_makecert.1*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libczmq.so
99 %{_includedir}/czmq
100 %{_pkgconfigdir}/libczmq.pc
101 %{_mandir}/man3/zactor.3*
102 %{_mandir}/man3/zarmour.3*
103 %{_mandir}/man3/zauth.3*
104 %{_mandir}/man3/zauth_v2.3*
105 %{_mandir}/man3/zbeacon.3*
106 %{_mandir}/man3/zbeacon_v2.3*
107 %{_mandir}/man3/zcert.3*
108 %{_mandir}/man3/zcertstore.3*
109 %{_mandir}/man3/zchunk.3*
110 %{_mandir}/man3/zclock.3*
111 %{_mandir}/man3/zconfig.3*
112 %{_mandir}/man3/zctx.3*
113 %{_mandir}/man3/zdigest.3*
114 %{_mandir}/man3/zdir.3*
115 %{_mandir}/man3/zdir_patch.3*
116 %{_mandir}/man3/zfile.3*
117 %{_mandir}/man3/zframe.3*
118 %{_mandir}/man3/zgossip.3*
119 %{_mandir}/man3/zhash.3*
120 %{_mandir}/man3/zhashx.3*
121 %{_mandir}/man3/ziflist.3*
122 %{_mandir}/man3/zlist.3*
123 %{_mandir}/man3/zlistx.3*
124 %{_mandir}/man3/zloop.3*
125 %{_mandir}/man3/zmonitor.3*
126 %{_mandir}/man3/zmonitor_v2.3*
127 %{_mandir}/man3/zmsg.3*
128 %{_mandir}/man3/zmutex.3*
129 %{_mandir}/man3/zpoller.3*
130 %{_mandir}/man3/zproxy.3*
131 %{_mandir}/man3/zproxy_v2.3*
132 %{_mandir}/man3/zrex.3*
133 %{_mandir}/man3/zsock.3*
134 %{_mandir}/man3/zsock_option.3*
135 %{_mandir}/man3/zsocket.3*
136 %{_mandir}/man3/zsockopt.3*
137 %{_mandir}/man3/zstr.3*
138 %{_mandir}/man3/zsys.3*
139 %{_mandir}/man3/zthread.3*
140 %{_mandir}/man3/zuuid.3*
141 %{_mandir}/man7/czmq.7*
142
143 %files static
144 %defattr(644,root,root,755)
145 %{_libdir}/libczmq.a
This page took 0.173656 seconds and 3 git commands to generate.