]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
drop mysql-libs conflict; not relevant anymore and prevents using older mysql versions
[packages/curl.git] / curl.spec
index c9eaeb52a94f11abe8fdc8a0cd9f7123f66b51bb..efa2964e708c359837c40f834ea303df737972d6 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -5,7 +5,7 @@
 %bcond_with    gnutls          # GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
-%bcond_with    http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_without http2           # HTTP/2.0 support (nghttp2 based)
 %bcond_without metalink        # metalink support
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
@@ -22,31 +22,32 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.36.0
-Release:       1
+Version:       7.60.0
+Release:       2
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: 291081121e604b04e0035bfdd736d196
+Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
+# Source0-md5: a889cd11b4ae8794b7030472cb4df0a0
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
-Patch2:                %{name}-http2.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.7.0}
 %{?with_kerberos5:BuildRequires:       heimdal-devel}
-BuildRequires: libidn-devel >= 0.4.1
-%{?with_metalink:BuildRequires:        libmetalink-devel}
+BuildRequires: libbrotli-devel >= 1.0.0
+BuildRequires: libidn2-devel
+%{?with_metalink:BuildRequires:        libmetalink-devel >= 0.1.0}
+BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
-%{?with_http2:BuildRequires:   nghttp2-devel >= 0.3}
+%{?with_http2:BuildRequires:   nghttp2-devel >= 1.9.0}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -57,7 +58,6 @@ BuildRequires:        openssl-devel >= 1.0.1
 BuildRequires: tar >= 1:1.22
 BuildRequires: zlib-devel
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      libidn >= 0.4.1
 Obsoletes:     libcurl2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -116,7 +116,7 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
 %{?with_ssh:Requires:  libssh2 >= 1.2.8}
-%{?with_http2:Requires:        nghttp2 >= 0.3}
+%{?with_http2:Requires:        nghttp2-libs >= 1.9.0}
 %if %{with ssl} && %{without gnutls}
 Requires:      openssl >= 1.0.1
 %endif
@@ -139,10 +139,12 @@ Group:            Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
-Requires:      libidn-devel >= 0.4.1
+Requires:      libbrotli-devel >= 1.0.0
+Requires:      libidn2-devel
+Requires:      libpsl-devel
 %{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-devel >= 0.3}
+%{?with_http2:Requires:        nghttp2-devel >= 1.9.0}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -197,11 +199,23 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 Цей пакет містить статичну бібліотеку для розробки програм з
 використанням бібліотеки curl.
 
+%package -n zsh-completion-curl
+Summary:       ZSH completion for curl command
+Summary(pl.UTF-8):     Dopełnianianie parametrów w ZSH dla polecenia curl
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      zsh
+
+%description -n zsh-completion-curl
+ZSH completion for curl command.
+
+%description -n zsh-completion-curl -l pl.UTF-8
+Dopełnianianie parametrów w ZSH dla polecenia curl.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %{__rm} m4/lt*.m4 m4/libtool.m4
 
@@ -213,6 +227,11 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %{__automake}
 %configure \
        ac_cv_header_gss_h=no \
+       %{__enable_disable ares} \
+       --enable-ipv6 \
+       %{__enable_disable ldap} \
+       %{__enable_disable ldap ldaps} \
+       --disable-silent-rules \
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
@@ -221,13 +240,11 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        --with-ssl=%{_prefix} \
 %endif
 %endif
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_metalink:--with-libmetalink} \
-       %{?with_rtmp:--with-librtmp} \
-       %{?with_http2:--with-nghttp2} \
-       %{?with_ares:--enable-ares} \
-       --enable-ipv6 \
-       %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
+       %{__with_without kerberos5 gssapi %{_prefix}} \
+       %{__with_without metalink libmetalink} \
+       %{__with_without rtmp librtmp} \
+       %{__with_without http2 nghttp2} \
+       %{__with_without ssh libssh2}
 
 %{__make}
 
@@ -236,6 +253,9 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__make} -C scripts install \
+       DESTDIR=$RPM_BUILD_ROOT
+
 # no longer in upstream but a lot of apps tries to include it so we create fake one
 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
@@ -248,7 +268,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
+%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,MANUAL,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
 %attr(755,root,root) %{_bindir}/curl
 %{_mandir}/man1/curl.1*
 
@@ -259,7 +279,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
-%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
+%doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
 %attr(755,root,root) %{_bindir}/curl-config
 %attr(755,root,root) %{_libdir}/libcurl.so
 %{_libdir}/libcurl.la
@@ -269,7 +289,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/curl_*.3*
 %{_mandir}/man3/libcurl*.3*
+%{_mandir}/man3/CURLINFO_*.3*
+%{_mandir}/man3/CURLOPT_*.3*
+%{_mandir}/man3/CURLMOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libcurl.a
+
+%files -n zsh-completion-curl
+%defattr(644,root,root,755)
+%{_datadir}/zsh/site-functions/_curl
This page took 0.18372 seconds and 4 git commands to generate.