]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
c9eaeb52a94f11abe8fdc8a0cd9f7123f66b51bb
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # SSH support
4 %bcond_without  ssl             # SSL support
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
6 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
7 %bcond_without  ldap            # LDAP support
8 %bcond_with     http2           # HTTP/2.0 support (nghttp2 based)
9 %bcond_without  metalink        # metalink support
10 %if "%{pld_release}" != "ac"
11 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
12 %bcond_without  rtmp            # Real Time Media Protocol support
13 %else
14 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
15 %bcond_with     rtmp            # Real Time Media Protocol support
16 %endif
17
18 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
19 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
23 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
24 Name:           curl
25 Version:        7.36.0
26 Release:        1
27 License:        MIT-like
28 Group:          Applications/Networking
29 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
30 # Source0-md5:  291081121e604b04e0035bfdd736d196
31 Patch0:         %{name}-ac.patch
32 Patch1:         %{name}-krb5flags.patch
33 Patch2:         %{name}-http2.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libidn-devel >= 0.4.1
40 %{?with_metalink:BuildRequires: libmetalink-devel}
41 %{?with_rtmp:BuildRequires:     librtmp-devel}
42 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
43 BuildRequires:  libtool
44 BuildRequires:  nettle-devel
45 %{?with_http2:BuildRequires:    nghttp2-devel >= 0.3}
46 %{?with_ldap:BuildRequires:     openldap-devel}
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm >= 4.4.9-56
49 BuildRequires:  rpmbuild(macros) >= 1.453
50 %if %{with ssl}
51 %if %{with gnutls}
52 BuildRequires:  gnutls-devel
53 %else
54 BuildRequires:  openssl-devel >= 1.0.1
55 %endif
56 %endif
57 BuildRequires:  tar >= 1:1.22
58 BuildRequires:  zlib-devel
59 Requires:       %{name}-libs = %{version}-%{release}
60 Requires:       libidn >= 0.4.1
61 Obsoletes:      libcurl2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 cURL is a tool for getting files with URL syntax, supporting FTP,
66 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
67 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
68 cookies, user+password authentication and a busload of other useful
69 tricks. The main use for curl is when you want to get or send files
70 automatically to or from a site using one of the supported protocols.
71
72 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
73 Dict servers, using any of the supported protocols. cURL is designed
74 to work without user interaction or any kind of interactivity. cURL
75 offers many useful capabilities, like proxy support, user
76 authentication, FTP upload, HTTP post, and file transfer resume.
77
78 %description -l pl.UTF-8
79 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
80 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
81 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
82 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
83 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
84 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
85 pliki z/na serwer używając jednego z dostępnych protokołów.
86 %{?with_ssl:Ten pakiet obsługuje także SSL.}
87
88 %description -l pt_BR.UTF-8
89 Curl é um cliente para baixar/enviar arquivos de/para servidores
90 usando um dos protocolos suportados. É projetado para funcionar sem a
91 interação do usuário.
92
93 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
94 continuar transferências interrompidas, e mais...
95
96 %description -l ru.UTF-8
97 curl - это клиент с множеством поддерживаемых протоколов для получения
98 файлов с серверов, спроектированный для работы как в неинтерактивном
99 режиме, так и с возможностью диалога с пользователем.
100
101 curl поддерживает много полезных возможностей, среди которых поддержка
102 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
103 POST, восстановление прерванной пересылки и многое другое.
104
105 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
106 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
107 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
108
109 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
110 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
111 в╕дновлення перервано╖ пересилки та багато ╕ншого.
112
113 %package libs
114 Summary:        curl library
115 Summary(pl.UTF-8):      Biblioteka curl
116 Group:          Libraries
117 %{?with_ares:Requires:  c-ares >= 1.7.0}
118 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
119 %{?with_http2:Requires: nghttp2 >= 0.3}
120 %if %{with ssl} && %{without gnutls}
121 Requires:       openssl >= 1.0.1
122 %endif
123 Suggests:       ca-certificates
124 Conflicts:      ca-certificates < 20080809-4
125
126 %description libs
127 curl library.
128
129 %description libs -l pl.UTF-8
130 Biblioteka curl.
131
132 %package devel
133 Summary:        Header files and development documentation for curl library
134 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
135 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
136 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
137 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{version}-%{release}
140 %{?with_ares:Requires:  c-ares-devel}
141 %{?with_kerberos5:Requires:     heimdal-devel}
142 Requires:       libidn-devel >= 0.4.1
143 %{?with_rtmp:Requires:  librtmp-devel}
144 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
145 %{?with_http2:Requires: nghttp2-devel >= 0.3}
146 %{?with_ldap:Requires:  openldap-devel}
147 %if %{with ssl}
148 %if %{with gnutls}
149 Requires:       gnutls-devel
150 %else
151 Requires:       openssl-devel >= 0.9.7c
152 %endif
153 %endif
154 Requires:       zlib-devel
155 Obsoletes:      libcurl2-devel
156
157 %description devel
158 Header files and development documentation for curl library.
159
160 %description devel -l pl.UTF-8
161 Pliki nagłówkowe i dokumentacja do biblioteki curl.
162
163 %description devel -l pt_BR.UTF-8
164 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
165
166 %description devel -l ru.UTF-8
167 Этот пакет содержит файлы, необходимые для разработки программ с
168 использованием библиотеки curl.
169
170 %description devel -l uk.UTF-8
171 Цей пакет містить файли, необхідні для розробки програм з
172 використанням бібліотеки curl.
173
174 %package static
175 Summary:        Static version of curl library
176 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
177 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
178 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
179 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description static
184 Static version of curl library.
185
186 %description static -l pl.UTF-8
187 Statyczna wersja biblioteki curl.
188
189 %description static -l pt_BR.UTF-8
190 Bibliotecas estáticas para desenvolvimento com o curl.
191
192 %description static -l ru.UTF-8
193 Этот пакет содержит статическую библиотеку для разработки программ с
194 использованием библиотеки curl.
195
196 %description static -l uk.UTF-8
197 Цей пакет містить статичну бібліотеку для розробки програм з
198 використанням бібліотеки curl.
199
200 %prep
201 %setup -q
202 %patch0 -p1
203 %patch1 -p1
204 %patch2 -p1
205
206 %{__rm} m4/lt*.m4 m4/libtool.m4
207
208 %build
209 %{__libtoolize}
210 %{__aclocal} -I m4
211 %{__autoconf}
212 %{__autoheader}
213 %{__automake}
214 %configure \
215         ac_cv_header_gss_h=no \
216 %if %{with ssl}
217         --with-ca-bundle=/etc/certs/ca-certificates.crt \
218 %if %{with gnutls}
219         --with-gnutls --without-ssl \
220 %else
221         --with-ssl=%{_prefix} \
222 %endif
223 %endif
224         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
225         %{?with_metalink:--with-libmetalink} \
226         %{?with_rtmp:--with-librtmp} \
227         %{?with_http2:--with-nghttp2} \
228         %{?with_ares:--enable-ares} \
229         --enable-ipv6 \
230         %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
231
232 %{__make}
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236 %{__make} install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 # no longer in upstream but a lot of apps tries to include it so we create fake one
240 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
241 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post   libs -p /sbin/ldconfig
247 %postun libs -p /sbin/ldconfig
248
249 %files
250 %defattr(644,root,root,755)
251 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
252 %attr(755,root,root) %{_bindir}/curl
253 %{_mandir}/man1/curl.1*
254
255 %files libs
256 %defattr(644,root,root,755)
257 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
258 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
259
260 %files devel
261 %defattr(644,root,root,755)
262 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
263 %attr(755,root,root) %{_bindir}/curl-config
264 %attr(755,root,root) %{_libdir}/libcurl.so
265 %{_libdir}/libcurl.la
266 %{_includedir}/curl
267 %{_pkgconfigdir}/libcurl.pc
268 %{_aclocaldir}/libcurl.m4
269 %{_mandir}/man1/curl-config.1*
270 %{_mandir}/man3/curl_*.3*
271 %{_mandir}/man3/libcurl*.3*
272
273 %files static
274 %defattr(644,root,root,755)
275 %{_libdir}/libcurl.a
This page took 0.04616 seconds and 3 git commands to generate.