]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
without ssh2 fix
[packages/curl.git] / curl.spec
index c9eaeb52a94f11abe8fdc8a0cd9f7123f66b51bb..24074df10201c69451118a34df05600787dfa3de 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -5,7 +5,7 @@
 %bcond_with    gnutls          # GnuTLS instead of OpenSSL
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
-%bcond_with    http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_without http2           # HTTP/2.0 support (nghttp2 based)
 %bcond_without metalink        # metalink support
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
@@ -22,15 +22,14 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.36.0
+Version:       7.42.1
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
 Source0:       http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
-# Source0-md5: 291081121e604b04e0035bfdd736d196
+# Source0-md5: f1e460020a99da039b153e4bf0cd8600
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
-Patch2:                %{name}-http2.patch
 URL:           http://curl.haxx.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
@@ -42,11 +41,11 @@ BuildRequires:      libidn-devel >= 0.4.1
 %{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
 BuildRequires: libtool
 BuildRequires: nettle-devel
-%{?with_http2:BuildRequires:   nghttp2-devel >= 0.3}
+%{?with_http2:BuildRequires:   nghttp2-devel >= 0.6}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
-BuildRequires: rpmbuild(macros) >= 1.453
+BuildRequires: rpmbuild(macros) >= 1.527
 %if %{with ssl}
 %if %{with gnutls}
 BuildRequires: gnutls-devel
@@ -116,7 +115,7 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.7.0}
 %{?with_ssh:Requires:  libssh2 >= 1.2.8}
-%{?with_http2:Requires:        nghttp2 >= 0.3}
+%{?with_http2:Requires:        nghttp2 >= 0.6}
 %if %{with ssl} && %{without gnutls}
 Requires:      openssl >= 1.0.1
 %endif
@@ -142,7 +141,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 Requires:      libidn-devel >= 0.4.1
 %{?with_rtmp:Requires: librtmp-devel}
 %{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-devel >= 0.3}
+%{?with_http2:Requires:        nghttp2-devel >= 0.6}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -201,7 +200,6 @@ Bibliotecas estáticas para desenvolvimento com o curl.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 
 %{__rm} m4/lt*.m4 m4/libtool.m4
 
@@ -221,13 +219,15 @@ Bibliotecas estáticas para desenvolvimento com o curl.
        --with-ssl=%{_prefix} \
 %endif
 %endif
-       %{?with_kerberos5:--with-gssapi=%{_prefix}} \
-       %{?with_metalink:--with-libmetalink} \
-       %{?with_rtmp:--with-librtmp} \
-       %{?with_http2:--with-nghttp2} \
-       %{?with_ares:--enable-ares} \
+       %{__with_without kerberos5 gssapi %{_prefix}} \
+       %{__with_without metalink libmetalink} \
+       %{__with_without rtmp librtmp} \
+       %{__with_without http2 nghttp2} \
+       %{__enable_disable ares} \
+       %{__with_without ssh libssh2} \
        --enable-ipv6 \
-       %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
+       %{__enable_disable ldap} \
+       %{__enable_disable ldap ldaps}
 
 %{__make}
 
@@ -269,6 +269,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/curl-config.1*
 %{_mandir}/man3/curl_*.3*
 %{_mandir}/man3/libcurl*.3*
+%{_mandir}/man3/CURLOPT_*.3*
+%{_mandir}/man3/CURLMOPT_*.3*
 
 %files static
 %defattr(644,root,root,755)
This page took 0.103055 seconds and 4 git commands to generate.