]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
bump libbrotli version required as there was no SOVER++
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
8 %bcond_without  ldap            # LDAP support
9 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
10 %bcond_without  metalink        # metalink support
11 %if "%{pld_release}" != "ac"
12 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
13 %bcond_without  rtmp            # Real Time Media Protocol support
14 %else
15 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
16 %bcond_with     rtmp            # Real Time Media Protocol support
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.67.0
27 Release:        1
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
31 # Source0-md5:  d55351b88dec558dd3a24dabb2c2d899
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libbrotli-devel >= 1.0.0
40 BuildRequires:  libidn2-devel
41 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42 BuildRequires:  libpsl-devel
43 %{?with_rtmp:BuildRequires:     librtmp-devel}
44 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
45 BuildRequires:  libtool
46 BuildRequires:  nettle-devel
47 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.9.0}
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.527
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel
55 %else
56 BuildRequires:  openssl-devel >= 1.0.1
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Obsoletes:      libcurl2
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 cURL is a tool for getting files with URL syntax, supporting FTP,
67 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
68 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
69 cookies, user+password authentication and a busload of other useful
70 tricks. The main use for curl is when you want to get or send files
71 automatically to or from a site using one of the supported protocols.
72
73 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
74 Dict servers, using any of the supported protocols. cURL is designed
75 to work without user interaction or any kind of interactivity. cURL
76 offers many useful capabilities, like proxy support, user
77 authentication, FTP upload, HTTP post, and file transfer resume.
78
79 %description -l pl.UTF-8
80 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
81 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
82 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
83 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
84 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
85 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
86 pliki z/na serwer używając jednego z dostępnych protokołów.
87 %{?with_ssl:Ten pakiet obsługuje także SSL.}
88
89 %description -l pt_BR.UTF-8
90 Curl é um cliente para baixar/enviar arquivos de/para servidores
91 usando um dos protocolos suportados. É projetado para funcionar sem a
92 interação do usuário.
93
94 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
95 continuar transferências interrompidas, e mais...
96
97 %description -l ru.UTF-8
98 curl - это клиент с множеством поддерживаемых протоколов для получения
99 файлов с серверов, спроектированный для работы как в неинтерактивном
100 режиме, так и с возможностью диалога с пользователем.
101
102 curl поддерживает много полезных возможностей, среди которых поддержка
103 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
104 POST, восстановление прерванной пересылки и многое другое.
105
106 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
107 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
108 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
109
110 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
111 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
112 в╕дновлення перервано╖ пересилки та багато ╕ншого.
113
114 %package libs
115 Summary:        curl library
116 Summary(pl.UTF-8):      Biblioteka curl
117 Group:          Libraries
118 %{?with_ares:Requires:  c-ares >= 1.7.0}
119 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
120 %{?with_http2:Requires: nghttp2-libs >= 1.9.0}
121 %if %{with ssl} && %{without gnutls}
122 Requires:       libbrotli >= 1.0.0
123 Requires:       openssl >= 1.0.1
124 %endif
125 Suggests:       ca-certificates
126 Conflicts:      ca-certificates < 20080809-4
127
128 %description libs
129 curl library.
130
131 %description libs -l pl.UTF-8
132 Biblioteka curl.
133
134 %package devel
135 Summary:        Header files and development documentation for curl library
136 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
137 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
138 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
139 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
140 Group:          Development/Libraries
141 Requires:       %{name}-libs = %{version}-%{release}
142 %{?with_ares:Requires:  c-ares-devel}
143 %{?with_kerberos5:Requires:     heimdal-devel}
144 Requires:       libbrotli-devel >= 1.0.0
145 Requires:       libidn2-devel
146 Requires:       libpsl-devel
147 %{?with_rtmp:Requires:  librtmp-devel}
148 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
149 %{?with_http2:Requires: nghttp2-devel >= 1.9.0}
150 %{?with_ldap:Requires:  openldap-devel}
151 %if %{with ssl}
152 %if %{with gnutls}
153 Requires:       gnutls-devel
154 %else
155 Requires:       openssl-devel >= 0.9.7c
156 %endif
157 %endif
158 Requires:       zlib-devel
159 Obsoletes:      libcurl2-devel
160
161 %description devel
162 Header files and development documentation for curl library.
163
164 %description devel -l pl.UTF-8
165 Pliki nagłówkowe i dokumentacja do biblioteki curl.
166
167 %description devel -l pt_BR.UTF-8
168 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
169
170 %description devel -l ru.UTF-8
171 Этот пакет содержит файлы, необходимые для разработки программ с
172 использованием библиотеки curl.
173
174 %description devel -l uk.UTF-8
175 Цей пакет містить файли, необхідні для розробки програм з
176 використанням бібліотеки curl.
177
178 %package static
179 Summary:        Static version of curl library
180 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
181 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
182 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
183 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
184 Group:          Development/Libraries
185 Requires:       %{name}-devel = %{version}-%{release}
186
187 %description static
188 Static version of curl library.
189
190 %description static -l pl.UTF-8
191 Statyczna wersja biblioteki curl.
192
193 %description static -l pt_BR.UTF-8
194 Bibliotecas estáticas para desenvolvimento com o curl.
195
196 %description static -l ru.UTF-8
197 Этот пакет содержит статическую библиотеку для разработки программ с
198 использованием библиотеки curl.
199
200 %description static -l uk.UTF-8
201 Цей пакет містить статичну бібліотеку для розробки програм з
202 використанням бібліотеки curl.
203
204 %package -n fish-completion-%{name}
205 Summary:        Fish completion for curl command
206 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
207 Group:          Applications/Shells
208 Requires:       %{name} = %{version}-%{release}
209 Requires:       fish
210
211 %description -n fish-completion-%{name}
212 Fish completion for curl command.
213
214 %description -n fish-completion-%{name} -l pl.UTF-8
215 Dopełnianie parametrów w fish dla polecenia curl.
216
217 %package -n zsh-completion-curl
218 Summary:        ZSH completion for curl command
219 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
220 Group:          Applications/Shells
221 Requires:       %{name} = %{version}-%{release}
222 Requires:       zsh
223
224 %description -n zsh-completion-curl
225 ZSH completion for curl command.
226
227 %description -n zsh-completion-curl -l pl.UTF-8
228 Dopełnianianie parametrów w ZSH dla polecenia curl.
229
230 %prep
231 %setup -q
232 %patch0 -p1
233 %patch1 -p1
234
235 %{__rm} m4/lt*.m4 m4/libtool.m4
236
237 %build
238 %{__libtoolize}
239 %{__aclocal} -I m4
240 %{__autoconf}
241 %{__autoheader}
242 %{__automake}
243 %configure \
244         ac_cv_header_gss_h=no \
245         %{__enable_disable ares} \
246         --enable-ipv6 \
247         %{__enable_disable ldap} \
248         %{__enable_disable ldap ldaps} \
249         --disable-silent-rules \
250 %if %{with ssl}
251         --with-ca-bundle=/etc/certs/ca-certificates.crt \
252 %if %{with gnutls}
253         --with-gnutls --without-ssl \
254 %else
255         --with-ssl=%{_prefix} \
256 %endif
257 %else
258         --without-ssl --without-gnutls \
259 %endif
260         --with-fish-functions-dir=%{fish_compdir} \
261         %{__with_without kerberos5 gssapi %{_prefix}} \
262         %{__with_without metalink libmetalink} \
263         %{__with_without rtmp librtmp} \
264         %{__with_without http2 nghttp2} \
265         %{__with_without ssh libssh2}
266
267 %{__make}
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 %{__make} install \
272         DESTDIR=$RPM_BUILD_ROOT
273
274 %{__make} -C scripts install \
275         DESTDIR=$RPM_BUILD_ROOT
276
277 # no longer in upstream but a lot of apps tries to include it so we create fake one
278 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
279 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
280
281 %clean
282 rm -rf $RPM_BUILD_ROOT
283
284 %post   libs -p /sbin/ldconfig
285 %postun libs -p /sbin/ldconfig
286
287 %files
288 %defattr(644,root,root,755)
289 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting}
290 %attr(755,root,root) %{_bindir}/curl
291 %{_mandir}/man1/curl.1*
292
293 %files libs
294 %defattr(644,root,root,755)
295 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
296 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
297
298 %files devel
299 %defattr(644,root,root,755)
300 %doc docs/{CONTRIBUTE.md,INTERNALS.md,LICENSE-MIXING.md,RESOURCES}
301 %attr(755,root,root) %{_bindir}/curl-config
302 %attr(755,root,root) %{_libdir}/libcurl.so
303 %{_libdir}/libcurl.la
304 %{_includedir}/curl
305 %{_pkgconfigdir}/libcurl.pc
306 %{_aclocaldir}/libcurl.m4
307 %{_mandir}/man1/curl-config.1*
308 %{_mandir}/man3/curl_*.3*
309 %{_mandir}/man3/libcurl*.3*
310 %{_mandir}/man3/CURLINFO_*.3*
311 %{_mandir}/man3/CURLOPT_*.3*
312 %{_mandir}/man3/CURLMOPT_*.3*
313
314 %files static
315 %defattr(644,root,root,755)
316 %{_libdir}/libcurl.a
317
318 %files -n fish-completion-%{name}
319 %defattr(644,root,root,755)
320 %{fish_compdir}/%{name}.fish
321
322 %files -n zsh-completion-curl
323 %defattr(644,root,root,755)
324 %{_datadir}/zsh/site-functions/_curl
This page took 0.102126 seconds and 3 git commands to generate.