]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.6.
[packages/curl.git] / curl.spec
1 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
2 Summary(pl):    narzêdziem do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
3 Name:           curl
4 Version:        7.6
5 Release:        1
6 License:        MPL
7 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
8 Group:          Applications/Networking
9 Group(de):      Applikationen/Netzwerkwesen
10 Group(pl):      Aplikacje/Sieciowe
11 Source0:        http://curl.haxx.se/stuff/%{name}-%{version}.tar.gz
12 URL:            http://curl.haxx.se/
13 BuildRequires:  openssl-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 cURL is a tool for getting files with URL syntax, supporting FTP,
18 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
19 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
20 cookies, user+password authentication and a busload of other useful
21 tricks. The main use for curl is when you want to get or send files
22 automatically to or from a site using one of the supported protocols.
23
24 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
25 Dict servers, using any of the supported protocols. cURL is designed
26 to work without user interaction or any kind of interactivity. cURL
27 offers many useful capabilities, like proxy support, user
28 authentication, FTP upload, HTTP post, and file transfer resume.
29
30 %description -l pl
31 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
32 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
33 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
34 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
35 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
36 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
37 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
38
39 %package devel
40 Summary:        Header files and development documentation for curl library
41 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
42 Group:          Development/Libraries
43 Group(de):      Entwicklung/Libraries
44 Group(fr):      Development/Librairies
45 Group(pl):      Programowanie/Biblioteki
46 Requires:       %{name} = %{version}
47
48 %description devel
49 Header files and development documentation for curl library.
50
51 %description -l pl devel
52 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
53
54 %package static
55 Summary:        Static version of curl library
56 Summary(pl):    Statyczna wersja biblioteki curl
57 Group:          Development/Libraries
58 Group(de):      Entwicklung/Libraries
59 Group(fr):      Development/Librairies
60 Group(pl):      Programowanie/Biblioteki
61 Requires:       %{name}-devel = %{version}
62
63 %description static
64 Static version of curl library
65
66 %description -l pl static
67 Statyczna wersja biblioteki curl.
68
69 %prep
70 %setup -q 
71
72 %build
73 %configure \
74         --with-ssl=/usr
75 %{__make} 
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install DESTDIR=$RPM_BUILD_ROOT
81
82 gzip -9nf docs/{BUGS,RESOURCES,CONTRIBUTE,FEATURES,FAQ,INTERNALS,README*,TODO,TheArtOfHttpScripting}
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc docs/*.gz
93 %attr(755,root,root) %{_bindir}/%{name}
94 %attr(755,root,root) %{_libdir}/lib*.so.*
95 %{_mandir}/man1/*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/lib*.so
100 %attr(755,root,root) %{_libdir}/lib*.la
101 %{_mandir}/man3/*
102 %{_includedir}/*
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/lib*.a
This page took 0.054828 seconds and 3 git commands to generate.