]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- force nghttp2 1.9.0+ (new symbols required at runtime if available at compile time)
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # SSH support
4 %bcond_without  ssl             # SSL support
5 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
6 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
7 %bcond_without  ldap            # LDAP support
8 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
9 %bcond_without  metalink        # metalink support
10 %if "%{pld_release}" != "ac"
11 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
12 %bcond_without  rtmp            # Real Time Media Protocol support
13 %else
14 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
15 %bcond_with     rtmp            # Real Time Media Protocol support
16 %endif
17
18 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
19 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
23 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
24 Name:           curl
25 Version:        7.49.1
26 Release:        1
27 License:        MIT-like
28 Group:          Applications/Networking
29 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.lzma
30 # Source0-md5:  ae5e5e395da413d1fa0864e1d0a3fa57
31 Patch0:         %{name}-ac.patch
32 Patch1:         %{name}-krb5flags.patch
33 URL:            http://curl.haxx.se/
34 BuildRequires:  autoconf >= 2.57
35 BuildRequires:  automake
36 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
37 %{?with_kerberos5:BuildRequires:        heimdal-devel}
38 BuildRequires:  libidn-devel >= 0.4.1
39 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
40 BuildRequires:  libpsl-devel
41 %{?with_rtmp:BuildRequires:     librtmp-devel}
42 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
43 BuildRequires:  libtool
44 BuildRequires:  nettle-devel
45 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.9.0}
46 %{?with_ldap:BuildRequires:     openldap-devel}
47 BuildRequires:  pkgconfig
48 BuildRequires:  rpm >= 4.4.9-56
49 BuildRequires:  rpmbuild(macros) >= 1.527
50 %if %{with ssl}
51 %if %{with gnutls}
52 BuildRequires:  gnutls-devel
53 %else
54 BuildRequires:  openssl-devel >= 1.0.1
55 %endif
56 %endif
57 BuildRequires:  tar >= 1:1.22
58 BuildRequires:  zlib-devel
59 Requires:       %{name}-libs = %{version}-%{release}
60 Requires:       libidn >= 0.4.1
61 Obsoletes:      libcurl2
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 %description
65 cURL is a tool for getting files with URL syntax, supporting FTP,
66 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
67 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
68 cookies, user+password authentication and a busload of other useful
69 tricks. The main use for curl is when you want to get or send files
70 automatically to or from a site using one of the supported protocols.
71
72 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
73 Dict servers, using any of the supported protocols. cURL is designed
74 to work without user interaction or any kind of interactivity. cURL
75 offers many useful capabilities, like proxy support, user
76 authentication, FTP upload, HTTP post, and file transfer resume.
77
78 %description -l pl.UTF-8
79 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
80 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
81 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
82 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
83 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
84 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
85 pliki z/na serwer używając jednego z dostępnych protokołów.
86 %{?with_ssl:Ten pakiet obsługuje także SSL.}
87
88 %description -l pt_BR.UTF-8
89 Curl é um cliente para baixar/enviar arquivos de/para servidores
90 usando um dos protocolos suportados. É projetado para funcionar sem a
91 interação do usuário.
92
93 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
94 continuar transferências interrompidas, e mais...
95
96 %description -l ru.UTF-8
97 curl - это клиент с множеством поддерживаемых протоколов для получения
98 файлов с серверов, спроектированный для работы как в неинтерактивном
99 режиме, так и с возможностью диалога с пользователем.
100
101 curl поддерживает много полезных возможностей, среди которых поддержка
102 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
103 POST, восстановление прерванной пересылки и многое другое.
104
105 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
106 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
107 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
108
109 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
110 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
111 в╕дновлення перервано╖ пересилки та багато ╕ншого.
112
113 %package libs
114 Summary:        curl library
115 Summary(pl.UTF-8):      Biblioteka curl
116 Group:          Libraries
117 %{?with_ares:Requires:  c-ares >= 1.7.0}
118 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
119 %{?with_http2:Requires: nghttp2 >= 1.9.0}
120 %if %{with ssl} && %{without gnutls}
121 Requires:       openssl >= 1.0.1
122 %endif
123 Suggests:       ca-certificates
124 Conflicts:      ca-certificates < 20080809-4
125
126 %description libs
127 curl library.
128
129 %description libs -l pl.UTF-8
130 Biblioteka curl.
131
132 %package devel
133 Summary:        Header files and development documentation for curl library
134 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
135 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
136 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
137 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
138 Group:          Development/Libraries
139 Requires:       %{name}-libs = %{version}-%{release}
140 %{?with_ares:Requires:  c-ares-devel}
141 %{?with_kerberos5:Requires:     heimdal-devel}
142 Requires:       libidn-devel >= 0.4.1
143 Requires:       libpsl-devel
144 %{?with_rtmp:Requires:  librtmp-devel}
145 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
146 %{?with_http2:Requires: nghttp2-devel >= 1.9.0}
147 %{?with_ldap:Requires:  openldap-devel}
148 %if %{with ssl}
149 %if %{with gnutls}
150 Requires:       gnutls-devel
151 %else
152 Requires:       openssl-devel >= 0.9.7c
153 %endif
154 %endif
155 Requires:       zlib-devel
156 Obsoletes:      libcurl2-devel
157
158 %description devel
159 Header files and development documentation for curl library.
160
161 %description devel -l pl.UTF-8
162 Pliki nagłówkowe i dokumentacja do biblioteki curl.
163
164 %description devel -l pt_BR.UTF-8
165 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
166
167 %description devel -l ru.UTF-8
168 Этот пакет содержит файлы, необходимые для разработки программ с
169 использованием библиотеки curl.
170
171 %description devel -l uk.UTF-8
172 Цей пакет містить файли, необхідні для розробки програм з
173 використанням бібліотеки curl.
174
175 %package static
176 Summary:        Static version of curl library
177 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
178 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
179 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
180 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183
184 %description static
185 Static version of curl library.
186
187 %description static -l pl.UTF-8
188 Statyczna wersja biblioteki curl.
189
190 %description static -l pt_BR.UTF-8
191 Bibliotecas estáticas para desenvolvimento com o curl.
192
193 %description static -l ru.UTF-8
194 Этот пакет содержит статическую библиотеку для разработки программ с
195 использованием библиотеки curl.
196
197 %description static -l uk.UTF-8
198 Цей пакет містить статичну бібліотеку для розробки програм з
199 використанням бібліотеки curl.
200
201 %package -n zsh-completion-curl
202 Summary:        ZSH completion for curl command
203 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
204 Group:          Applications/Shells
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       zsh
207
208 %description -n zsh-completion-curl
209 ZSH completion for curl command.
210
211 %description -n zsh-completion-curl -l pl.UTF-8
212 Dopełnianianie parametrów w ZSH dla polecenia curl.
213
214 %prep
215 %setup -q
216 %patch0 -p1
217 %patch1 -p1
218
219 %{__rm} m4/lt*.m4 m4/libtool.m4
220
221 %build
222 %{__libtoolize}
223 %{__aclocal} -I m4
224 %{__autoconf}
225 %{__autoheader}
226 %{__automake}
227 %configure \
228         ac_cv_header_gss_h=no \
229         %{__enable_disable ares} \
230         --enable-ipv6 \
231         %{__enable_disable ldap} \
232         %{__enable_disable ldap ldaps} \
233         --disable-silent-rules \
234 %if %{with ssl}
235         --with-ca-bundle=/etc/certs/ca-certificates.crt \
236 %if %{with gnutls}
237         --with-gnutls --without-ssl \
238 %else
239         --with-ssl=%{_prefix} \
240 %endif
241 %endif
242         %{__with_without kerberos5 gssapi %{_prefix}} \
243         %{__with_without metalink libmetalink} \
244         %{__with_without rtmp librtmp} \
245         %{__with_without http2 nghttp2} \
246         %{__with_without ssh libssh2}
247
248 %{__make}
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252 %{__make} install \
253         DESTDIR=$RPM_BUILD_ROOT
254
255 %{__make} -C scripts install \
256         DESTDIR=$RPM_BUILD_ROOT
257
258 # no longer in upstream but a lot of apps tries to include it so we create fake one
259 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
260 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %post   libs -p /sbin/ldconfig
266 %postun libs -p /sbin/ldconfig
267
268 %files
269 %defattr(644,root,root,755)
270 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
271 %attr(755,root,root) %{_bindir}/curl
272 %{_mandir}/man1/curl.1*
273
274 %files libs
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
277 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
278
279 %files devel
280 %defattr(644,root,root,755)
281 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
282 %attr(755,root,root) %{_bindir}/curl-config
283 %attr(755,root,root) %{_libdir}/libcurl.so
284 %{_libdir}/libcurl.la
285 %{_includedir}/curl
286 %{_pkgconfigdir}/libcurl.pc
287 %{_aclocaldir}/libcurl.m4
288 %{_mandir}/man1/curl-config.1*
289 %{_mandir}/man3/curl_*.3*
290 %{_mandir}/man3/libcurl*.3*
291 %{_mandir}/man3/CURLINFO_*.3*
292 %{_mandir}/man3/CURLOPT_*.3*
293 %{_mandir}/man3/CURLMOPT_*.3*
294
295 %files static
296 %defattr(644,root,root,755)
297 %{_libdir}/libcurl.a
298
299 %files -n zsh-completion-curl
300 %defattr(644,root,root,755)
301 %{_datadir}/zsh/site-functions/_curl
This page took 0.071304 seconds and 3 git commands to generate.