]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.17.1
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  kerberos5       # without MIT Kerberos 5 support
7 #
8 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
9 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
10 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
11 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
12 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
13 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
14 Name:           curl
15 Version:        7.17.1
16 Release:        1
17 License:        MIT-like
18 Group:          Applications/Networking
19 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
20 # Source0-md5:  1fa635d1dfde8337c98c82749d75c1de
21 Patch0:         %{name}-no_strip.patch
22 Patch1:         %{name}-ac.patch
23 Patch2:         %{name}-pc.patch
24 URL:            http://curl.haxx.se/
25 BuildRequires:  autoconf >= 2.57
26 BuildRequires:  automake
27 %{?with_ares:BuildRequires:     c-ares-devel}
28 %{?with_kerberos5:BuildRequires:        krb5-devel}
29 BuildRequires:  libidn-devel >= 0.4.1
30 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
31 BuildRequires:  libtool
32 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
33 BuildRequires:  zlib-devel
34 Requires:       %{name}-libs = %{version}-%{release}
35 Requires:       libidn >= 0.4.1
36 %{?with_ssh:Requires:   libssh2 >= 0.16}
37 Requires:       openssl-tools >= 0.9.7d
38 Obsoletes:      libcurl2
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 cURL is a tool for getting files with URL syntax, supporting FTP,
43 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
44 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
45 cookies, user+password authentication and a busload of other useful
46 tricks. The main use for curl is when you want to get or send files
47 automatically to or from a site using one of the supported protocols.
48
49 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
50 Dict servers, using any of the supported protocols. cURL is designed
51 to work without user interaction or any kind of interactivity. cURL
52 offers many useful capabilities, like proxy support, user
53 authentication, FTP upload, HTTP post, and file transfer resume.
54
55 %description -l pl.UTF-8
56 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
57 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
58 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
59 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
60 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
61 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
62 pliki z/na serwer używając jednego z dostępnych protokołów.
63 %{?with_ssl:Ten pakiet obsługuje także SSL.}
64
65 %description -l pt_BR.UTF-8
66 Curl é um cliente para baixar/enviar arquivos de/para servidores
67 usando um dos protocolos suportados. É projetado para funcionar sem a
68 interação do usuário.
69
70 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
71 continuar transferências interrompidas, e mais...
72
73 %description -l ru.UTF-8
74 curl - это клиент с множеством поддерживаемых протоколов для получения
75 файлов с серверов, спроектированный для работы как в неинтерактивном
76 режиме, так и с возможностью диалога с пользователем.
77
78 curl поддерживает много полезных возможностей, среди которых поддержка
79 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
80 POST, восстановление прерванной пересылки и многое другое.
81
82 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
83 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
84 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
85
86 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
87 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
88 в╕дновлення перервано╖ пересилки та багато ╕ншого.
89
90 %package libs
91 Summary:        curl library
92 Summary(pl.UTF-8):      Biblioteka curl
93 Group:          Libraries
94
95 %description libs
96 curl library.
97
98 %description libs -l pl.UTF-8
99 Biblioteka curl.
100
101 %package devel
102 Summary:        Header files and development documentation for curl library
103 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
104 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
105 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
106 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
107 Group:          Development/Libraries
108 Requires:       %{name}-libs = %{version}-%{release}
109 %{?with_ares:Requires:  c-ares-devel}
110 %{?with_kerberos5:Requires:     krb5-devel}
111 Requires:       libidn-devel >= 0.4.1
112 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
113 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
114 Requires:       zlib-devel
115 Obsoletes:      libcurl2-devel
116
117 %description devel
118 Header files and development documentation for curl library.
119
120 %description devel -l pl.UTF-8
121 Pliki nagłówkowe i dokumentacja do biblioteki curl.
122
123 %description devel -l pt_BR.UTF-8
124 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
125
126 %description devel -l ru.UTF-8
127 Этот пакет содержит файлы, необходимые для разработки программ с
128 использованием библиотеки curl.
129
130 %description devel -l uk.UTF-8
131 Цей пакет містить файли, необхідні для розробки програм з
132 використанням бібліотеки curl.
133
134 %package static
135 Summary:        Static version of curl library
136 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
137 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
138 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
139 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description static
144 Static version of curl library.
145
146 %description static -l pl.UTF-8
147 Statyczna wersja biblioteki curl.
148
149 %description static -l pt_BR.UTF-8
150 Bibliotecas estáticas para desenvolvimento com o curl.
151
152 %description static -l ru.UTF-8
153 Этот пакет содержит статическую библиотеку для разработки программ с
154 использованием библиотеки curl.
155
156 %description static -l uk.UTF-8
157 Цей пакет містить статичну бібліотеку для розробки програм з
158 використанням бібліотеки curl.
159
160 %prep
161 %setup -q
162 %patch0 -p1
163 %patch1 -p1
164 %patch2 -p1
165
166 %build
167 %{__libtoolize}
168 %{__aclocal}
169 %{__autoconf}
170 %{__autoheader}
171 %{__automake}
172 %configure \
173         ac_cv_header_gss_h=no \
174         %{?with_ssl:--with-ssl=%{_prefix}} \
175         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
176         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
177         %{?with_ares:--enable-ares=%{_prefix}} \
178         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
179
180 %{__make}
181
182 %install
183 rm -rf $RPM_BUILD_ROOT
184
185 %{__make} install \
186         DESTDIR=$RPM_BUILD_ROOT
187
188 %clean
189 rm -rf $RPM_BUILD_ROOT
190
191 %post   libs -p /sbin/ldconfig
192 %postun libs -p /sbin/ldconfig
193
194 %files
195 %defattr(644,root,root,755)
196 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
197 %attr(755,root,root) %{_bindir}/curl
198 %{_mandir}/man1/curl.1*
199
200 %files libs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
203
204 %files devel
205 %defattr(644,root,root,755)
206 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
207 %attr(755,root,root) %{_bindir}/curl-config
208 %attr(755,root,root) %{_libdir}/libcurl.so
209 %{_libdir}/libcurl.la
210 %{_includedir}/curl
211 %{_pkgconfigdir}/libcurl.pc
212 %{_mandir}/man1/curl-config.1*
213 %{_mandir}/man3/*curl*.3*
214
215 %files static
216 %defattr(644,root,root,755)
217 %{_libdir}/libcurl.a
This page took 0.062996 seconds and 3 git commands to generate.