]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
fix %doc; rel 2
[packages/curl.git] / curl.spec
1 # TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl)
2 #
3 # Conditional build:
4 %bcond_without  ssh             # SSH support
5 %bcond_without  ssl             # SSL support
6 %bcond_with     gnutls          # GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # Heimdal Kerberos 5 support
8 %bcond_without  ldap            # LDAP support
9 %bcond_without  http2           # HTTP/2.0 support (nghttp2 based)
10 %bcond_without  metalink        # metalink support
11 %if "%{pld_release}" != "ac"
12 %bcond_without  ares            # c-ares (asynchronous DNS operations) library support
13 %bcond_without  rtmp            # Real Time Media Protocol support
14 %else
15 %bcond_with     ares            # c-ares (asynchronous DNS operations) library support
16 %bcond_with     rtmp            # Real Time Media Protocol support
17 %endif
18
19 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
20 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
21 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
22 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
23 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
24 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
25 Name:           curl
26 Version:        7.74.0
27 Release:        2
28 License:        MIT-like
29 Group:          Applications/Networking
30 Source0:        https://curl.haxx.se/download/%{name}-%{version}.tar.xz
31 # Source0-md5:  448156d9cd05009b0097b43de639fd34
32 Patch0:         %{name}-ac.patch
33 Patch1:         %{name}-krb5flags.patch
34 URL:            http://curl.haxx.se/
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
38 %{?with_kerberos5:BuildRequires:        heimdal-devel}
39 BuildRequires:  libbrotli-devel >= 1.0.0
40 BuildRequires:  libidn2-devel
41 %{?with_metalink:BuildRequires: libmetalink-devel >= 0.1.0}
42 BuildRequires:  libpsl-devel
43 %{?with_rtmp:BuildRequires:     librtmp-devel}
44 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
45 BuildRequires:  libtool
46 BuildRequires:  nettle-devel
47 %{?with_http2:BuildRequires:    nghttp2-devel >= 1.12.0}
48 %{?with_ldap:BuildRequires:     openldap-devel}
49 BuildRequires:  pkgconfig
50 BuildRequires:  rpm >= 4.4.9-56
51 BuildRequires:  rpmbuild(macros) >= 1.527
52 %if %{with ssl}
53 %if %{with gnutls}
54 BuildRequires:  gnutls-devel >= 3.1.10
55 %else
56 BuildRequires:  openssl-devel >= 1.0.1
57 %endif
58 %endif
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  zlib-devel
61 BuildRequires:  zstd-devel
62 Requires:       %{name}-libs = %{version}-%{release}
63 Obsoletes:      libcurl2
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 cURL is a tool for getting files with URL syntax, supporting FTP,
68 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
69 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
70 cookies, user+password authentication and a busload of other useful
71 tricks. The main use for curl is when you want to get or send files
72 automatically to or from a site using one of the supported protocols.
73
74 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75 Dict servers, using any of the supported protocols. cURL is designed
76 to work without user interaction or any kind of interactivity. cURL
77 offers many useful capabilities, like proxy support, user
78 authentication, FTP upload, HTTP post, and file transfer resume.
79
80 %description -l pl.UTF-8
81 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
82 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
83 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
84 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
85 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
86 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
87 pliki z/na serwer używając jednego z dostępnych protokołów.
88 %{?with_ssl:Ten pakiet obsługuje także SSL.}
89
90 %description -l pt_BR.UTF-8
91 Curl é um cliente para baixar/enviar arquivos de/para servidores
92 usando um dos protocolos suportados. É projetado para funcionar sem a
93 interação do usuário.
94
95 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
96 continuar transferências interrompidas, e mais...
97
98 %description -l ru.UTF-8
99 curl - это клиент с множеством поддерживаемых протоколов для получения
100 файлов с серверов, спроектированный для работы как в неинтерактивном
101 режиме, так и с возможностью диалога с пользователем.
102
103 curl поддерживает много полезных возможностей, среди которых поддержка
104 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
105 POST, восстановление прерванной пересылки и многое другое.
106
107 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
108 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
109 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
110
111 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
112 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
113 в╕дновлення перервано╖ пересилки та багато ╕ншого.
114
115 %package libs
116 Summary:        curl library
117 Summary(pl.UTF-8):      Biblioteka curl
118 Group:          Libraries
119 %{?with_ares:Requires:  c-ares >= 1.7.0}
120 %{?with_gnutls:Requires:        gnutls-libs >= 3.1.10}
121 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
122 %{?with_http2:Requires: nghttp2-libs >= 1.12.0}
123 %if %{with ssl} && %{without gnutls}
124 Requires:       libbrotli >= 1.0.0
125 Requires:       openssl >= 1.0.1
126 %endif
127 Suggests:       ca-certificates
128 Conflicts:      ca-certificates < 20080809-4
129
130 %description libs
131 curl library.
132
133 %description libs -l pl.UTF-8
134 Biblioteka curl.
135
136 %package devel
137 Summary:        Header files and development documentation for curl library
138 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
139 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
140 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
141 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
142 Group:          Development/Libraries
143 Requires:       %{name}-libs = %{version}-%{release}
144 %{?with_ares:Requires:  c-ares-devel}
145 %{?with_kerberos5:Requires:     heimdal-devel}
146 Requires:       libbrotli-devel >= 1.0.0
147 Requires:       libidn2-devel
148 Requires:       libpsl-devel
149 %{?with_rtmp:Requires:  librtmp-devel}
150 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
151 %{?with_http2:Requires: nghttp2-devel >= 1.12.0}
152 %{?with_ldap:Requires:  openldap-devel}
153 %if %{with ssl}
154 %if %{with gnutls}
155 Requires:       gnutls-devel >= 3.1.10
156 %else
157 Requires:       openssl-devel >= 0.9.7c
158 %endif
159 %endif
160 Requires:       zlib-devel
161 Requires:       zstd-devel
162 Obsoletes:      libcurl2-devel
163
164 %description devel
165 Header files and development documentation for curl library.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe i dokumentacja do biblioteki curl.
169
170 %description devel -l pt_BR.UTF-8
171 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
172
173 %description devel -l ru.UTF-8
174 Этот пакет содержит файлы, необходимые для разработки программ с
175 использованием библиотеки curl.
176
177 %description devel -l uk.UTF-8
178 Цей пакет містить файли, необхідні для розробки програм з
179 використанням бібліотеки curl.
180
181 %package static
182 Summary:        Static version of curl library
183 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
184 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
185 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
186 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}-%{release}
189
190 %description static
191 Static version of curl library.
192
193 %description static -l pl.UTF-8
194 Statyczna wersja biblioteki curl.
195
196 %description static -l pt_BR.UTF-8
197 Bibliotecas estáticas para desenvolvimento com o curl.
198
199 %description static -l ru.UTF-8
200 Этот пакет содержит статическую библиотеку для разработки программ с
201 использованием библиотеки curl.
202
203 %description static -l uk.UTF-8
204 Цей пакет містить статичну бібліотеку для розробки програм з
205 використанням бібліотеки curl.
206
207 %package -n fish-completion-%{name}
208 Summary:        Fish completion for curl command
209 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla polecenia curl
210 Group:          Applications/Shells
211 Requires:       %{name} = %{version}-%{release}
212 Requires:       fish
213
214 %description -n fish-completion-%{name}
215 Fish completion for curl command.
216
217 %description -n fish-completion-%{name} -l pl.UTF-8
218 Dopełnianie parametrów w fish dla polecenia curl.
219
220 %package -n zsh-completion-curl
221 Summary:        ZSH completion for curl command
222 Summary(pl.UTF-8):      Dopełnianianie parametrów w ZSH dla polecenia curl
223 Group:          Applications/Shells
224 Requires:       %{name} = %{version}-%{release}
225 Requires:       zsh
226
227 %description -n zsh-completion-curl
228 ZSH completion for curl command.
229
230 %description -n zsh-completion-curl -l pl.UTF-8
231 Dopełnianianie parametrów w ZSH dla polecenia curl.
232
233 %prep
234 %setup -q
235 %patch0 -p1
236 %patch1 -p1
237
238 %{__rm} m4/lt*.m4 m4/libtool.m4
239
240 %build
241 %{__libtoolize}
242 %{__aclocal} -I m4
243 %{__autoconf}
244 %{__autoheader}
245 %{__automake}
246 %configure \
247         ac_cv_header_gss_h=no \
248         %{__enable_disable ares} \
249         --enable-ipv6 \
250         %{__enable_disable ldap} \
251         %{__enable_disable ldap ldaps} \
252         --disable-silent-rules \
253 %if %{with ssl}
254         --with-ca-bundle=/etc/certs/ca-certificates.crt \
255 %if %{with gnutls}
256         --with-gnutls --without-ssl \
257 %else
258         --with-ssl=%{_prefix} \
259 %endif
260 %else
261         --without-ssl --without-gnutls \
262 %endif
263         --with-fish-functions-dir=%{fish_compdir} \
264         %{__with_without kerberos5 gssapi %{_prefix}} \
265         %{__with_without metalink libmetalink} \
266         %{__with_without rtmp librtmp} \
267         %{__with_without http2 nghttp2} \
268         %{__with_without ssh libssh2}
269
270 %{__make}
271
272 %install
273 rm -rf $RPM_BUILD_ROOT
274
275 %{__make} install \
276         DESTDIR=$RPM_BUILD_ROOT
277
278 %{__make} -C scripts install \
279         DESTDIR=$RPM_BUILD_ROOT
280
281 # obsoleted by pkg-config
282 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcurl.la
283
284 # no longer in upstream but a lot of apps tries to include it so we create fake one
285 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
286 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
287
288 %clean
289 rm -rf $RPM_BUILD_ROOT
290
291 %post   libs -p /sbin/ldconfig
292 %postun libs -p /sbin/ldconfig
293
294 %files
295 %defattr(644,root,root,755)
296 %doc CHANGES COPYING README docs/{BUGS.md,FAQ,FEATURES.md,HISTORY.md,KNOWN_BUGS,SSLCERTS.md,THANKS,TODO,TheArtOfHttpScripting.md}
297 %attr(755,root,root) %{_bindir}/curl
298 %{_mandir}/man1/curl.1*
299
300 %files libs
301 %defattr(644,root,root,755)
302 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
303 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
304
305 %files devel
306 %defattr(644,root,root,755)
307 %doc docs/{CONTRIBUTE.md,INTERNALS.md}
308 %attr(755,root,root) %{_bindir}/curl-config
309 %attr(755,root,root) %{_libdir}/libcurl.so
310 %{_includedir}/curl
311 %{_pkgconfigdir}/libcurl.pc
312 %{_aclocaldir}/libcurl.m4
313 %{_mandir}/man1/curl-config.1*
314 %{_mandir}/man3/curl_*.3*
315 %{_mandir}/man3/libcurl*.3*
316 %{_mandir}/man3/CURLINFO_*.3*
317 %{_mandir}/man3/CURLOPT_*.3*
318 %{_mandir}/man3/CURLMOPT_*.3*
319
320 %files static
321 %defattr(644,root,root,755)
322 %{_libdir}/libcurl.a
323
324 %files -n fish-completion-%{name}
325 %defattr(644,root,root,755)
326 %{fish_compdir}/%{name}.fish
327
328 %files -n zsh-completion-curl
329 %defattr(644,root,root,755)
330 %{_datadir}/zsh/site-functions/_curl
This page took 0.141807 seconds and 3 git commands to generate.