]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- added config patch (fixes curl-config --version)
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
4 %bcond_without  ssh             # without SSH support
5 %bcond_without  ssl             # without SSL support
6 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
7 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
8 %bcond_without  rtmp            # without Real Time Media Protocol
9 %bcond_without  ldap            # without LDAP support
10
11 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
12 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
13 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
14 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
15 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
16 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
17 Name:           curl
18 Version:        7.21.5
19 Release:        2
20 License:        MIT-like
21 Group:          Applications/Networking
22 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
23 # Source0-md5:  decd5586c2bd0496ca562dc8a7244e24
24 Patch0:         %{name}-no_strip.patch
25 Patch1:         %{name}-ac.patch
26 Patch2:         %{name}-pc.patch
27 Patch3:         %{name}-krb5flags.patch
28 Patch4:         libcurl.fb-changes.diff
29 Patch5:         %{name}-config.patch
30 URL:            http://curl.haxx.se/
31 BuildRequires:  autoconf >= 2.57
32 BuildRequires:  automake
33 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
34 %{?with_kerberos5:BuildRequires:        heimdal-devel}
35 BuildRequires:  libidn-devel >= 0.4.1
36 %{?with_rtmp:BuildRequires:     librtmp-devel}
37 %{?with_ssh:BuildRequires:      libssh2-devel >= 0.16}
38 BuildRequires:  libtool
39 %{?with_ldap:BuildRequires:     openldap-devel}
40 BuildRequires:  pkgconfig
41 %if %{with ssl}
42 %if %{with gnutls}
43 BuildRequires:  gnutls-devel
44 %else
45 BuildRequires:  openssl-devel >= 0.9.7d
46 %endif
47 %endif
48 BuildRequires:  tar >= 1:1.22
49 BuildRequires:  zlib-devel
50 Requires:       %{name}-libs = %{version}-%{release}
51 Requires:       libidn >= 0.4.1
52 %{?with_ssh:Requires:   libssh2 >= 0.16}
53 Requires:       openssl-tools >= 0.9.7d
54 Obsoletes:      libcurl2
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 cURL is a tool for getting files with URL syntax, supporting FTP,
59 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
60 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
61 cookies, user+password authentication and a busload of other useful
62 tricks. The main use for curl is when you want to get or send files
63 automatically to or from a site using one of the supported protocols.
64
65 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
66 Dict servers, using any of the supported protocols. cURL is designed
67 to work without user interaction or any kind of interactivity. cURL
68 offers many useful capabilities, like proxy support, user
69 authentication, FTP upload, HTTP post, and file transfer resume.
70
71 %description -l pl.UTF-8
72 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
73 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
74 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
75 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
76 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
77 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
78 pliki z/na serwer używając jednego z dostępnych protokołów.
79 %{?with_ssl:Ten pakiet obsługuje także SSL.}
80
81 %description -l pt_BR.UTF-8
82 Curl é um cliente para baixar/enviar arquivos de/para servidores
83 usando um dos protocolos suportados. É projetado para funcionar sem a
84 interação do usuário.
85
86 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
87 continuar transferências interrompidas, e mais...
88
89 %description -l ru.UTF-8
90 curl - это клиент с множеством поддерживаемых протоколов для получения
91 файлов с серверов, спроектированный для работы как в неинтерактивном
92 режиме, так и с возможностью диалога с пользователем.
93
94 curl поддерживает много полезных возможностей, среди которых поддержка
95 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
96 POST, восстановление прерванной пересылки и многое другое.
97
98 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
99 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
100 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
101
102 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
103 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
104 в╕дновлення перервано╖ пересилки та багато ╕ншого.
105
106 %package libs
107 Summary:        curl library
108 Summary(pl.UTF-8):      Biblioteka curl
109 Group:          Libraries
110 Suggests:       ca-certificates
111 Conflicts:      ca-certificates < 20080809-4
112 %{?with_ares:Requires:  c-ares >= 1.7.0}
113
114 %description libs
115 curl library.
116
117 %description libs -l pl.UTF-8
118 Biblioteka curl.
119
120 %package devel
121 Summary:        Header files and development documentation for curl library
122 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
123 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
124 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
125 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
126 Group:          Development/Libraries
127 Requires:       %{name}-libs = %{version}-%{release}
128 %{?with_ares:Requires:  c-ares-devel}
129 %{?with_kerberos5:Requires:     heimdal-devel}
130 Requires:       libidn-devel >= 0.4.1
131 %{?with_rtmp:Requires:  librtmp-devel}
132 %{?with_ssh:Requires:   libssh2-devel >= 0.16}
133 %{?with_ldap:Requires:  openldap-devel}
134 %if %{with ssl}
135 %if %{with gnutls}
136 Requires:       gnutls-devel
137 %else
138 Requires:       openssl-devel >= 0.9.7c
139 %endif
140 %endif
141 Requires:       zlib-devel
142 Obsoletes:      libcurl2-devel
143
144 %description devel
145 Header files and development documentation for curl library.
146
147 %description devel -l pl.UTF-8
148 Pliki nagłówkowe i dokumentacja do biblioteki curl.
149
150 %description devel -l pt_BR.UTF-8
151 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
152
153 %description devel -l ru.UTF-8
154 Этот пакет содержит файлы, необходимые для разработки программ с
155 использованием библиотеки curl.
156
157 %description devel -l uk.UTF-8
158 Цей пакет містить файли, необхідні для розробки програм з
159 використанням бібліотеки curl.
160
161 %package static
162 Summary:        Static version of curl library
163 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
164 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
165 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
166 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
167 Group:          Development/Libraries
168 Requires:       %{name}-devel = %{version}-%{release}
169
170 %description static
171 Static version of curl library.
172
173 %description static -l pl.UTF-8
174 Statyczna wersja biblioteki curl.
175
176 %description static -l pt_BR.UTF-8
177 Bibliotecas estáticas para desenvolvimento com o curl.
178
179 %description static -l ru.UTF-8
180 Этот пакет содержит статическую библиотеку для разработки программ с
181 использованием библиотеки curl.
182
183 %description static -l uk.UTF-8
184 Цей пакет містить статичну бібліотеку для розробки програм з
185 використанням бібліотеки curl.
186
187 %prep
188 %setup -q
189 %patch0 -p1
190 %patch1 -p1
191 %patch2 -p1
192 %patch3 -p1
193 %patch4 -p1
194 %patch5 -p1
195
196 %build
197 %{__libtoolize}
198 %{__aclocal} -I m4
199 %{__autoconf}
200 %{__autoheader}
201 %{__automake}
202 %configure \
203         ac_cv_header_gss_h=no \
204 %if %{with ssl}
205         --with-ca-bundle=/etc/certs/ca-certificates.crt \
206 %if %{with gnutls}
207         --with-gnutls --without-ssl \
208 %else
209         --with-ssl=%{_prefix} \
210 %endif
211 %endif
212         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
213         %{?with_rtmp:--with-librtmp} \
214         %{?with_ares:--enable-ares} \
215         %{?with_ldap:--enable-ldaps} \
216         %{!?with_ldap:--disable-ldap} \
217         --enable-ipv6
218
219 %{__make}
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223
224 %{__make} install \
225         DESTDIR=$RPM_BUILD_ROOT
226
227 %clean
228 rm -rf $RPM_BUILD_ROOT
229
230 %post   libs -p /sbin/ldconfig
231 %postun libs -p /sbin/ldconfig
232
233 %files
234 %defattr(644,root,root,755)
235 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
236 %attr(755,root,root) %{_bindir}/curl
237 %{_mandir}/man1/curl.1*
238
239 %files libs
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
242 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
243
244 %files devel
245 %defattr(644,root,root,755)
246 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
247 %attr(755,root,root) %{_bindir}/curl-config
248 %attr(755,root,root) %{_libdir}/libcurl.so
249 %{_libdir}/libcurl.la
250 %{_includedir}/curl
251 %{_pkgconfigdir}/libcurl.pc
252 %{_mandir}/man1/curl-config.1*
253 %{_mandir}/man3/curl_*.3*
254 %{_mandir}/man3/libcurl*.3*
255
256 %files static
257 %defattr(644,root,root,755)
258 %{_libdir}/libcurl.a
This page took 0.09364 seconds and 3 git commands to generate.