]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- updated to 7.28.0
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_without  gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.28.0
25 Release:        1
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  f8a9f99d9db71d8ce1d2c4ccea3c3850
30 Patch1:         %{name}-ac.patch
31 Patch2:         %{name}-pc.patch
32 Patch3:         %{name}-krb5flags.patch
33 URL:            http://curl.haxx.se/
34 BuildRequires:  autoconf >= 2.57
35 BuildRequires:  automake
36 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
37 %{?with_kerberos5:BuildRequires:        heimdal-devel}
38 BuildRequires:  libidn-devel >= 0.4.1
39 %{?with_rtmp:BuildRequires:     librtmp-devel}
40 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
41 BuildRequires:  libtool
42 BuildRequires:  nettle-devel
43 %{?with_ldap:BuildRequires:     openldap-devel}
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpm >= 4.4.9-56
46 BuildRequires:  rpmbuild(macros) >= 1.453
47 %if %{with ssl}
48 %if %{with gnutls}
49 BuildRequires:  gnutls-devel
50 %else
51 BuildRequires:  openssl-devel >= 0.9.7d
52 %endif
53 %endif
54 BuildRequires:  tar >= 1:1.22
55 BuildRequires:  zlib-devel
56 Requires:       %{name}-libs = %{version}-%{release}
57 Requires:       libidn >= 0.4.1
58 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
59 Obsoletes:      libcurl2
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 cURL is a tool for getting files with URL syntax, supporting FTP,
64 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
65 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
66 cookies, user+password authentication and a busload of other useful
67 tricks. The main use for curl is when you want to get or send files
68 automatically to or from a site using one of the supported protocols.
69
70 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
71 Dict servers, using any of the supported protocols. cURL is designed
72 to work without user interaction or any kind of interactivity. cURL
73 offers many useful capabilities, like proxy support, user
74 authentication, FTP upload, HTTP post, and file transfer resume.
75
76 %description -l pl.UTF-8
77 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
78 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
79 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
80 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
81 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
82 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
83 pliki z/na serwer używając jednego z dostępnych protokołów.
84 %{?with_ssl:Ten pakiet obsługuje także SSL.}
85
86 %description -l pt_BR.UTF-8
87 Curl é um cliente para baixar/enviar arquivos de/para servidores
88 usando um dos protocolos suportados. É projetado para funcionar sem a
89 interação do usuário.
90
91 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
92 continuar transferências interrompidas, e mais...
93
94 %description -l ru.UTF-8
95 curl - это клиент с множеством поддерживаемых протоколов для получения
96 файлов с серверов, спроектированный для работы как в неинтерактивном
97 режиме, так и с возможностью диалога с пользователем.
98
99 curl поддерживает много полезных возможностей, среди которых поддержка
100 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
101 POST, восстановление прерванной пересылки и многое другое.
102
103 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
104 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
105 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
106
107 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
108 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
109 в╕дновлення перервано╖ пересилки та багато ╕ншого.
110
111 %package libs
112 Summary:        curl library
113 Summary(pl.UTF-8):      Biblioteka curl
114 Group:          Libraries
115 %{?with_ares:Requires:  c-ares >= 1.7.0}
116 Suggests:       ca-certificates
117 Conflicts:      ca-certificates < 20080809-4
118
119 %description libs
120 curl library.
121
122 %description libs -l pl.UTF-8
123 Biblioteka curl.
124
125 %package devel
126 Summary:        Header files and development documentation for curl library
127 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
128 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
129 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
130 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
131 Group:          Development/Libraries
132 Requires:       %{name}-libs = %{version}-%{release}
133 %{?with_ares:Requires:  c-ares-devel}
134 %{?with_kerberos5:Requires:     heimdal-devel}
135 Requires:       libidn-devel >= 0.4.1
136 %{?with_rtmp:Requires:  librtmp-devel}
137 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
138 %{?with_ldap:Requires:  openldap-devel}
139 %if %{with ssl}
140 %if %{with gnutls}
141 Requires:       gnutls-devel
142 %else
143 Requires:       openssl-devel >= 0.9.7c
144 %endif
145 %endif
146 Requires:       zlib-devel
147 Obsoletes:      libcurl2-devel
148
149 %description devel
150 Header files and development documentation for curl library.
151
152 %description devel -l pl.UTF-8
153 Pliki nagłówkowe i dokumentacja do biblioteki curl.
154
155 %description devel -l pt_BR.UTF-8
156 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
157
158 %description devel -l ru.UTF-8
159 Этот пакет содержит файлы, необходимые для разработки программ с
160 использованием библиотеки curl.
161
162 %description devel -l uk.UTF-8
163 Цей пакет містить файли, необхідні для розробки програм з
164 використанням бібліотеки curl.
165
166 %package static
167 Summary:        Static version of curl library
168 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
169 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
170 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
171 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 Static version of curl library.
177
178 %description static -l pl.UTF-8
179 Statyczna wersja biblioteki curl.
180
181 %description static -l pt_BR.UTF-8
182 Bibliotecas estáticas para desenvolvimento com o curl.
183
184 %description static -l ru.UTF-8
185 Этот пакет содержит статическую библиотеку для разработки программ с
186 использованием библиотеки curl.
187
188 %description static -l uk.UTF-8
189 Цей пакет містить статичну бібліотеку для розробки програм з
190 використанням бібліотеки curl.
191
192 %prep
193 %setup -q
194 %patch1 -p1
195 %patch2 -p1
196 %patch3 -p1
197
198 %{__rm} -v m4/lt*.m4 m4/libtool.m4
199
200 %build
201 %{__libtoolize}
202 %{__aclocal} -I m4
203 %{__autoconf}
204 %{__autoheader}
205 %{__automake}
206 %configure \
207         ac_cv_header_gss_h=no \
208 %if %{with ssl}
209         --with-ca-bundle=/etc/certs/ca-certificates.crt \
210 %if %{with gnutls}
211         --with-gnutls --without-ssl \
212 %else
213         --with-ssl=%{_prefix} \
214 %endif
215 %endif
216         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
217         %{?with_rtmp:--with-librtmp} \
218         %{?with_ares:--enable-ares} \
219         %{?with_ldap:--enable-ldaps} \
220         %{!?with_ldap:--disable-ldap} \
221         --enable-ipv6
222
223 %{__make}
224
225 %install
226 rm -rf $RPM_BUILD_ROOT
227
228 %{__make} install \
229         DESTDIR=$RPM_BUILD_ROOT
230
231 # no longer in upstream but a lot of apps tries to include it so we create fake one
232 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
233 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
234
235 %clean
236 rm -rf $RPM_BUILD_ROOT
237
238 %post   libs -p /sbin/ldconfig
239 %postun libs -p /sbin/ldconfig
240
241 %files
242 %defattr(644,root,root,755)
243 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
244 %attr(755,root,root) %{_bindir}/curl
245 %{_mandir}/man1/curl.1*
246
247 %files libs
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
250 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
251
252 %files devel
253 %defattr(644,root,root,755)
254 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
255 %attr(755,root,root) %{_bindir}/curl-config
256 %attr(755,root,root) %{_libdir}/libcurl.so
257 %{_libdir}/libcurl.la
258 %{_includedir}/curl
259 %{_pkgconfigdir}/libcurl.pc
260 %{_mandir}/man1/curl-config.1*
261 %{_mandir}/man3/curl_*.3*
262 %{_mandir}/man3/libcurl*.3*
263
264 %files static
265 %defattr(644,root,root,755)
266 %{_libdir}/libcurl.a
This page took 0.053958 seconds and 3 git commands to generate.