]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
This commit was manufactured by cvs2git to create tag 'AC-STABLE'.
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_with     ares    # with c-ares (asynchronous DNS operations) library (disables IPv6)
4 %bcond_without  ssl     # without SSL support
5 %bcond_without  heimdal # without HEIMDAL support
6 #
7 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
8 Summary(es):    Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
9 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
10 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
11 Summary(ru):    õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
12 Summary(uk):    õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
13 Name:           curl
14 Version:        7.16.1
15 Release:        2
16 License:        MIT-like
17 Group:          Applications/Networking
18 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
19 # Source0-md5:  acdab0b0467c55e10ed02d2afed80575
20 Patch0:         %{name}-no_strip.patch
21 Patch1:         %{name}-ac.patch
22 Patch2:         %{name}-heimdal.patch
23 URL:            http://curl.haxx.se/
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 %{?with_ares:BuildRequires:     c-ares-devel}
27 %{?with_heimdal:BuildRequires:  heimdal-devel >= 0.7}
28 BuildRequires:  libidn-devel >= 0.4.1
29 BuildRequires:  libtool
30 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
31 BuildRequires:  zlib-devel
32 Requires:       %{name}-libs = %{version}-%{release}
33 Requires:       libidn >= 0.4.1
34 Requires:       openssl-tools >= 0.9.7d
35 Obsoletes:      libcurl2
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 cURL is a tool for getting files with URL syntax, supporting FTP,
40 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
41 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
42 cookies, user+password authentication and a busload of other useful
43 tricks. The main use for curl is when you want to get or send files
44 automatically to or from a site using one of the supported protocols.
45
46 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
47 Dict servers, using any of the supported protocols. cURL is designed
48 to work without user interaction or any kind of interactivity. cURL
49 offers many useful capabilities, like proxy support, user
50 authentication, FTP upload, HTTP post, and file transfer resume.
51
52 %description -l pl
53 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
54 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
55 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
56 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
57 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
58 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
59 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
60 %{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
61
62 %description -l pt_BR
63 Curl é um cliente para baixar/enviar arquivos de/para servidores
64 usando um dos protocolos suportados. É projetado para funcionar sem a
65 interação do usuário.
66
67 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
68 continuar transferências interrompidas, e mais...
69
70 %description -l ru
71 curl - ÜÔÏ ËÌÉÅÎÔ Ó ÍÎÏÖÅÓÔ×ÏÍ ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ÐÒÏÔÏËÏÌÏ× ÄÌÑ ÐÏÌÕÞÅÎÉÑ
72 ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ×, ÓÐÒÏÅËÔÉÒÏ×ÁÎÎÙÊ ÄÌÑ ÒÁÂÏÔÙ ËÁË × ÎÅÉÎÔÅÒÁËÔÉ×ÎÏÍ
73 ÒÅÖÉÍÅ, ÔÁË É Ó ×ÏÚÍÏÖÎÏÓÔØÀ ÄÉÁÌÏÇÁ Ó ÐÏÌØÚÏ×ÁÔÅÌÅÍ.
74
75 curl ÐÏÄÄÅÒÖÉ×ÁÅÔ ÍÎÏÇÏ ÐÏÌÅÚÎÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ, ÓÒÅÄÉ ËÏÔÏÒÙÈ ÐÏÄÄÅÒÖËÁ
76 ÐÒÏËÓÉ, Á×ÔÏÒÉÚÁÃÉÑ ÐÏÌØÚÏ×ÁÔÅÌÑ, ÚÁËÁÞÉ×ÁÎÉÅ ÐÏ FTP, ÐÏÄÄÅÒÖËÁ HTTP
77 POST, ×ÏÓÓÔÁÎÏ×ÌÅÎÉÅ ÐÒÅÒ×ÁÎÎÏÊ ÐÅÒÅÓÙÌËÉ É ÍÎÏÇÏÅ ÄÒÕÇÏÅ.
78
79 curl - ÃÅ Ë̦¤ÎÔ Ú ÂÁÇÁÔØÍÁ Ð¦ÄÔÒÉÍÕ×ÁÎÉÍÉ ÐÒÏÔÏËÏÌÁÍÉ ÄÌÑ ÏÔÒÉÍÁÎÎÑ
80 ÆÁÊ̦נڠÓÅÒ×ÅÒ¦×, ÓÐÒÏÅËÔÏ×ÁÎÉÊ ÄÌÑ ÒÏÂÏÔÉ ÑË × ÎŦÎÔÅÒÁËÔÉ×ÎÏÍÕ
81 ÒÅÖÉͦ, ÔÁË ¦ Ú ÍÏÖÌÉצÓÔÀ Ä¦ÁÌÏÇÕ Ú ËÏÒÉÓÔÕ×ÁÞÅÍ.
82
83 curl Ð¦ÄÔÒÉÍÕ¤ ÂÁÇÁÔÏ ËÏÒÉÓÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ, ÓÅÒÅÄ ÑËÉȠЦÄÔÒÉÍËÁ
84 ÐÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
85 צÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
86
87 %package libs
88 Summary:        curl library
89 Summary(pl):    Biblioteka curl
90 Group:          Libraries
91
92 %description libs
93 curl library.
94
95 %description libs -l pl
96 Biblioteka curl.
97
98 %package devel
99 Summary:        Header files and development documentation for curl library
100 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
101 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
102 Summary(ru):    æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
103 Summary(uk):    æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
104 Group:          Development/Libraries
105 Requires:       %{name}-libs = %{version}-%{release}
106 %{?with_heimdal:Requires:       heimdal-devel}
107 Requires:       libidn-devel >= 0.4.1
108 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
109 Obsoletes:      libcurl2-devel
110
111 %description devel
112 Header files and development documentation for curl library.
113
114 %description devel -l pl
115 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
116
117 %description devel -l pt_BR
118 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
119
120 %description devel -l ru
121 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
122 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
123
124 %description devel -l uk
125 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
126 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
127
128 %package static
129 Summary:        Static version of curl library
130 Summary(pl):    Statyczna wersja biblioteki curl
131 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
132 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
133 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
134 Group:          Development/Libraries
135 Requires:       %{name}-devel = %{version}-%{release}
136
137 %description static
138 Static version of curl library.
139
140 %description static -l pl
141 Statyczna wersja biblioteki curl.
142
143 %description static -l pt_BR
144 Bibliotecas estáticas para desenvolvimento com o curl.
145
146 %description static -l ru
147 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÕÀ ÂÉÂÌÉÏÔÅËÕ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
148 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
149
150 %description static -l uk
151 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞÎՠ¦Â̦ÏÔÅËÕ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
152 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
153
154 %prep
155 %setup -q
156 %patch0 -p1
157 %patch1 -p1
158 %{?with_heimdal:%patch2 -p0}
159
160 %build
161 %{__libtoolize}
162 %{__aclocal}
163 %{__autoconf}
164 %{__autoheader}
165 %{__automake}
166 %configure \
167         %{?with_ssl:--with-ssl=%{_prefix}} \
168         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
169         %{?with_heimdal:--with-gssapi=%{_prefix}} \
170         %{?with_ares:--enable-ares=%{_prefix}} \
171         --%{?with_ares:dis}%{!?with_ares:en}able-ipv6
172
173 %{__make}
174
175 %install
176 rm -rf $RPM_BUILD_ROOT
177
178 %{__make} install \
179         DESTDIR=$RPM_BUILD_ROOT
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %post   libs -p /sbin/ldconfig
185 %postun libs -p /sbin/ldconfig
186
187 %files
188 %defattr(644,root,root,755)
189 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
190 %attr(755,root,root) %{_bindir}/curl
191 %{_mandir}/man1/curl.1*
192
193 %files libs
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
196
197 %files devel
198 %defattr(644,root,root,755)
199 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
200 %attr(755,root,root) %{_bindir}/curl-config
201 %attr(755,root,root) %{_libdir}/libcurl.so
202 %{_libdir}/libcurl.la
203 %{_includedir}/curl
204 %{_pkgconfigdir}/libcurl.pc
205 %{_mandir}/man1/curl-config.1*
206 %{_mandir}/man3/*curl*.3*
207
208 %files static
209 %defattr(644,root,root,755)
210 %{_libdir}/libcurl.a
This page took 0.108142 seconds and 3 git commands to generate.