]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- rel 3
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssl     # without SSL support
4 %bcond_without  heimdal # without HEIMDAL support
5 #
6 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
7 Summary(es):    Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
8 Summary(pl):    Narzêdzie do ¶ci±gania plików z serwerów (FTP, HTTP i innych)
9 Summary(pt_BR): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
10 Summary(ru):    õÔÉÌÉÔÁ ÄÌÑ ÐÏÌÕÞÅÎÉÑ ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ× FTP, HTTP É ÄÒÕÇÉÈ
11 Summary(uk):    õÔÉ̦ÔÁ ÄÌÑ ÏÔÒÉÍÁÎÎÑ ÆÁÊ̦נڠÓÅÒ×ÅҦנFTP, HTTP ÔÁ ¦ÎÛÉÈ
12 Name:           curl
13 Version:        7.15.0
14 Release:        3
15 License:        MIT-like
16 Vendor:         Daniel Stenberg <Daniel.Stenberg@sth.frontec.se>
17 Group:          Applications/Networking
18 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
19 # Source0-md5:  e3b130320d3704af375c097606f49c01
20 Patch0:         %{name}-no_strip.patch
21 Patch1:         %{name}-ac.patch
22 Patch2:         %{name}-heimdal.patch
23 URL:            http://curl.haxx.se/
24 BuildRequires:  autoconf >= 2.57
25 BuildRequires:  automake
26 BuildRequires:  libidn-devel >= 0.4.1
27 %{?with_heimdal:BuildRequires:  heimdal-devel >= 0.7}
28 BuildRequires:  libtool
29 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
30 Requires:       openssl-tools >= 0.9.7d
31 Requires:       libidn >= 0.4.1
32 Requires:       %{name}-libs = %{version}-%{release}
33 Obsoletes:      libcurl2
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 cURL is a tool for getting files with URL syntax, supporting FTP,
38 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
39 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
40 cookies, user+password authentication and a busload of other useful
41 tricks. The main use for curl is when you want to get or send files
42 automatically to or from a site using one of the supported protocols.
43
44 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
45 Dict servers, using any of the supported protocols. cURL is designed
46 to work without user interaction or any kind of interactivity. cURL
47 offers many useful capabilities, like proxy support, user
48 authentication, FTP upload, HTTP post, and file transfer resume.
49
50 %description -l pl
51 cURL jest narzêdziem do ¶ci±gania plików o sk³adni URL. Obs³uguje FTP,
52 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obs³uguje równie¿
53 HTTP POST, HTTP PUT, za³adowywanie (uploading) FTP, za³adowywanie HTTP
54 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
55 u¿ytkownik/has³o oraz wiele innych u¿ytecznych sztuczek. Curla u¿ywa
56 siê g³ównie wtedy, kiedy chce siê automatycznie ¶ci±gn±æ lub wys³aæ
57 pliki z/na serwer u¿ywaj±c jednego z dostêpnych protoko³ów.
58 %{?with_ssl:Ten pakiet obs³uguje tak¿e SSL.}
59
60 %description -l pt_BR
61 Curl é um cliente para baixar/enviar arquivos de/para servidores
62 usando um dos protocolos suportados. É projetado para funcionar sem a
63 interação do usuário.
64
65 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
66 continuar transferências interrompidas, e mais...
67
68 %description -l ru
69 curl - ÜÔÏ ËÌÉÅÎÔ Ó ÍÎÏÖÅÓÔ×ÏÍ ÐÏÄÄÅÒÖÉ×ÁÅÍÙÈ ÐÒÏÔÏËÏÌÏ× ÄÌÑ ÐÏÌÕÞÅÎÉÑ
70 ÆÁÊÌÏ× Ó ÓÅÒ×ÅÒÏ×, ÓÐÒÏÅËÔÉÒÏ×ÁÎÎÙÊ ÄÌÑ ÒÁÂÏÔÙ ËÁË × ÎÅÉÎÔÅÒÁËÔÉ×ÎÏÍ
71 ÒÅÖÉÍÅ, ÔÁË É Ó ×ÏÚÍÏÖÎÏÓÔØÀ ÄÉÁÌÏÇÁ Ó ÐÏÌØÚÏ×ÁÔÅÌÅÍ.
72
73 curl ÐÏÄÄÅÒÖÉ×ÁÅÔ ÍÎÏÇÏ ÐÏÌÅÚÎÙÈ ×ÏÚÍÏÖÎÏÓÔÅÊ, ÓÒÅÄÉ ËÏÔÏÒÙÈ ÐÏÄÄÅÒÖËÁ
74 ÐÒÏËÓÉ, Á×ÔÏÒÉÚÁÃÉÑ ÐÏÌØÚÏ×ÁÔÅÌÑ, ÚÁËÁÞÉ×ÁÎÉÅ ÐÏ FTP, ÐÏÄÄÅÒÖËÁ HTTP
75 POST, ×ÏÓÓÔÁÎÏ×ÌÅÎÉÅ ÐÒÅÒ×ÁÎÎÏÊ ÐÅÒÅÓÙÌËÉ É ÍÎÏÇÏÅ ÄÒÕÇÏÅ.
76
77 curl - ÃÅ Ë̦¤ÎÔ Ú ÂÁÇÁÔØÍÁ Ð¦ÄÔÒÉÍÕ×ÁÎÉÍÉ ÐÒÏÔÏËÏÌÁÍÉ ÄÌÑ ÏÔÒÉÍÁÎÎÑ
78 ÆÁÊ̦נڠÓÅÒ×ÅÒ¦×, ÓÐÒÏÅËÔÏ×ÁÎÉÊ ÄÌÑ ÒÏÂÏÔÉ ÑË × ÎŦÎÔÅÒÁËÔÉ×ÎÏÍÕ
79 ÒÅÖÉͦ, ÔÁË ¦ Ú ÍÏÖÌÉצÓÔÀ Ä¦ÁÌÏÇÕ Ú ËÏÒÉÓÔÕ×ÁÞÅÍ.
80
81 curl Ð¦ÄÔÒÉÍÕ¤ ÂÁÇÁÔÏ ËÏÒÉÓÎÉÈ ÍÏÖÌÉ×ÏÓÔÅÊ, ÓÅÒÅÄ ÑËÉȠЦÄÔÒÉÍËÁ
82 ÐÒÏËÓ¦, Á×ÔÏÒÉÚÁæѠËÏÒÉÓÔÕ×ÁÞÁ, ×¦Ä×ÁÎÔÁÖÅÎÎÑ ÐÏ FTP, HTTP POST,
83 צÄÎÏ×ÌÅÎÎÑ ÐÅÒÅÒ×ÁÎϧ ÐÅÒÅÓÉÌËÉ ÔÁ ÂÁÇÁÔÏ ¦ÎÛÏÇÏ.
84
85 %package devel
86 Summary:        Header files and development documentation for curl library
87 Summary(pl):    Pliki nag³ówkowe i dokumentacja do biblioteki curl
88 Summary(pt_BR): Arquivos de cabeçalho e bibliotecas de desenvolvimento
89 Summary(ru):    æÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
90 Summary(uk):    æÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
91 Group:          Development/Libraries
92 Requires:       %{name}-libs = %{version}-%{release}
93 Requires:       libidn-devel >= 0.4.1
94 %{?with_heimdal:Requires:       heimdal-devel}
95 %{?with_ssl:Requires:   openssl-devel >= 0.9.7c}
96 Obsoletes:      libcurl2-devel
97
98 %description devel
99 Header files and development documentation for curl library.
100
101 %description devel -l pl
102 Pliki nag³ówkowe i dokumentacja do biblioteki curl.
103
104 %description devel -l pt_BR
105 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
106
107 %description devel -l ru
108 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÆÁÊÌÙ, ÎÅÏÂÈÏÄÉÍÙÅ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
109 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
110
111 %description devel -l uk
112 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÆÁÊÌÉ, ÎÅÏÂȦÄΦ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
113 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
114
115 %package libs
116 Summary:        curl library
117 Summary(pl):    Biblioteka curl
118 Group:          Libraries
119
120 %description libs
121 curl library.
122
123 %description libs -l pl
124 Biblioteka curl.
125
126 %package static
127 Summary:        Static version of curl library
128 Summary(pl):    Statyczna wersja biblioteki curl
129 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento com o curl
130 Summary(ru):    óÔÁÔÉÞÅÓËÉÅ ÂÉÂÌÉÏÔÅËÉ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl
131 Summary(uk):    óÔÁÔÉÞΦ Â¦Â̦ÏÔÅËÉ ÄÌÑ ÒÏÚÒÏÂËÉ Ú ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134
135 %description static
136 Static version of curl library.
137
138 %description static -l pl
139 Statyczna wersja biblioteki curl.
140
141 %description static -l pt_BR
142 Bibliotecas estáticas para desenvolvimento com o curl.
143
144 %description static -l ru
145 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÓÔÁÔÉÞÅÓËÕÀ ÂÉÂÌÉÏÔÅËÕ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
146 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ ÂÉÂÌÉÏÔÅËÉ curl.
147
148 %description static -l uk
149 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÓÔÁÔÉÞÎՠ¦Â̦ÏÔÅËÕ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú
150 ×ÉËÏÒÉÓÔÁÎÎÑ͠¦Â̦ÏÔÅËÉ curl.
151
152 %prep
153 %setup -q
154 %patch0 -p1
155 %patch1 -p1
156 %{?with_heimdal:%patch2 -p0}
157
158 %build
159 %{__libtoolize}
160 %{__aclocal}
161 %{__autoconf}
162 %{__autoheader}
163 %{__automake}
164 %configure \
165         %{?with_ssl:--with-ssl=%{_prefix}} \
166         %{?with_ssl:--with-ca-bundle=/usr/share/ssl/ca-bundle.crt} \
167         %{?with_heimdal:--with-gssapi-includes=%{_includedir}} \
168         --with-ipv6
169
170 %{__make}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post   libs -p /sbin/ldconfig
182 %postun libs -p /sbin/ldconfig
183
184 %files
185 %defattr(644,root,root,755)
186 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
187 %attr(755,root,root) %{_bindir}/curl
188 %{_mandir}/man1/curl.1*
189
190 %files devel
191 %defattr(644,root,root,755)
192 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
193 %attr(755,root,root) %{_bindir}/curl-config
194 %attr(755,root,root) %{_libdir}/libcurl.so
195 %{_libdir}/libcurl.la
196 %{_includedir}/curl
197 %{_mandir}/man1/curl-config.1*
198 %{_mandir}/man3/*curl*.3*
199
200 %files libs
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
203
204 %files static
205 %defattr(644,root,root,755)
206 %{_libdir}/libcurl.a
This page took 0.03685 seconds and 3 git commands to generate.