]> git.pld-linux.org Git - packages/curl.git/blob - curl.spec
- up to 7.31.0 - CVE-2013-2174
[packages/curl.git] / curl.spec
1 #
2 # Conditional build:
3 %bcond_without  ssh             # without SSH support
4 %bcond_without  ssl             # without SSL support
5 %bcond_without  kerberos5       # without Heimdal Kerberos 5 support
6 %bcond_without  ldap            # without LDAP support
7 %if "%{pld_release}" != "ac"
8 %bcond_without  ares            # with c-ares (asynchronous DNS operations) library
9 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
10 %bcond_without  rtmp            # without Real Time Media Protocol
11 %else
12 %bcond_with     ares            # with c-ares (asynchronous DNS operations) library
13 %bcond_with     gnutls          # use GnuTLS instead of OpenSSL
14 %bcond_with     rtmp            # without Real Time Media Protocol
15 %endif
16
17 Summary:        A utility for getting files from remote servers (FTP, HTTP, and others)
18 Summary(es.UTF-8):      Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
19 Summary(pl.UTF-8):      Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
20 Summary(pt_BR.UTF-8):   Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
21 Summary(ru.UTF-8):      Утилита для получения файлов с серверов FTP, HTTP и других
22 Summary(uk.UTF-8):      Утиліта для отримання файлів з серверів FTP, HTTP та інших
23 Name:           curl
24 Version:        7.31.0
25 Release:        1
26 License:        MIT-like
27 Group:          Applications/Networking
28 Source0:        http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
29 # Source0-md5:  996c1a5004d96cb4baa3f4e1985058b8
30 Patch0:         %{name}-ac.patch
31 Patch1:         %{name}-krb5flags.patch
32 URL:            http://curl.haxx.se/
33 BuildRequires:  autoconf >= 2.57
34 BuildRequires:  automake
35 %{?with_ares:BuildRequires:     c-ares-devel >= 1.7.0}
36 %{?with_kerberos5:BuildRequires:        heimdal-devel}
37 BuildRequires:  libidn-devel >= 0.4.1
38 %{?with_rtmp:BuildRequires:     librtmp-devel}
39 %{?with_ssh:BuildRequires:      libssh2-devel >= 1.2.8}
40 BuildRequires:  libtool
41 BuildRequires:  nettle-devel
42 %{?with_ldap:BuildRequires:     openldap-devel}
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpm >= 4.4.9-56
45 BuildRequires:  rpmbuild(macros) >= 1.453
46 %if %{with ssl}
47 %if %{with gnutls}
48 BuildRequires:  gnutls-devel
49 %else
50 BuildRequires:  openssl-devel >= 0.9.7d
51 %endif
52 %endif
53 BuildRequires:  tar >= 1:1.22
54 BuildRequires:  zlib-devel
55 Requires:       %{name}-libs = %{version}-%{release}
56 Requires:       libidn >= 0.4.1
57 %{?with_ssh:Requires:   libssh2 >= 1.2.8}
58 Obsoletes:      libcurl2
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %description
62 cURL is a tool for getting files with URL syntax, supporting FTP,
63 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
64 POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
65 cookies, user+password authentication and a busload of other useful
66 tricks. The main use for curl is when you want to get or send files
67 automatically to or from a site using one of the supported protocols.
68
69 cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
70 Dict servers, using any of the supported protocols. cURL is designed
71 to work without user interaction or any kind of interactivity. cURL
72 offers many useful capabilities, like proxy support, user
73 authentication, FTP upload, HTTP post, and file transfer resume.
74
75 %description -l pl.UTF-8
76 cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
77 HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
78 HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
79 oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
80 użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
81 się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
82 pliki z/na serwer używając jednego z dostępnych protokołów.
83 %{?with_ssl:Ten pakiet obsługuje także SSL.}
84
85 %description -l pt_BR.UTF-8
86 Curl é um cliente para baixar/enviar arquivos de/para servidores
87 usando um dos protocolos suportados. É projetado para funcionar sem a
88 interação do usuário.
89
90 Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
91 continuar transferências interrompidas, e mais...
92
93 %description -l ru.UTF-8
94 curl - это клиент с множеством поддерживаемых протоколов для получения
95 файлов с серверов, спроектированный для работы как в неинтерактивном
96 режиме, так и с возможностью диалога с пользователем.
97
98 curl поддерживает много полезных возможностей, среди которых поддержка
99 прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
100 POST, восстановление прерванной пересылки и многое другое.
101
102 curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
103 файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
104 режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
105
106 curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
107 прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
108 в╕дновлення перервано╖ пересилки та багато ╕ншого.
109
110 %package libs
111 Summary:        curl library
112 Summary(pl.UTF-8):      Biblioteka curl
113 Group:          Libraries
114 %{?with_ares:Requires:  c-ares >= 1.7.0}
115 Suggests:       ca-certificates
116 Conflicts:      ca-certificates < 20080809-4
117
118 %description libs
119 curl library.
120
121 %description libs -l pl.UTF-8
122 Biblioteka curl.
123
124 %package devel
125 Summary:        Header files and development documentation for curl library
126 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do biblioteki curl
127 Summary(pt_BR.UTF-8):   Arquivos de cabeçalho e bibliotecas de desenvolvimento
128 Summary(ru.UTF-8):      Файлы для разработки с использованием библиотеки curl
129 Summary(uk.UTF-8):      Файли для розробки з використанням бібліотеки curl
130 Group:          Development/Libraries
131 Requires:       %{name}-libs = %{version}-%{release}
132 %{?with_ares:Requires:  c-ares-devel}
133 %{?with_kerberos5:Requires:     heimdal-devel}
134 Requires:       libidn-devel >= 0.4.1
135 %{?with_rtmp:Requires:  librtmp-devel}
136 %{?with_ssh:Requires:   libssh2-devel >= 1.2.8}
137 %{?with_ldap:Requires:  openldap-devel}
138 %if %{with ssl}
139 %if %{with gnutls}
140 Requires:       gnutls-devel
141 %else
142 Requires:       openssl-devel >= 0.9.7c
143 %endif
144 %endif
145 Requires:       zlib-devel
146 Obsoletes:      libcurl2-devel
147
148 %description devel
149 Header files and development documentation for curl library.
150
151 %description devel -l pl.UTF-8
152 Pliki nagłówkowe i dokumentacja do biblioteki curl.
153
154 %description devel -l pt_BR.UTF-8
155 Arquivos de cabeçalho e bibliotecas de desenvolvimento.
156
157 %description devel -l ru.UTF-8
158 Этот пакет содержит файлы, необходимые для разработки программ с
159 использованием библиотеки curl.
160
161 %description devel -l uk.UTF-8
162 Цей пакет містить файли, необхідні для розробки програм з
163 використанням бібліотеки curl.
164
165 %package static
166 Summary:        Static version of curl library
167 Summary(pl.UTF-8):      Statyczna wersja biblioteki curl
168 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento com o curl
169 Summary(ru.UTF-8):      Статические библиотеки для разработки с использованием библиотеки curl
170 Summary(uk.UTF-8):      Статичні бібліотеки для розробки з використанням бібліотеки curl
171 Group:          Development/Libraries
172 Requires:       %{name}-devel = %{version}-%{release}
173
174 %description static
175 Static version of curl library.
176
177 %description static -l pl.UTF-8
178 Statyczna wersja biblioteki curl.
179
180 %description static -l pt_BR.UTF-8
181 Bibliotecas estáticas para desenvolvimento com o curl.
182
183 %description static -l ru.UTF-8
184 Этот пакет содержит статическую библиотеку для разработки программ с
185 использованием библиотеки curl.
186
187 %description static -l uk.UTF-8
188 Цей пакет містить статичну бібліотеку для розробки програм з
189 використанням бібліотеки curl.
190
191 %prep
192 %setup -q
193 %patch0 -p1
194 %patch1 -p1
195
196 %{__rm} -v m4/lt*.m4 m4/libtool.m4
197
198 %build
199 %{__libtoolize}
200 %{__aclocal} -I m4
201 %{__autoconf}
202 %{__autoheader}
203 %{__automake}
204 %configure \
205         ac_cv_header_gss_h=no \
206 %if %{with ssl}
207         --with-ca-bundle=/etc/certs/ca-certificates.crt \
208 %if %{with gnutls}
209         --with-gnutls --without-ssl \
210 %else
211         --with-ssl=%{_prefix} \
212 %endif
213 %endif
214         %{?with_kerberos5:--with-gssapi=%{_prefix}} \
215         %{?with_rtmp:--with-librtmp} \
216         %{?with_ares:--enable-ares} \
217         %{?with_ldap:--enable-ldaps} \
218         %{!?with_ldap:--disable-ldap} \
219         --enable-ipv6
220
221 %{__make}
222
223 %install
224 rm -rf $RPM_BUILD_ROOT
225
226 %{__make} install \
227         DESTDIR=$RPM_BUILD_ROOT
228
229 # no longer in upstream but a lot of apps tries to include it so we create fake one
230 [ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
231 echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
232
233 %clean
234 rm -rf $RPM_BUILD_ROOT
235
236 %post   libs -p /sbin/ldconfig
237 %postun libs -p /sbin/ldconfig
238
239 %files
240 %defattr(644,root,root,755)
241 %doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
242 %attr(755,root,root) %{_bindir}/curl
243 %{_mandir}/man1/curl.1*
244
245 %files libs
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
248 %attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
249
250 %files devel
251 %defattr(644,root,root,755)
252 %doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
253 %attr(755,root,root) %{_bindir}/curl-config
254 %attr(755,root,root) %{_libdir}/libcurl.so
255 %{_libdir}/libcurl.la
256 %{_includedir}/curl
257 %{_pkgconfigdir}/libcurl.pc
258 %{_mandir}/man1/curl-config.1*
259 %{_mandir}/man3/curl_*.3*
260 %{_mandir}/man3/libcurl*.3*
261
262 %files static
263 %defattr(644,root,root,755)
264 %{_libdir}/libcurl.a
This page took 0.049145 seconds and 3 git commands to generate.