]> git.pld-linux.org Git - packages/curl.git/blame - curl.spec
- updated nghttp2 version
[packages/curl.git] / curl.spec
CommitLineData
195ea5a8
JB
1#
2# Conditional build:
358ad66a
JB
3%bcond_without ssh # SSH support
4%bcond_without ssl # SSL support
5%bcond_with gnutls # GnuTLS instead of OpenSSL
6%bcond_without kerberos5 # Heimdal Kerberos 5 support
7%bcond_without ldap # LDAP support
8%bcond_with http2 # HTTP/2.0 support (nghttp2 based)
9%bcond_without metalink # metalink support
de17b215 10%if "%{pld_release}" != "ac"
358ad66a
JB
11%bcond_without ares # c-ares (asynchronous DNS operations) library support
12%bcond_without rtmp # Real Time Media Protocol support
de17b215 13%else
358ad66a
JB
14%bcond_with ares # c-ares (asynchronous DNS operations) library support
15%bcond_with rtmp # Real Time Media Protocol support
de17b215
ER
16%endif
17
f7f276d9 18Summary: A utility for getting files from remote servers (FTP, HTTP, and others)
ce380d80
ER
19Summary(es.UTF-8): Un cliente para bajar archivos de servidores (FTP, HTTP, y otros)
20Summary(pl.UTF-8): Narzędzie do ściągania plików z serwerów (FTP, HTTP i innych)
21Summary(pt_BR.UTF-8): Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e HTTPS)
22Summary(ru.UTF-8): Утилита для получения файлов с серверов FTP, HTTP и других
23Summary(uk.UTF-8): Утиліта для отримання файлів з серверів FTP, HTTP та інших
5767e1a7 24Name: curl
4b520519 25Version: 7.38.0
d0cec3a8 26Release: 1
c091c0ac 27License: MIT-like
5767e1a7 28Group: Applications/Networking
0307878f 29Source0: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
4b520519 30# Source0-md5: fdafc30cbf0acd2fe6bc31b956b856a5
d0cec3a8
JB
31Patch0: %{name}-ac.patch
32Patch1: %{name}-krb5flags.patch
4557544f 33URL: http://curl.haxx.se/
c091c0ac 34BuildRequires: autoconf >= 2.57
66cf63f1 35BuildRequires: automake
7c7ffb45 36%{?with_ares:BuildRequires: c-ares-devel >= 1.7.0}
f73c4120 37%{?with_kerberos5:BuildRequires: heimdal-devel}
5d94786d 38BuildRequires: libidn-devel >= 0.4.1
a17d9303 39%{?with_metalink:BuildRequires: libmetalink-devel}
9defadab 40%{?with_rtmp:BuildRequires: librtmp-devel}
b83a223e 41%{?with_ssh:BuildRequires: libssh2-devel >= 1.2.8}
c091c0ac 42BuildRequires: libtool
0f90f9c0 43BuildRequires: nettle-devel
d68c2f4d 44%{?with_http2:BuildRequires: nghttp2-devel >= 0.6}
588be88f 45%{?with_ldap:BuildRequires: openldap-devel}
c260acfc 46BuildRequires: pkgconfig
de17b215
ER
47BuildRequires: rpm >= 4.4.9-56
48BuildRequires: rpmbuild(macros) >= 1.453
5559a124
AM
49%if %{with ssl}
50%if %{with gnutls}
51BuildRequires: gnutls-devel
52%else
549c5328 53BuildRequires: openssl-devel >= 1.0.1
5559a124
AM
54%endif
55%endif
d04a5e91 56BuildRequires: tar >= 1:1.22
6903f0dc 57BuildRequires: zlib-devel
3fb47407 58Requires: %{name}-libs = %{version}-%{release}
5d94786d 59Requires: libidn >= 0.4.1
cfa95fc0 60Obsoletes: libcurl2
8aa4e5ec 61BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81714278 62
63%description
655b91ad 64cURL is a tool for getting files with URL syntax, supporting FTP,
65HTTP, HTTPS, GOPHER, TELNET, DICT, FILE and LDAP. cURL supports HTTP
66POST, HTTP PUT, FTP uploading, HTTP form based upload, proxies,
67cookies, user+password authentication and a busload of other useful
68tricks. The main use for curl is when you want to get or send files
69automatically to or from a site using one of the supported protocols.
70
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. cURL is designed
73to work without user interaction or any kind of interactivity. cURL
74offers many useful capabilities, like proxy support, user
e566d906 75authentication, FTP upload, HTTP post, and file transfer resume.
81714278 76
d63bcf1b
JR
77%description -l pl.UTF-8
78cURL jest narzędziem do ściągania plików o składni URL. Obsługuje FTP,
79HTTP, HTTPS, GOPHER, TELNET, DICT, FILE i LDAP. cURL obsługuje również
80HTTP POST, HTTP PUT, załadowywanie (uploading) FTP, załadowywanie HTTP
655b91ad 81oparte na formularzu, serwery proksy, ciasteczka, autoryzacja
d63bcf1b
JR
82użytkownik/hasło oraz wiele innych użytecznych sztuczek. Curla używa
83się głównie wtedy, kiedy chce się automatycznie ściągnąć lub wysłać
84pliki z/na serwer używając jednego z dostępnych protokołów.
85%{?with_ssl:Ten pakiet obsługuje także SSL.}
1310544e 86
d63bcf1b
JR
87%description -l pt_BR.UTF-8
88Curl é um cliente para baixar/enviar arquivos de/para servidores
89usando um dos protocolos suportados. É projetado para funcionar sem a
90interação do usuário.
1310544e 91
d63bcf1b
JR
92Curl trabalha com proxy, autenticação, FTP put, HTTP post, e pode
93continuar transferências interrompidas, e mais...
1310544e 94
d63bcf1b
JR
95%description -l ru.UTF-8
96curl - это клиент с множеством поддерживаемых протоколов для получения
97файлов с серверов, спроектированный для работы как в неинтерактивном
98режиме, так и с возможностью диалога с пользователем.
f05b825f 99
d63bcf1b
JR
100curl поддерживает много полезных возможностей, среди которых поддержка
101прокси, авторизация пользователя, закачивание по FTP, поддержка HTTP
102POST, восстановление прерванной пересылки и многое другое.
f05b825f 103
d63bcf1b
JR
104curl - це кл╕╓нт з багатьма п╕дтримуваними протоколами для отримання
105файл╕в з сервер╕в, спроектований для роботи як в не╕нтерактивному
106режим╕, так ╕ з можлив╕стю д╕алогу з користувачем.
f05b825f 107
d63bcf1b
JR
108curl п╕дтриму╓ багато корисних можливостей, серед яких п╕дтримка
109прокс╕, авторизац╕я користувача, в╕двантаження по FTP, HTTP POST,
110в╕дновлення перервано╖ пересилки та багато ╕ншого.
f05b825f 111
814b6f7d
JB
112%package libs
113Summary: curl library
ce380d80 114Summary(pl.UTF-8): Biblioteka curl
814b6f7d 115Group: Libraries
de17b215 116%{?with_ares:Requires: c-ares >= 1.7.0}
549c5328 117%{?with_ssh:Requires: libssh2 >= 1.2.8}
d68c2f4d 118%{?with_http2:Requires: nghttp2 >= 0.6}
fddc44fa 119%if %{with ssl} && %{without gnutls}
549c5328 120Requires: openssl >= 1.0.1
fddc44fa 121%endif
dfeb0d8d
PG
122Suggests: ca-certificates
123Conflicts: ca-certificates < 20080809-4
814b6f7d
JB
124
125%description libs
126curl library.
127
d63bcf1b 128%description libs -l pl.UTF-8
814b6f7d
JB
129Biblioteka curl.
130
1f54b511 131%package devel
132Summary: Header files and development documentation for curl library
ce380d80
ER
133Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja do biblioteki curl
134Summary(pt_BR.UTF-8): Arquivos de cabeçalho e bibliotecas de desenvolvimento
135Summary(ru.UTF-8): Файлы для разработки с использованием библиотеки curl
136Summary(uk.UTF-8): Файли для розробки з використанням бібліотеки curl
1f54b511 137Group: Development/Libraries
3fb47407 138Requires: %{name}-libs = %{version}-%{release}
bd2c841c 139%{?with_ares:Requires: c-ares-devel}
f73c4120 140%{?with_kerberos5:Requires: heimdal-devel}
5d94786d 141Requires: libidn-devel >= 0.4.1
70778617 142%{?with_rtmp:Requires: librtmp-devel}
b83a223e 143%{?with_ssh:Requires: libssh2-devel >= 1.2.8}
d68c2f4d 144%{?with_http2:Requires: nghttp2-devel >= 0.6}
588be88f 145%{?with_ldap:Requires: openldap-devel}
5559a124
AM
146%if %{with ssl}
147%if %{with gnutls}
148Requires: gnutls-devel
149%else
150Requires: openssl-devel >= 0.9.7c
151%endif
152%endif
5e1699d5 153Requires: zlib-devel
cfa95fc0 154Obsoletes: libcurl2-devel
1f54b511 155
156%description devel
157Header files and development documentation for curl library.
158
d63bcf1b
JR
159%description devel -l pl.UTF-8
160Pliki nagłówkowe i dokumentacja do biblioteki curl.
cec38cdf 161
d63bcf1b
JR
162%description devel -l pt_BR.UTF-8
163Arquivos de cabeçalho e bibliotecas de desenvolvimento.
1310544e 164
d63bcf1b
JR
165%description devel -l ru.UTF-8
166Этот пакет содержит файлы, необходимые для разработки программ с
167использованием библиотеки curl.
f05b825f 168
d63bcf1b
JR
169%description devel -l uk.UTF-8
170Цей пакет містить файли, необхідні для розробки програм з
171використанням бібліотеки curl.
f05b825f 172
1f54b511 173%package static
174Summary: Static version of curl library
ce380d80
ER
175Summary(pl.UTF-8): Statyczna wersja biblioteki curl
176Summary(pt_BR.UTF-8): Bibliotecas estáticas para desenvolvimento com o curl
177Summary(ru.UTF-8): Статические библиотеки для разработки с использованием библиотеки curl
178Summary(uk.UTF-8): Статичні бібліотеки для розробки з використанням бібліотеки curl
1f54b511 179Group: Development/Libraries
6e6a5186 180Requires: %{name}-devel = %{version}-%{release}
1f54b511 181
182%description static
d06d2fe1 183Static version of curl library.
1f54b511 184
d63bcf1b 185%description static -l pl.UTF-8
cec38cdf 186Statyczna wersja biblioteki curl.
b73e2a73 187
d63bcf1b
JR
188%description static -l pt_BR.UTF-8
189Bibliotecas estáticas para desenvolvimento com o curl.
1310544e 190
d63bcf1b
JR
191%description static -l ru.UTF-8
192Этот пакет содержит статическую библиотеку для разработки программ с
193использованием библиотеки curl.
f05b825f 194
d63bcf1b
JR
195%description static -l uk.UTF-8
196Цей пакет містить статичну бібліотеку для розробки програм з
197використанням бібліотеки curl.
f05b825f 198
81714278 199%prep
13caa23a 200%setup -q
d0cec3a8 201%patch0 -p1
d4dc980e 202%patch1 -p1
81714278 203
358ad66a 204%{__rm} m4/lt*.m4 m4/libtool.m4
36cd7270 205
81714278 206%build
c091c0ac 207%{__libtoolize}
03613829 208%{__aclocal} -I m4
d4dc980e
AM
209%{__autoconf}
210%{__autoheader}
c091c0ac 211%{__automake}
e566d906 212%configure \
ef822e11 213 ac_cv_header_gss_h=no \
5559a124 214%if %{with ssl}
03613829 215 --with-ca-bundle=/etc/certs/ca-certificates.crt \
5559a124 216%if %{with gnutls}
28c87603 217 --with-gnutls --without-ssl \
5559a124
AM
218%else
219 --with-ssl=%{_prefix} \
220%endif
221%endif
7d46ac1d 222 %{?with_kerberos5:--with-gssapi=%{_prefix}} \
a17d9303 223 %{?with_metalink:--with-libmetalink} \
2ea4eb23
JB
224 %{?with_rtmp:--with-librtmp} \
225 %{?with_http2:--with-nghttp2} \
28c87603 226 %{?with_ares:--enable-ares} \
2ea4eb23
JB
227 --enable-ipv6 \
228 %{!?with_ldap:--disable-ldap}%{?with_ldap:--enable-ldaps}
a436679a 229
c2167492 230%{__make}
81714278 231
232%install
5767e1a7 233rm -rf $RPM_BUILD_ROOT
56f17d66
AM
234%{__make} install \
235 DESTDIR=$RPM_BUILD_ROOT
236
34ca770a 237# no longer in upstream but a lot of apps tries to include it so we create fake one
925b36ff
AM
238[ -e $RPM_BUILD_ROOT%{_includedir}/curl/types.h ] && exit 1
239echo '#warning curl/types.h IS OBSOLETE FROM 2004. STOP USING IT' > $RPM_BUILD_ROOT%{_includedir}/curl/types.h
34ca770a 240
81714278 241%clean
242rm -rf $RPM_BUILD_ROOT
81714278 243
3fb47407
ER
244%post libs -p /sbin/ldconfig
245%postun libs -p /sbin/ldconfig
1f54b511 246
81714278 247%files
5767e1a7 248%defattr(644,root,root,755)
c091c0ac
JB
249%doc CHANGES COPYING README docs/{BUGS,FAQ,FEATURES,HISTORY,KNOWN_BUGS,MANUAL,SSLCERTS,THANKS,TODO,TheArtOfHttpScripting}
250%attr(755,root,root) %{_bindir}/curl
c091c0ac 251%{_mandir}/man1/curl.1*
1f54b511 252
814b6f7d
JB
253%files libs
254%defattr(644,root,root,755)
255%attr(755,root,root) %{_libdir}/libcurl.so.*.*.*
b3964ccb 256%attr(755,root,root) %ghost %{_libdir}/libcurl.so.4
814b6f7d 257
1f54b511 258%files devel
259%defattr(644,root,root,755)
c091c0ac
JB
260%doc docs/{CONTRIBUTE,INTERNALS,LICENSE-MIXING,RESOURCES}
261%attr(755,root,root) %{_bindir}/curl-config
262%attr(755,root,root) %{_libdir}/libcurl.so
263%{_libdir}/libcurl.la
264%{_includedir}/curl
8ad78925 265%{_pkgconfigdir}/libcurl.pc
1399f3ff 266%{_aclocaldir}/libcurl.m4
c091c0ac 267%{_mandir}/man1/curl-config.1*
b3964ccb
JB
268%{_mandir}/man3/curl_*.3*
269%{_mandir}/man3/libcurl*.3*
67744768 270%{_mandir}/man3/CURLOPT_*.3*
1f54b511 271
272%files static
273%defattr(644,root,root,755)
c091c0ac 274%{_libdir}/libcurl.a
This page took 0.111194 seconds and 4 git commands to generate.